teamviewer.com link icon
or
Ask The Community

TeamViewer does not load on Mac OS Mojave (10.14.6)

TeamViewer doesn't load on mac os mojave, but it runs in the background when I open my Activity Monitor and search for this program.

I installed the correct Mac OS TeamViewer download, installed it, clicked the application icon, but the application will not load properly. The icon jumps up and down, turns off and does not load.

It used to work, so I'm not sure why it stopped. I tried uninstalling and re-installing the application, but that didn't help. What's weird is after I searched for TeamViewer in my Activity Monitor, it shows TeamViewer running or at least some TeamViewer script running in the background, but it's not the actual application. I think it's an issue with their app, not my computer. I'm happy to trouble shoot with TeamViewer, but they make it hard to create a technical support ticket on their website, so I'm writing here to the community for assistance.

Tagged:

Comments

  • Ying_QYing_Q Posts: 853

    Hi @j-mac,

    Thank you for posting.

    Can you kindly follow the steps from How do I uninstall TeamViewer on my Mac? to uninstall the current TeamViewer client, then Download TeamViewer again please.

    If there is any error message shows during installation, kindly send it with your reply please.

    Regards

    Ying_Q   

     

    Chinese Community Moderator [on leave]
  • I also tried to install TV on my Macbook Air MacOS Mojave and whilst it installs successfully it will not run. It asks me again to install a new helper tool then crashes and repeats the same request. Can you help me please?

Sign In or Register to comment.