teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Haven't received trusted device email or password change email

I'm not receiving the "new trusted device" or password change emails for a few days now, please help

 

 

Best Answers

«1

Answers

  • Anyone? This is getting ridiculous, it's been almost a week, still not getting the emails.

    Nothing in my spam folder, getting emails from anyone else works fine. Teamviewer just isn't sending them to me, how do I solve this and be able to access my account again?

  • Still nothing, it's been about 10 days now. 

    I'll never pay to use this software commercially if it doesn't work correctly. Unbelieveable. I won't be recommending TeamViewer to anyone anymore.

  • I've been trying to change the account email address but haven't had any email verification email come through - any suggestions?

  • Will this work for verifying a new email address for my account too?

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @chrisarmstrong

    they are two different paths. The common part is that you do not receive emails from TeamViewer and the first check to be performed and the verification of the possibility of receiving mail from the sender I have indicated.

    The suggestion given above applies only to accounts already confirmed that need to ensure the reliability of a device.

    In your case it is your account not yet recognized, so you could not even authenticate via browser.

    So NO, but try to visit https://login.teamviewer.com. Starting from your username (email) you'll find a way to re-send the TeamViewer Account - Email Validation

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • KlausiMaus
    KlausiMaus Posts: 2

    Hi, I have the same problem, I do not receive email from TV anymore.
    It was working perfect in the past, now I want to add a new computer or just want to register my browser - I never receive any registration email!

    Mybe some ckeck my email account - thanks

  • I use TeamViewer Business Subscription. My account is [email address removed by moderator per community guidelines]

    I am not receiving trusting device e-mails.

    So, i cant open management console, i cant login into comunity under my account...

    Please, HELP!!

     

  • RayneFall
    RayneFall Posts: 2

    I also have been having issues with receiving emails for the past 4 days.  I cannot verify my new laptop as a trusted device, log into the teamviewer website, or reset my password due to no emails from TeamViewer being received in my linked email account.  I have checked the spam folder as well as filtering settings (which to be honest was probably unnecessary since I've always had no issues recieving TeamViewer's emails before).  Anyone have any updates as to how to fix this issue or when a solution might arise?

    Thanks,

    EDIT: I literially had to create a new TeamViewer account to even post this.

  • RayneFall
    RayneFall Posts: 2
    The wonderful community managers here on the TeamViewer community were able to quickly fix my issue. Thanks a ton!
  • Can someone help me with this. I tried registering a new device but I dont get any email of the trusted device. [personal information removed by moderator] .

    Can someone help me ASAP!

  • "In any case, you still have the possibility to indirectly qualify the device as recognized: using your current machine -> open TV client -> Connection menu -> Open Management console. A browser instance will open, so log into then your client will be trusted."

    No, because your browser must be trusted first, otherwise you're stuck!

  • SKChua
    SKChua Posts: 2

    Same issue for me! Tried selecting "Resend activation E-mail" for a few times and changing email address but no validation email is received till now. 

    Kindly assist to whitelist my email in your SMTP server. Tks in advance! 

     

    Account activation required

    Your account using the E-Mail address "[email protected]" is not activated yet.
    Please choose how you want to continue.

    • Resend activation E-Mail
    • Ignore and continue this time
    • Change E-Mail address
    • The activation link will be resent to "[email protected]".
    • Please make sure the E-Mail address is correct and E-Mails from teamviewer.com are not classified as spam.
     

     

  • AFDF
    AFDF Posts: 1

    Hello,

     

    I am having the same problem! I am not receiving the email to reset the password and I had to create a new account to write in the community...can anyone help?

     

     

  • How do you get anyone to whitelist email account, does a problem ticket have to be raised?

    I am a free account user.
  • rickg72
    rickg72 Posts: 1

    reset emails were not coming to my Outlook inbox.  I had to login to my att.net account via chrome browser to see the reset link.

  • Linden
    Linden Posts: 1

    im in the same boat... not receiving email to verify

  • MrJohn
    MrJohn Posts: 4

    How can this be labeled as a "solution"? So many users, INCLUDING ME, have the same problem and it has been going on like this for quite some time. I don't appreciate an extra layer of security that keeps me from my own account.

  • MrJohn
    MrJohn Posts: 4

    I certainly am not alone in this and that only means that TeamViewer is dropping the ball. I am on my 3rd (THIRD!) new account to even get in here to research this problem. If I am correct, TeamViewer needs to whitelist my email address. Really?

    Could someone contact me so I can resolve this? I know it's free and I really really really love it but if I can't use it, then what? 

  • MR4
    MR4 Posts: 1

    We are in a similar situation. We have a corporate license and two of the user accounts we have setup are not recieving emails at all. 

    One of these accounts has not recieved any emails since it was created.

    When trying to change the email address of a second account no confirmation email has been sent to the new address.

    How can we get these accoumnts working again?

     

  • rnrfree
    rnrfree Posts: 3

    I need to log into my business profile to make some changes, and discovered I cannot logon anymore. The login form displays the message about Trusted Device (not sure what this is about, since the device I am trying to log in is the very device I ordered the product and primary use it). 
    Anyways, the activation email does not arrive at all.

    Submitting this ticket is another ordeal, since you cannot submit one - and neither a community question, it seems - without logging on, which kind of defeats the purpose since the logon is the thing not working.

    I had to create this free account - on the same domain, rocknowradio.ro - to be able to ask at least this question. 

    Someone from TV support, please, contact me privately or using this account's email (I will not post publicly the real business email and the TeamViewer ID). Reading thru other similar sounding issues, it looks like the email gets blacklisted somehow and they are not sent, so, TV support: please contact me to reply with the real email and check the outgoing email logs after.

    Thanks, 
    Cristian A.

  • rnrfree
    rnrfree Posts: 3

    Why is this a solution?

  • MrJohn
    MrJohn Posts: 4

    I don't know why TeamViewer is totally ignoring this issue. There has never been a solution published. It appears that they blacklist a domain or email address and there is no way to clear the path. Creating new accounts just to game the system is not the answer. I feel your pain, rnrfree, I've been battling this for years and years. I have NEVER recieved a response from them.

  • MrJohn
    MrJohn Posts: 4

    Maybe TeamViewer's dictionaries define "solution" different than the rest of the world. I haven't seen a "solution" from them yet.


    @rnrfree wrote:

    Why is this a solution?


     

  • rnrfree
    rnrfree Posts: 3

    I don't know either, but I will return the product and ask for a refund if they will not answer. I am planning to wait for one more week.

  • emin911
    emin911 Posts: 1

    I too am having this issue, please get this resolved ASAP. We are a company and we rely on teamviewer for our company. We risk losing business.

     

  • blondcb
    blondcb Posts: 1

    I too am having this same issue for my 90 year old mother's machine and account. Who can help?

  • MeriMiettinen
    MeriMiettinen Posts: 1 Newbie

    Same problem with one account at the start of 2021 (we had to create a new account with an alias email address so it was different). Now the same problem again with another new user in the company I created last week. Email address is correct but no emails are sent (I checked mail server too).

  • AlexNotA_BOT
    AlexNotA_BOT Posts: 1 Newbie
    edited July 11