teamviewer.com link icon
or
Ask The Community

TeamViewer 11 in Linux Mint 19 Xfce

A preliminary search has not shown me a solution to my current problem: I need to install TeamViewer 11 on Linux Mint Xfce 19, 64-bit. The regular install instructions have never worked, on account of TeamViewer needing the libpng12-0 package in i386 architecture. I'm thinking it also needs wine-stable? I tried installing those packages first, and it recognized that I had installed the libpng12-0:i386 package, but when I try to start TeamViewer, nothing happens. Could the TeamViewer team please update the instructions for installing TeamViewer so that it's painless on Linux? What am I missing to finish the install on my machine?

 

Thanks for your time!

Best Answer

Answers

  • The libpng package required by old versions of Teamviewer is no longer in Ubuntu repositories.  I got it from here:

    http://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_i386.deb

    And installed it by doing

    sudo dpkg -i ./libpng12-0_1.2.50-2+deb8u3_i386.deb

    See if that helps.

  • @emptythevoid: Maybe you didn't read my post, or I wasn't very clear. I already installed that exact package exactly the way you said, and it didn't help. I need further ideas, I'm afraid.

  • Ah, sorry, I was a bit hasty.

    I'm spinning up a Linux Mint 19 XFCE VM right now.  If you try to launch Teamviewer from the command line, do you get any error messages?

  • I get the following:

     

    Init...

    XRandRWait: No value set. Using default.

    XRandRWait: Started by user.

    Checking setup...

    Launching TeamViewer ...

    Launching TeamViewer GUI ...

    Then I get my prompt back, and nothing else happens. I don't see TeamViewer come up.

  • Do you recall if you installed the 64-bit-only version, or the 32-bit/64-bit multiarch version?

  • That worked, oh joy! I got all the way in, and was able to TeamViewer into another of my computers. Thanks so much!

  • Only one issue: the libpgp-error0:i386 has no install candidate. This doesn't seem to prevent the install from going through, however.
  • Thanks for getting back! It's made my day that I was able to help.

    Let me investigate that pgp package.  Maybe I had a typo.

    Edit: Yep.  It's supposed to be libgpg-error0:i386  Whoopsie.  I'll update my notes. Thanks for pointing it out.

  • Thanks you!!!

    It helped me a lot. I was stucked for two days trying to run TV11 on my linuxmint 19.

  • @MasterDLI wrote:
    Thanks you!!!

    It helped me a lot. I was stucked for two days trying to run TV11 on my linuxmint 19.

    Excellent!  Glad to hear it helped! That makes my day :D

  • This worked for Teamviewer 12 i386 on Linux Mint 19 Cinnamon. Thank you.
  • Hey, just wanted you to know that your pastebin solution also works in Xubuntu 18.04. I've switched to this distro on account of Lambda Labs Stack, which makes machine learning package installation a breeze. Thanks again!
  • I'm really glad to hear that fixed it for you! That makes my day!

  • It's not possible to install procedure nr 7 (wget http://security.ubuntu.com/ubuntu/pool/main/f/freetype/libfreetype6_2.6.1-0.1ubuntu2.3_i386.deb), it gives a 404 not found error. Where to find this package? Thank you very much in advance. Without this, seems I can't continue with the installation.

  • dallas87dallas87 Posts: 1

    Here is the updated link

    http://security.ubuntu.com/ubuntu/pool/main/f/freetype/libfreetype6_2.6.1-0.1ubuntu2.4_i386.deb

    Step 8 on pastebin should be

    8.)  ar -x ./libfreetype6_2.6.1-0.1ubuntu2.4_i386.deb

    This is how I got it to run on Linux Mint 19

Sign In or Register to comment.