Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Henagon

TeamViever v14 last, uses 50% of my i7 CPU

Why ?

Windows 10. TeamViever v14.2.2.2558
I not connected to remote computers, but now my i7 CPU at 4.2ghz is used by 50% ??????

What are you doing on my computer ?

14 Replies
14 Replies
Highlighted
Posted by
Photon

Re: TeamViever v14 last, uses 50% of my i7 CPU

This is happening to me as well on three seperate computers. Also noticed "Service Host:Local Session Manager" is also running high CPU pegging my CPU at 100%... When Teamviewer is forced closed, that Service Host drops to under 1%.

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Yes, for me also "Service Host:Local Session Manager" is using ~50% of CPU with TW.
in total ~100%

When click Exit from TeamViever menu - program didn't exit from Process Manager, it still used my cpu.

I had to manally "Stop Process" ..

Highlighted
Posted by
Digon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Same problem, same CPU. TeamViewer service returns to runaway status after restart, also.

Highlighted
Posted by
Digon

FIXED! - RE: TeamViever v14 last, uses 50% of my i7 CPU

Uninstalling the TeamViewer Windows Store app stopped the runaway TV service on my laptop. I had both TV Desktop & TV app installed for a long time without any issues until this latest TV Desktop update.

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

I also have this issue. Same Teamviewer version, but with an i5-4440 processor. I have never had the windows store version installed.

Highlighted
Posted by
Digon

Re: FIXED! - RE: TeamViever v14 last, uses 50% of my i7 CPU

Unfortunately uninstalling the TV app didn't fix the TV service runaway.

Yesterday I also uninstalled TV desktop app, restarted and reinstalled TV desktop. This morning the runaway TV service problem is back.

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Was also having the same problem, fixed it by uninstalling with remove settings, restart, reinstall. Seems to be working well even after a restart

Highlighted
Posted by
Digon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Thanks for the idea, AdmiralAR1. Unfortunately, your solution didn't work for me. I tried uninstall with "remove settings," rebooted, reinstalled TV desktop, and just 30 mins ago TV service went wild, again. I went to Services, shut it down and set it to manual start. UGH!

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Hi!

Me too.

Dell Inspiron i7-6700HQ going from 100% cpu to 6% after stopping Teamviewer 14 Service.

Please advise.

Thanks.

Highlighted
Posted by
Digon

Re: TeamViever v14 last, uses 50% of my i7 CPU

I've also learned that the runaway occurs even without the TV SERVICE running, just the TV Desktop (not Windows AppStore) app. Yesterday, I quit TV app & stoppped service, disabled the TV service, restarted TV app running (and logged in to my TV account), and found it, again, went runaway after some time (don't know how long).

Highlighted
Posted by
Electron

Re: TeamViever v14 last, uses 50% of my i7 CPU

Same on Surface Go.

Eat 100% CPU.

Highlighted
Posted by
Digon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Same here multiple PCs **bleep** are they doing with TV14 im about to just uninstall it from everyone and downgrade back to 12....

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

same here on mac os mojave

Highlighted
Posted by
Henagon

Re: TeamViever v14 last, uses 50% of my i7 CPU

Mee too. Local Session Manager spikes the CPU. Closing TeamViewer drops CPU usage to normal.