Posted by asil
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Works fine

Posted by bhoth
Digon

Re: Not ready. Please check your connection after upgrade to v12

I changed the sleep 60 to 15 and it still works for me.

Thank you!

Posted by zezar98
Proton

Re: Not ready. Please check your connection after upgrade to v12

I had the same problem on Debian Linux and solved it by disabling ipv6. I ran the following commands

/etc/init.d/teamviewerd stop

sysctl -w net.ipv6.conf.all.disable_ipv6=1


sysctl -w net.ipv6.conf.default.disable_ipv6=1

sysctl -w net.ipv6.conf.lo.disable_ipv6=1


/etc/init.d/teamviewerd start

 

Posted by Ales
Digon

Re: Not ready. Please check your connection after upgrade to v12

I can't get it work no matter what I do. I tried even tar.xz version without installation. Nothing helped.

  • My OS is Kubuntu 17.04, TeamViewer version is 12.0.76279 wine-1.6.
  • I have internet connection allright. I can connect TeamViewer on my Android device on the same wifi router just fine so it has to be something with the client on the computer not internet connection or router.
  • I can ping master1.teamviewer.com (master2, master3, master4).
  • I have ipv6 disabled (cat /proc/sys/net/ipv6/conf/all/disable_ipv6 says 1).
  • I tried stopping and starting teamviewer service several times.
  • I tried complete uninstall + removing /etc/teamviewer and installing again.
  • I tried editing /etc/nsswitch.conf (+ mdns4) and /etc/systemd/system/teamviewerd.service (delayed start) even with complete reboot (which is embarrassing).
  • I tried running it using wine 1.8.7 (as suggested by izacki above). It starts fine but still says "Not ready. Please check your connection".
  • I tried also old version 11.0.67687 downloaded from https://www.teamviewer.com/en/download/previous-versions/ with the same result - not ready.
  • I checked logs in /home/user/.local/share/teamviewer12/logfiles/ but I don't see anything helpful.

Finally when I stopped the teamviewer.service and launched portable version (no daemon) I found something in logfiles/TeamViewer12_Logfile.log. But I don't know what to do about it.

2017/04/29 23:38:06.702  2031 4118616896 NX0   Activating Router carrier
2017/04/29 23:38:06.703  2031 4135402304 NX0!!!CTcpConnectionBase[5]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: asio.netdb:2, Errorcode=11
2017/04/29 23:38:06.703  2031 4135402304 NX0   Activating Router carrier
2017/04/29 23:38:06.707  2031 4127009600 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com, Errorcode=11
2017/04/29 23:38:06.707  2031 4127009600 NX0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0, Errorcode=11
2017/04/29 23:38:06.707  2031 4127009600 NX0!! NetWatchdog: Port 443 proxy search failed! No working setting found., Errorcode=11
2017/04/29 23:38:06.707  2031 4127009600 NX0   Activating Router carrier
2017/04/29 23:38:06.710  2031 4127009600 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/04/29 23:38:06.711  2031 4127009600 NX0!! NetWatchdog: Port 80 proxy search failed! No working setting found.
2017/04/29 23:38:06.711  2031 4127009600 NX0!  CKeepAliveClientClient::HandlePing(): ping failed
2017/04/29 23:38:06.711  2031 4127009600 NX0   Activating Router carrier
2017/04/29 23:38:06.711  2031 4127009600 NX0   CProcessCommandHandlerMasterConnect[8]::CreateMasterConnect(): master16.teamviewer.com:80, Connection 8, proxy=''
2017/04/29 23:38:06.713  2031 4118616896 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve proxy name (5), Could not resolve proxy: master16.teamviewer.com
2017/04/29 23:38:06.714  2031 4118616896 NX0!  CProcessCommandHandlerMasterConnect[8]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/04/29 23:38:06.714  2031 4118616896 NX0!! LookUpDNS failed for master16.teamviewer.com, socket error = -3, Errorcode=11
2017/04/29 23:38:06.714  2031 4118616896 NX0!!!Connect to Master master16.teamviewer.com /  failed!, Errorcode=11
2017/04/29 23:38:06.714  2031 4118616896 NX0!! CMasterConnectorAsio::HandleMasterResponseRegister(): MasterConnect failed. ErrorCode=10, Errorcode=11
2017/04/29 23:38:09.715  2031 4127009600 NX0   Activating Router carrier
2017/04/29 23:38:09.716  2031 4118616896 NX0!!!CTcpConnectionBase[9]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: asio.netdb:2, Errorcode=11
2017/04/29 23:38:09.716  2031 4118616896 NX0   Activating Router carrier
2017/04/29 23:38:09.719  2031 4127009600 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/04/29 23:38:09.719  2031 4127009600 NX0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0
2017/04/29 23:38:09.720  2031 4127009600 NX0!! NetWatchdog: Port 443 proxy search failed! No working setting found.
2017/04/29 23:38:09.720  2031 4127009600 NX0   Activating Router carrier
2017/04/29 23:38:09.723  2031 4143795008 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/04/29 23:38:09.723  2031 4143795008 NX0!! NetWatchdog: Port 80 proxy search failed! No working setting found. -- next log entries will be omitted --
2017/04/29 23:38:09.723  2031 4143795008 NX0!  CKeepAliveClientClient::HandlePing(): ping failed
2017/04/29 23:38:09.724  2031 4143795008 NX0   Activating Router carrier
2017/04/29 23:38:09.724  2031 4143795008 NX0   CProcessCommandHandlerMasterConnect[12]::CreateMasterConnect(): master4.teamviewer.com:80, Connection 12, proxy=''
2017/04/29 23:38:09.728  2031 4143795008 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve proxy name (5), Could not resolve proxy: master4.teamviewer.com
2017/04/29 23:38:09.728  2031 4143795008 NX0!  CProcessCommandHandlerMasterConnect[12]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/04/29 23:38:09.728  2031 4143795008 NX0!! LookUpDNS failed for master4.teamviewer.com, socket error = -3, Errorcode=11
2017/04/29 23:38:09.728  2031 4143795008 NX0!!!Connect to Master master4.teamviewer.com /  failed!, Errorcode=11
2017/04/29 23:38:09.728  2031 4143795008 NX0!! CMasterConnectorAsio::HandleMasterResponseRegister(): MasterConnect failed. ErrorCode=10, Errorcode=11

I'm stuck. Everything else works perfectly - no network issues at all. I think trouble started after updating Kubuntu from 16.10 to 17.04 but I'm not sure. Before that I've been using TeamViewer many times and I never had any problems.

Posted by jrobbo
Electron

Re: Not ready. Please check your connection after upgrade to v12

My problem is exactly the same as reported in the previous post. Team Viewer has stopped working with this issue since upgrading from Kubuntu 16.10 to 17.04. Have tried Teamviewer 11 and 2 versions of TV 12, with the same result. 

Posted by Helmdog
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Same problem here, Teamview doesn't work after Kubuntu 16.10 -> 17.04 upgrade.

I get the message "No connection to TeamViewer server"

Running TeamViewer 12.0.71510

Update: I just purged teamviewer:

sudo apt-get purge teamviewer

Then downloaded teamviewer_12.0.76279_i386.deb and ran it.  Now Teamviewer is working for me.

Posted by Ales
Digon

Re: Not ready. Please check your connection after upgrade to v12

Unfortunately purging didn't work for me.

Posted by photoperitus
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Had this issue on a 2012 server and I had to run this command in cmd as admin

netsh interface tcp set global ecncapability=disabled

Found it on some obscure forum as a solution that teamviewer support had provided someone. Soon as I ran that the ID generated and I was back in business.

This would only apply to Server 2012 and later though I'm pretty sure.

Posted by oiram
Digon

Re: Not ready. Please check your connection after upgrade to v12

After the upgrade from Ubuntu 16.04 to Ubuntu 17.04 I got the same error. I tryed all the suggestions proposed in the replaies but without success. looking at log I saw this error "MachineHooks: Library not found, Errorcode=126" I don't know what means and if this is the problem. Follows a piece of log:

Start: 2017/05/19 10:23:49.142 (UTC+1:00)
Version: 12.0.76279
ID: 0
Loglevel: LogAll (0)
License: 0
Server: master2.teamviewer.com
IC: 0
CPU: x86 Family 6 Model 60 Stepping 3, GenuineIntel
CPU extensions: h9
OS: Lx Ubuntu 17.04 (32-bit)
IP: 192.168.1.5
Proxy-Settings: Type=0 IP= User=
AppPath: C:\TeamViewer\TeamViewer.exe
UserAccount: ryo

2017/05/19 10:23:49.182 8 30 GX0 Win32_GUI::FontReallyExists: 'Segoe UI' found 0 matches.
2017/05/19 10:23:49.182 8 30 GX0 Win32_GUI::FontReallyExists: 'Liberation Sans' found 4 matches.
2017/05/19 10:23:49.186 8 30 GX0 InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
2017/05/19 10:23:49.186 8 30 GX0 Opening local TCP connection to 127.0.0.1:5940
2017/05/19 10:23:49.186 8 30 GX0 Local TCP connection established
2017/05/19 10:23:49.186 8 30 GX0 Process ID: L 3720 / W 8
2017/05/19 10:23:49.277 8 30 GX0 SettingsIPCReception receive a SYNCHRONISE Settings command : UserSettings
2017/05/19 10:23:49.278 8 30 GX0 Received Control_InitIPC_Response processtype=1
2017/05/19 10:23:49.278 8 30 GX0 Received Control_InitIPC_Response runningProcesses=3
2017/05/19 10:23:49.278 8 30 GX0 Control_InitIPC_Response: all processes 3 completely initialized
2017/05/19 10:23:49.312 8 30 GX0 Slave signalized initialization
2017/05/19 10:23:49.312 8 35 GX0 ProxySearch: no PAC script detected via WPAD
2017/05/19 10:23:49.312 8 35 GX0 ProxySearch: no PAC script detected via WPAD
2017/05/19 10:23:49.325 3934 140522844304768 gX0 XSM: Initialised X Session Management (gnome-session, 3.24.0) [13]
2017/05/19 10:23:49.371 3938 4029672256 QX0 SessionBusWatcher: suitable bus found with address "unix:path=/run/user/1000/bus"
2017/05/19 10:23:52.941 8 32 GX0 Slave signalized initialization
2017/05/19 10:23:52.942 8 9 GX0 tvshared::WindowsSessionStateManager::WindowsSessionStateManager(02234150) state 0
2017/05/19 10:23:52.942 8 9 GX0 VoIP: VoIPCentral: Set capturing-device = "", rendering-device = ""
2017/05/19 10:23:52.943 8 9 GX0 MachineID m=0 - 1
2017/05/19 10:23:52.944 8 9 GX0 TVUpdate::Init() Version-URL: download.teamviewer.com/download/update/ Update-URL: download.teamviewer.com/download/update/
2017/05/19 10:23:52.944 3934 140522203117312 gX0 PulseAudio: Connected to server 'unix:/run/user/1000/pulse/native' (protocol version 32, library version 10.0.0
2017/05/19 10:23:52.945 8 9 GX0 TVUpdate::Init() Preview Channel Number : 1
2017/05/19 10:23:52.946 3934 140522640029440 gX0 PulseAudio: Connection established
2017/05/19 10:23:52.946 8 31 GX0 Mixer: Device added: alsa_input.usb-Microsoft_Microsoft___LifeCam_HD-3000-02.analog-mono, LifeCam HD-3000 Analog Mono {247bbd22-89af-5cd3-ba72-1881cdacf8e7}
2017/05/19 10:23:52.946 8 31 GX0 Mixer: Device added: alsa_input.pci-0000_00_1b.0.analog-stereo, Built-in Audio Analog Stereo {4f128769-8fee-5b51-8080-a60fdb1820f7}
2017/05/19 10:23:52.947 8 9 GX0 DynamicPasswordUIModel::ShouldShowDynamicPassword(): dynPw=1 allowIncoming=1 id=0 ka=0 lanAllowed=0 lanOnly=0 networkState=1 showDynPwd=0
2017/05/19 10:23:52.991 8 9 GX0!! MachineHooks: Library not found, Errorcode=126
2017/05/19 10:23:53.093 8 9 GX0 Wine: HwndToWindow 00010058 -> 4e00004
2017/05/19 10:23:53.094 8 9 GX0 ManagerHolderStateMachine: Switching from None to NotReady_LoginPending
2017/05/19 10:23:53.094 8 26 GX0 ChatManager::ChatManager: created
2017/05/19 10:23:53.094 8 26 GX0 ChatManager::Factory: ChatManager created
2017/05/19 10:23:53.094 8 26 GX0 IncomingBetterChatCommandHandler::IncomingBetterChatCommandHandler: created
2017/05/19 10:23:53.094 8 26 GX0 IncomingChatCommandRegistration::Start: registering for ready state properties
2017/05/19 10:23:53.103 8 9 GX0 AccountLoginGUI::CreateLoginKey(): [OnlineState] System is set to Visible.
2017/05/19 10:23:53.109 8 9 GX0 Wine: HwndToWindow 00010058 -> 4e00004
2017/05/19 10:23:53.109 8 9 GX0 Wine: HwndToWindow 000100C6 -> 4e00007
2017/05/19 10:23:53.243 8 9 GX0 CMainWindow::ShouldShowDynamicPassword(): dynPw=1 allowIncoming=1 id=0 ka=0 lanAllowed=0 lanOnly=0 networkState=1 showDynPwd=0
2017/05/19 10:23:53.245 8 9 GX0!! ServerControl: RegisterPowerSettingNotification failed with error 0
2017/05/19 10:23:53.350 8 31 GX0 Mixer: Device added: alsa_input.usb-Microsoft_Microsoft___LifeCam_HD-3000-02.analog-mono, LifeCam HD-3000 Analog Mono {247bbd22-89af-5cd3-ba72-1881cdacf8e7}
2017/05/19 10:23:53.350 8 31 GX0 Mixer: Device added: alsa_input.pci-0000_00_1b.0.analog-stereo, Built-in Audio Analog Stereo {4f128769-8fee-5b51-8080-a60fdb1820f7}
2017/05/19 10:23:53.353 8 39 GX0 VoIP: VoIPCentral: Set capturing-device = "", rendering-device = ""
2017/05/19 10:23:53.373 8 9 GX0!! TVW Wine: SetWindowManagerClassHint: No such window
2017/05/19 10:23:53.373 8 9 GX0!! TVW Wine: SetWindowManagerClassHint: No such window
2017/05/19 10:23:54.041 8 9 GX0 TVW X Error 3 on ???, Req 2.0 (#1889 r81788936): BadWindow (invalid Window parameter)
2017/05/19 10:23:59.535 8 9 GX0!! TVW Wine: HwndToWindow: No such window
2017/05/19 10:23:59.535 8 9 GX0 Wine: HwndToWindow 00000000 -> 0
2017/05/19 10:23:59.535 8 9 GX0 Wine: HwndToWindow 00010058 -> 4e00004
2017/05/19 10:23:59.535 8 9 GX0 Wine: HwndToWindow 000100C6 -> 4e00007
2017/05/19 10:24:02.880 8 9 GX0 TVW X Error 3 on ???, Req 2.0 (#2458 r81788939): BadWindow (invalid Window parameter)
2017/05/19 10:24:02.884 8 31 GX0 Mixer: Device added: alsa_output.pci-0000_00_1b.0.analog-stereo, Built-in Audio Analog Stereo {47a6ec9c-0926-5233-b1a1-d125eb058546}
2017/05/19 10:24:02.884 8 31 GX0 Mixer: Device added: alsa_input.usb-Microsoft_Microsoft___LifeCam_HD-3000-02.analog-mono, LifeCam HD-3000 Analog Mono {247bbd22-89af-5cd3-ba72-1881cdacf8e7}
2017/05/19 10:24:02.885 8 31 GX0 Mixer: Device added: alsa_input.pci-0000_00_1b.0.analog-stereo, Built-in Audio Analog Stereo {4f128769-8fee-5b51-8080-a60fdb1820f7}
2017/05/19 10:24:02.932 8 9 GX0! Direct3D 9 not available.
2017/05/19 10:24:02.932 8 9 GX0!! RenderDeviceWrapper: Failed to activate DirectX rendering.
2017/05/19 10:24:02.932 8 9 GX0 RenderDeviceWrapper: GDI rendering activated.
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 9 on ???, Req 55.0 (#4230 r81788965): BadDrawable (invalid Pixmap or Window parameter)
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 13 on ???, Req 59.0 (#4231 r52430005): BadGC (invalid GC parameter)
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 13 on ???, Req 59.0 (#4232 r52430005): BadGC (invalid GC parameter)
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 13 on ???, Req 56.0 (#4263 r52430005): BadGC (invalid GC parameter)
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 13 on ???, Req 56.0 (#4264 r52430005): BadGC (invalid GC parameter)
2017/05/19 10:24:02.937 8 9 GX0 TVW X Error 13 on ???, Req 60.0 (#4265 r52430005): BadGC (invalid GC parameter)
2017/05/19 10:24:03.615 8 9 GX0!! TVW Wine: SetWindowManagerClassHint: No such window, Errorcode=5
2017/05/19 10:24:03.884 8 40 GX0 MM: Number of Audio Devices changed
2017/05/19 10:24:03.885 8 40 GX0 VoIP: VoIPCentral: Set capturing-device = "", rendering-device = ""
2017/05/19 10:24:18.106 8 9 GX0 DynamicPasswordUIModel::ShouldShowDynamicPassword(): dynPw=1 allowIncoming=1 id=0 ka=0 lanAllowed=0 lanOnly=0 networkState=1 showDynPwd=0
2017/05/19 10:24:18.106 8 9 GX0 CMainWindow::ShouldShowDynamicPassword(): dynPw=1 allowIncoming=1 id=0 ka=0 lanAllowed=0 lanOnly=0 networkState=1 showDynPwd=0
2017/05/19 10:28:24.170 3934 140522625185536 gX0 XClipboard: RequestClipboard as TARGETS (424)
2017/05/19 10:28:24.175 3934 140522625185536 gX0 XClipboard: RequestClipboard as text/html (613)
2017/05/19 10:28:24.175 3934 140522625185536 gX0 XClipboard: RequestClipboard as UTF8_STRING (293)
2017/05/19 10:28:24.175 3934 140522625185536 gX0 XClipboard: Got clipboard as 'text/html', size (n=488, c=488)
2017/05/19 10:28:24.175 3934 140522625185536 gX0 XClipboard: Got clipboard as 'UTF8_STRING', size (n=20, c=40)
2017/05/19 10:29:53.092 8 9 GX0 CMainWindow::TrackIdleTime(): System goes idle. (IdleTime=326162)

Posted by MSun
Electron

Re: Not ready. Please check your connection after upgrade to v12

I just simply opened the Task Manager and killed the TeamViewer processes. It started working. Possibly I am just lucky this time. Hopefully it will continue to work from now on.

Posted by Phlyer
Henagon

Re: Not ready. Please check your connection after upgrade to v12

i had the same issue after upgrading my desktop and Lappy from 11 to 12 about a month ago.  

I ended up uninstalling and reinstalling 12, doing a registry wipe using ccleaner, rebooting and then reinstalling 12 which made zero difference.  I repeated this and reinstalled 11. still zero difference I dont have installation files for 9 or 10 so ive regressed back to 8 on both machines. Desktop is on XP, Lappy is on win 7.  

If i try to setup unattended access i get the same no connection message. 

Both machines exhibit LAN only connection messages, but if i use my partner ID list I can connect, even over hotel wifi from 100 miles away, but....

The link is fragile and if it drops out or gets closed in error, I cannot reestablish a connection with the remote PC unless I call home and get someone to reboot it.  

before an ID was displayed, now all i have is a local IP address (on both machines).

Also cannot sign in to account (computers & contacts option).from either machine except my phone.  The GUI refuses to respond to mouse clicks. 

If the link drops out, i usually get  "Teamviewer not running on partner computer" when I try to reconnect. 

My phone has TV installed on it which has NOT been upgraded and that works fine with both machines.  The thing works, just but im no nearer finding out why or what I can do to resolve the issue, which is a real pain when im away and i get a support call from one of my aged relatives! 

Posted by TcoUpLoad
Henagon

Re: Not ready. Please check your connection after upgrade to v12

i know this is a reply to an old question but next time search in filehipo.com and for your search has this link filehippo.com teamviewer v11 and others

Posted by ahasbini
Photon

Re: Not ready. Please check your connection after upgrade to v12

Exit Teamviewer, open task manager and go to Services tab, find Teamviewer serivce, right click and stop. Wait until it's Status changes to stop. Then open Teamviewer again and now it connects.

Posted by smart2017
Electron

Re: Not ready. Please check your connection after upgrade to v12

I have the same problem and i have reebooth and upgrade but its still not working

Posted by LadyTramp
Photon

Re: Not ready. Please check your connection after upgrade to v12

@MSunThis worked for me... Thank you

Posted by oiram
Digon

Re: Not ready. Please check your connection after upgrade to v12

I have resolved on Ubuntu 17.04 executing in a terminal the following command:

sudo apt install libnss-resolve:i386

Posted by Ales
Digon

Re: Not ready. Please check your connection after upgrade to v12


oiram wrote: 
sudo apt install libnss-resolve:i386

That finally helped! I wonder how did you figure it out but thanks a lot.

Posted by oiram
Digon

Re: Not ready. Please check your connection after upgrade to v12

I suspected it was a problem with Wine and the network, and because all worked fine until I have installed Ubuntu 17.04 I have take a look to the release notes discovering Canonical changed the support for DNS, so I googled looking for people having a similar problem with Wine and network comunication after the update to Ubuntu 17.04 and I found the solution :)

Posted by subho
Photon

Re: Not ready. Please check your connection after upgrade to v12

I was facing the same problem with v12 on Windows 10.....and it is solved after the Microsoft .NET Framework 4.7 for Windows 10 Version 1607 and Windows Server 2016 for x64 (KB3186568) update. So I believe the problem was in Windows 10 and not in Teamviwer.

I hope this will help.

Posted by johnBasinger
Photon

Re: Not ready. Please check your connection after upgrade to v12

sudo service teamviewerd restart


This works for me. Thank u very much

Posted by SashaS
Electron

Re: Not ready. Please check your connection after upgrade to v12


@oiram wrote:

I have resolved on Ubuntu 17.04 executing in a terminal the following command:

sudo apt install libnss-resolve:i386



Excellent! The only real thing which worked for me (ubuntu 16.10).

Posted by Vallefor
Photon

Re: Not ready. Please check your connection after upgrade to v12

Omg! Thank you! You save me!

Posted by Elder-Geek
Henagon

Re: Not ready. Please check your connection after upgrade to v12

This did the trick for me.  I tried stopping the Teamviewer service and it didn't stop.  I then used Task Manager to stop the service.   The service was still marked at stopping.  I then tried to stop it again and it was finally marked as stopped.  I then started the service and all is now working perfectly.

Posted by TDawg
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Thanks! This worked for me also.

Highlighted
Posted by TuyenBui
Electron

Re: Not ready. Please check your connection after upgrade to v12

After reading  lots of comments and try many recommendations, I was successed when disable "Internet protocol Version 6(IPv6)", disable IPv6 at Lan/Wifi properties(not at router), just uncheck this option, I work like a boss. Please view the link below to detail

Fix teamviewer v12 connection on window 10

Nice day!

Posted by dnemcanin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

HI!

On Windows 10 I had same problem.

I stopped teamviewer services. On Teamview option I disable start with system.
After reboot teamviewer worked fine.

Posted by MarinaTajPalace
Henagon

Re: Not ready. Please check your connection after upgrade to v12

No, Its not working did that.

Posted by phoenix49
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Thanks!!

Posted by BehradKazemi
Photon

Re: Not ready. Please check your connection after upgrade to v12

Fixed after starting VPN :|

Posted by R0YMU5TANG
Photon

Re: Not ready. Please check your connection after upgrade to v12

I've had to kill the background process for teamviewer and start it up again. Generally I get this when I lose internet and get it back again.

As a workaround, I wrote a .bat file that essentially kills Teamviewer and all of it's background processes, then start it up again and it works.

taskkill /f /im teamviewer.exe
taskkill /f /im tv_x64.exe
taskkill /f /im tv_w32.exe

Posted by GlenB
Digon

Re: Not ready. Please check your connection after upgrade to v12

Same error message. Have been running TV12 on Win10 for weeks with no troubles. Then this started. I have not knowingly changed any of my network configuration.But I checked.

1 - Windows Firewall is on and there are rules to let TV and TV-service run over TCP and UDP.

2 - My adapter has IPv6 off and has ALWAYS had it off.

3 - I used Task Mgr to get rid of any and all instances of TV andthen restarted the program.

4 - "Check for updates" says that I am already up to date.

None of those made the slightest difference. So I downloaded the install package and ran it again and now it all seems fine.

Not helpful to have NO IDEA what got messed up or how it happened. The error message is particularly uninformative, making a suggestion about Proxies which I don't use but have always had set as self-discover.

Posted by aquintanar
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Hi,

I get the same message.  I was working pretty nice for several months.  I upgraded some times and increase the version without any problem. But since some days ago, I get the message "Not ready. Please check your connection".

I upgraded to the version 13 Beta and until now everything works great for me.

Kind regards.

Posted by mcochi
Henagon

Re: Not ready. Please check your connection after upgrade to v12

The issue was IPv6. I disabled it and it worked fine.

Running Win 10 Home OS

Posted by GlenB
Digon

Re: Not ready. Please check your connection after upgrade to v12

My router does not support IPv6 so I never enabled it. Unless TV messes with my net config (which it should not without letting me know) then there is some other reason for the problem.  

Seems that it eventually goes away all on its own ... further evidence that the problem is not my configuration. Of course if it can go away, then it can come back.  

We really need a better explanation and not something that is assumed because they seemed to happen at the same time.

Posted by Rps
Neutron

Re: Not ready. Please check your connection after upgrade to v12

Thanks it worked.

Posted by matsimo
Photon

Re: Not ready. Please check your connection after upgrade to v12

This workaround works for me, for other people with the same issue before try to restart your teamviewerd service before modify the  /etc/systemd/system/teamviewerd.service. If after the service restar teamviewer is online go a head to modify the config file. @Bloodhound Thanks for the solution.

Posted by edstrait
Henagon

Re: Not ready. Please check your connection after upgrade to v12

This is the one that worked for me. Stopped teamview, renamed the /etc/teamviewer/globla.conf to .old restarted Teamviewer and all was golden.

Posted by getinto-pc
Electron

Re: Not ready. Please check your connection after upgrade to v12

thanks for ur info.

download here the required software at getinto-pc

Posted by Ray666
Proton

Re: Not ready. Please check your connection after upgrade to v12

Same problem, caused by Avast web shield