Posted by Confucian
Henagon

Not ready. Please check your connection after upgrade to v12

Hi

I get "Not ready. Please check your connection" after upgrade to v12

was working fine before upgrade.

Internet connection ok as it let me download the upgrade.

It keeps banging on about "proxy servers" which i have set to none as i dont have or use one

88 Replies
Posted by TosterCx
Digon

Re: Not ready. Please check your connection after upgrade to v12

Exactly the same problem here. Running windows 10 if that matters.

Posted by TosterCx
Digon

Re: Not ready. Please check your connection after upgrade to v12

Uninstalling/Reinstalling v12 didn't help. Couldn't find v11 anywhere. Ended up downgrading to v8, which runs fine.

http://www.oldversion.com/windows/teamviewer/

Still have no idea what acutally went wrong.

Posted by Confucian
Henagon

Re: Not ready. Please check your connection after upgrade to v12

TosterCx

I was lucky still had a copy of V11 so re installed it and guess what

 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

All working fine again now.

mick

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

I uninstalled version 12 and installed version 11. I still get the same Not ready message. Teamviewer was working fine before I upgraded to 12. I don't think I can install anything below 11 since the computer I need to control is probably running 11, and my 98-year-old mother won't be able to update by herself. I'm on the latest version of OSX.

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

I reinstalled version 12. I'm running Avast antivirus. I turned off web shield, and Teamviewer could suddenly connect.

Posted by Ronin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Was working fine on 12.x for sometime, after a recent reinstall, it appeared to be running, but instead of an ID it displayed a local IP address (also happened on a client's machine).

Now it displays LAN only, if I disable LAN connections, it has no connection at all. Also cannot sign in to account (computers & contacts option).

As it happens, I cannot even access it on the local network - "Teamviewer not running on partner computer".

Teamviewer 12.0.71510 wine-1.6
Running Ubuntu 16.10, hardwired internet.

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

It seems to be random. I turned the web shield back on and nothing happened. Then it didn't connect again with web shield off. I switched to the new interface. First, it didn't connect and then it did.

Posted by bhoth
Digon

Re: Not ready. Please check your connection after upgrade to v12

I can get it to work by running in a terminal:

sudo systemctl stop teamviewerd.service

sudo systemctl start teamviewerd.service

Posted by Ronin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Cheers, @bhoth that does get it running again...we'll have to see if it survives a reboot!

Posted by Wenbin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

The same issue. Any idea why? Any fix for windows?

Posted by Ronin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

@bhoth - your solution is good as a temporary fix, however it does not survive a reboot. At least it's a somewhat manual solution for now.

Very frustrating as Teamviewer has been working very well up to now - even though it's still dependent on WINE under Linux.

Posted by Wenbin
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Log:

2017/01/04 22:57:58.120 2688 2572 S0!! LocalIPVector: getaddrinfo failed with socket error 11001, Errorcode=11001 Start: 2017/01/04 22:57:58.119 

Version: 12.0.72365 ID: xxxx Loglevel: Info (100)

License: 10000 Server: master6.teamviewer.com

CPU: Intel64 Family 6 Model 42 Stepping 7, GenuineIntel CPU extensions: g9 OS: Win_10.0.10586_W (64-bit)

IP:

MIDv: 1

Proxy-Settings: Type=1 IP= User= IE: 11.713.10586.0

AppPath: C:\Program Files (x86)\TeamViewer\TeamViewer_Service.exe UserAccount: SYSTEM

2017/01/04 22:57:58.146 2688 1032 S0! CKeepAliveClientClient::HandlePing(): ping failed 2017/01/04 22:57:58.147 2688 1032 S0 Non-Commercial use 2017/01/04 22:57:58.147 2688 1032 S0 Resource-Language: en 2017/01/04 22:57:58.147 2688 1032 S0 Activating Router carrier 2017/01/04 22:57:58.148 2688 1032 S0 CProcessCommandHandlerMasterConnect[48]::CreateMasterConnect(): master6.teamviewer.com:80, Connection 48, proxy=''

2017/01/04 22:57:58.164 2688 1032 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: master6.teamviewer.com 2017/01/04 22:57:58.164 2688 2572 S0! CProcessCommandHandlerMasterConnect[48]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed

2017/01/04 22:57:58.164 2688 2572 S0!! LookUpDNS failed for master6.teamviewer.com, socket error = 11001, Errorcode=11001 2017/01/04 22:57:58.164 2688 2572 S0!!!Connect to Master master6.teamviewer.com / failed!, Errorcode=11001 2017/01/04 22:57:58.165 2688 2572 S0!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10, Errorcode=11001

2017/01/04 22:58:01.166 2688 2660 S0 Activating Router carrier 2017/01/04 22:58:01.166 2688 2660 S0!!!CTcpConnectionBase[49]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: system:11001

2017/01/04 22:58:01.166 2688 2572 S0 Activating Router carrier 2017/01/04 22:58:01.180 2688 2572 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com

2017/01/04 22:58:01.180 2688 2572 S0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0

2017/01/04 22:58:01.180 2688 1032 S0!! NetWatchdog: Port 443 proxy search failed! No working setting found. -- 2 previous log entries omitted --

Posted by TosterCx
Digon

Re: Not ready. Please check your connection after upgrade to v12

Yep, same errors. I think they're forcing curl to use IPv6 interfaces somehow (which my ISP doesn't support).

curl master12.teamviewer.com -6
curl: (6) Could not resolve host: master12.teamviewer.com; No data record of requested type

curl master12.teamviewer.com -4
<html><body>This site is running <a href='http://www.TeamViewer.com'>TeamViewer</a>.</body></html>

Posted by bhoth
Digon

Re: Not ready. Please check your connection after upgrade to v12


@TosterCx wrote:

Yep, same errors. I think they're forcing curl to use IPv6 interfaces somehow (which my ISP doesn't support).

curl master12.teamviewer.com -6
curl: (6) Could not resolve host: master12.teamviewer.com; No data record of requested type

curl master12.teamviewer.com -4
<html><body>This site is running <a href='http://www.TeamViewer.com'>TeamViewer</a>.</body></html>


Ok so it looks like Teamviewer 12 is trying to be IPV6 ready. Is there a way to tell Teamviewer 12 to not use IPV 6 or ignore it?

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

My ISP does have iPv6, but I usually have to fiddle with my router to get it to work and then it stops working again. Maybe that's why I was able to use Teamviewer intermittently.

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

I am IPv6 ready, which took me a while to verify, and I had this problem, too, though it's possible that IPv6 wasn't working when Teamviewer was unavble to connect. Now, it is.

Posted by bhoth
Digon

Re: Not ready. Please check your connection after upgrade to v12

I have now enabled ipv6 thru my router and my linux box and it still does not work. So it's more than just not having ipv6.

Posted by vikishi
Henagon

Re: Not ready. Please check your connection after upgrade to v12

I'm also facing same problem on Fedora 25. All started after I upgraded from Fedora 23 to 24 and the problem still persists. On Fedora 23 I was using TeamViewer V10 then V11 and now V12 still the problem is not resolved. Please TeamViewer team fix the bug.

Posted by LinuxRob
Digon

Re: Not ready. Please check your connection after upgrade to v12

I have a sorta a bad **bleep** patch/hack that seems to be stable.. 

From reading the other posts it looks like something was/is wrong with DNS lookups.  

So my "fix" that is **bleep** is not to do dns lookups. 

sudo vi /etc/hosts (or windows host file C:\Windows\System32\drivers\etc\hosts )

and add

# Teamviewer
178.77.120.6 master1.teamviewer.com
178.77.120.104 master2.teamviewer.com
178.77.120.100 master3.teamviewer.com
178.77.120.102 master4.teamviewer.com
178.77.120.6 master5.teamviewer.com
178.77.120.100 master6.teamviewer.com
178.77.120.102 master7.teamviewer.com
178.77.120.104 master8.teamviewer.com
178.77.120.106 master9.teamviewer.com
178.77.120.104 master10.teamviewer.com
178.77.120.100 master11.teamviewer.com
178.77.120.6 master12.teamviewer.com
178.77.120.102 master13.teamviewer.com
178.77.120.106 master14.teamviewer.com
178.77.120.106 master15.teamviewer.com
178.77.120.106 master16.teamviewer.com

to it.  You may verify all the IPs manually by doing ping master1.teamviewer.com and  verify the IPs. I stopped at 16 it looked out of country (of usa) IPs. So there may be more than 16.

After adding them I was unable to reproduce the problem.  **bleep** because if they change dns entries this will all break.  So now you have to maintain a sudo dns table.  

**bleep** because it could be a security issue as you are not using DNS to verify that is actually teamviewer you are talking to.  

But end of the day it seems to fix the issue. + it looks like there is many re-used duplicate IPs.

Robert

 

 

 

Posted by LinuxRob
Digon

Re: Not ready. Please check your connection after upgrade to v12

(U)Gl,y is a bad word? Bleep me..

Posted by rekaut
Electron

Re: Not ready. Please check your connection after upgrade to v12

for me I was trying to cnnect to my server remotly, however! anytime before you run teamviewer and connect to the server it will shows not ready. 

I solved to restart my server and from the other end not starting any ssh, it worked. 

Posted by ibsdemo15
Photon

Re: Not ready. Please check your connection after upgrade to v12

I had the same issue. Check to see if your internet is working or not. If it is working then check your firewall setting to make sure that TeamViewer is allowed to go out and recieve incoming request.  That should take care of the Version 12 problem.

Good Luck

Muhammed

Highlighted
Posted by alex
Photon

Re: Not ready. Please check your connection after upgrade to v12

I tried restarting the service on Windows 10 and it hung on stopping. I killed the process in task manager. Fired it back up and it connected right up. This is the first time I have noticed issues. 

4 Replies
Posted by Firesky
Photon

Re: Not ready. Please check your connection after upgrade to v12

I was having problems aswell, since I saw some people here talking about ipv6 I went ahead and disabled ipv6 from my adapter, and voila it worked, hope this helps someone.

https://gyazo.com/75f4a0cf4da817197189d0d8c9ad7625

Posted by kronflux
Henagon

Re: Not ready. Please check your connection after upgrade to v12

 

bhoth wrote:
I can get it to work by running in a terminal:
sudo systemctl stop teamviewerd.service
sudo systemctl start teamviewerd.service

I can confirm this fixes it until system reboot.

Firesky wrote:
I was having problems aswell, since I saw some people here talking about ipv6 I went ahead and disabled ipv6 from my adapter, and voila it worked, hope this helps someone.
https://gyazo.com/75f4a0cf4da817197189d0d8c9ad7625

Sadly disabling ipv6 on Ubuntu did not help at all.

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

I can now say consistently that when IPv6 is active in my router, TeamViewer runs normally. However, my Netgear router seems to occasionally drop IPv6. When that happens, TeamViewer cannot connect. I go into my router settings and reapply them for IPv6 and TeamViewer connects again. However, from other posts I have read, there may be other issues that others are encountering.

Posted by hans
Photon

Re: Not ready. Please check your connection after upgrade to v12

Hi! Same problem here, on Manjaro. Solution for me was to add 'mdns4' to 'hosts:' list in /etc/nsswitch.conf

Posted by Toanlv
Electron

Re: Not ready. Please check your connection after upgrade to v12

Thank you! It's work for me

Posted by eddieleprince
Photon

Re: Not ready. Please check your connection after upgrade to v12

I am running linux and I unistalled teamviewer, removed the local log (probably not necessary) but I found a config file in /etc/teamviewer.  I deleted that directory (or folder whatever you want to call it).  Reinstalled teamview 12.  Accepted teh licence agreement and all is well.

Hope that helps.

Posted by RodneyLee
Henagon

Re: Not ready. Please check your connection after upgrade to v12

That works, thanks, what a PITA if I have to do that all the time

Posted by arjun101
Electron

Re: Not ready. Please check your connection after upgrade to v12

completely garbage system. Keeps telling me there no connection

Posted by RodneyLee
Henagon

Re: Not ready. Please check your connection after upgrade to v12

stop and restart worked great for me

sudo systemctl stop teanviewerd.service

sudo systenctl start teanviewerd.service

 

Posted by hurricane
Henagon

Re: Not ready. Please check your connection after upgrade to v12

thank you, that's helpful

Posted by deval
Electron

Re: Not ready. Please check your connection after upgrade to v12

It was indeed a case of multiple Teamviewer tasks running<trying to make a connection> at the same time on my machine.

Killed all of them and fired the application again, which worked straight away.

Probably best to select, in settings, for the app to not start with/when Windows starts, which for me was probably the actual issue.

Posted by CliftonH
Electron

Re: Not ready. Please check your connection after upgrade to v12

I am running Windows 10 and TeamViewer 12 Desktop App. I was receiving the "Not Ready. Please check your connection" error when trying to login. I read through other forums looking for help and found someone who mentioned IPv6. I logged into my router and DISABLED IPv6 LAN connection and TeamViewer immediately started working and I was able to log into my account.

I hope someone finds this helpful.

Posted by IAmMoen
Photon

Re: Not ready. Please check your connection after upgrade to v12

@hans wrote:

Hi! Same problem here, on Manjaro. Solution for me was to add 'mdns4' to 'hosts:' list in /etc/nsswitch.conf


On my Ubuntu 16.04 LTS install there was already mdns4_minimal on the hosts line. I removed the _minimal part and now it seems to work for me.

Edit: After looking into this a bit further I realized that I shouldn't just remove the _minimal part. Per the mdns project page (http://0pointer.de/lennart/projects/nss-mdns/) the recommended line is: 

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

You can read here about what all of that means: https://ubuntuforums.org/showthread.php?t=971693

Posted by diehummel
Henagon

Re: Not ready. Please check your connection after upgrade to v12

Hi,

non of the suggestions fixed it for me.

not the hosts entries, not the mdns4 entry and also not disabling ipv6 in ubuntu (16.04) and router (dd-wrt).

i have this on 2 ubuntu 16.04 systems with different hardware, but same kernel.

currently 4.10. But also with 4.9 it was the same.

come on teamviewer team... you can do it better..

Posted by izacki
Photon

Re: Not ready. Please check your connection after upgrade to v12

I had this connection problem for many months on Ubuntu 16.04. After each OS update, I got the error on Teamviewer and I was unable to use it. I've done the chmod trick and it worked only one time. On my last Ubuntu update and reboot, nothing was able to get Teamviewer back.

After checking the Teamviewer 'wine' directory, I saw that it was using the version 1.6, which isn't the last release. I then checked the net and installed Wine 1.8 (http://ubuntuhandbook.org/index.php/2015/12/install-wine-1-8-stable-new-ppa/). To make it work with Teamviewer, I simply renamed all bins of /opt/teamviewer/tv_bin/wine/bin and created symlinks to the new bins in /usr/bin. I've done the same thing with libwine.so.1.0 and wine directory of /opt/teamviewer/tv_bin/wine/lib directory to link them to the 32bit version of Wine 1.8 in /usr/lib/i386-linux-gnu.

So here are the new links:

me@zpc:~/$ ls -l /opt/teamviewer/tv_bin/wine/bin
total 408
lrwxrwxrwx 1 me me 13 Feb 22 10:42 wine -> /usr/bin/wine
-rwxrwxrwx 1 root root 9816 Nov 28 09:30 wine.orig
lrwxrwxrwx 1 me me 23 Feb 22 10:43 wine-preloader -> /usr/bin/wine-preloader
-rwxrwxrwx 1 root root 12944 Nov 28 09:30 wine-preloader.orig
lrwxrwxrwx 1 me me 19 Feb 22 10:43 wineserver -> /usr/bin/wineserver
-rwxrwxrwx 1 root root 387280 Nov 28 09:30 wineserver.orig

me@zpc:~/$ ls -l /opt/teamviewer/tv_bin/wine/lib
total 1672
lrwxrwxrwx 1 root root 14 Nov 28 09:30 libwine.so -> libwine.so.1.0
lrwxrwxrwx 1 root root 14 Nov 28 09:30 libwine.so.1 -> libwine.so.1.0
lrwxrwxrwx 1 me me 38 Feb 22 10:59 libwine.so.1.0 -> /usr/lib/i386-linux-gnu/libwine.so.1.0
-rwxrwxrwx 1 root root 1698324 Nov 28 09:30 libwine.so.1.0.orig
lrwxrwxrwx 1 me me 29 Feb 22 10:59 wine -> /usr/lib/i386-linux-gnu/wine/
drwxrwxrwx 3 root root 12288 Feb 22 10:56 wine.orig

I was then able to start TeamViewer with the new wine version using:

sudo teamviewer daemon start

To shutdown Teamviewer, run "sudo teamviewer daemon stop" and ensure that there is no TeamViewer processes running using "ps aux | grep tv". Kill them before restart if some are still running.

Works for me. I hope it'll work for you too!

 

Posted by diehummel
Henagon

Re: Not ready. Please check your connection after upgrade to v12

thanks. i have wine 2.0 and it looks like its connecting without problems also with that version but i can't connect from other hosts to ubuntu.. And it takes about 2 minutes longer to start. And really.. i don't think its on the user to rename and link to other wine installation ;). Next update will overwrite them and maybe TV next version is still using wine 1.6

And i wonder why TV takes so long to fix this. :(

Posted by WillSilva
Photon

Re: Not ready. Please check your connection after upgrade to v12

Disable IPV6 for your internet adapter. It works for me.

Posted by stevegoldfield
Digon

Re: Not ready. Please check your connection after upgrade to v12

It seems that there are different solutions for different platforms. It's exactly the opposite for me. When IPv6 is disabled, I cannot connect to TeamViewer. When it is enabled, I can.

Posted by diehummel
Henagon

Re: Not ready. Please check your connection after upgrade to v12

For me its "unstable" with ipv6 enabled and disabled. It doesn't change the behavier that it most of the tim it does not connect during startup.

Also just restarting the daemon often it does not connect.

Sometime i have to restart it 6 or more times until it connects and very seldom it connets on startup.

Posted by opifug
Electron

Re: Not ready. Please check your connection after upgrade to v12

Me too. Does it work today (March 5/2017)? It seems to me, not. Any advice? Any help? 

Posted by Nounours18200
Electron

Re: Not ready. Please check your connection after upgrade to v12

his kind of problems is just UNACCEPTABLE provided that 95% of the people use windows !

So I am fed up with this issue and I remove Teamviewer from my computer ...

Bye bye Teamviewer... you must at least test your releases before make them available to millions of users...

Posted by dimaloma
Photon

Re: Not ready. Please check your connection after upgrade to v12

I had similar problem. It looks like teamviewerd starts too early, when interface is not ready. After this change it starts properly on my system:

$ cat /etc/systemd/system/teamviewerd.service
[Unit]
Description = TeamViewer remote control daemon
After=NetworkManager-wait-online.service network.target network-online.target dbus.service
After=network-online.target
After=time-sync.target
Wants = NetworkManager-wait-online.service network-online.target
Requires = dbus.service

[Service]
Type = forking
PIDFile = /var/run/teamviewerd.pid
ExecStart = /opt/teamviewer/tv_bin/teamviewerd -d
Restart = on-abort
StartLimitInterval = 60
StartLimitBurst = 10

[Install]
WantedBy = multi-user.target

Posted by sakshar007
Photon

Re: Not ready. Please check your connection after upgrade to v12

just end all team viewer tasks in taskmanager . and restart the app

Posted by Bloodhound
Henagon

Re: Not ready. Please check your connection after upgrade to v12


@dimaloma wrote:

I had similar problem. It looks like teamviewerd starts too early, when interface is not ready. After this change it starts properly on my system:

$ cat /etc/systemd/system/teamviewerd.service
[Unit]
Description = TeamViewer remote control daemon
After=NetworkManager-wait-online.service network.target network-online.target dbus.service
After=network-online.target
After=time-sync.target
Wants = NetworkManager-wait-online.service network-online.target
Requires = dbus.service

[Service]
Type = forking
PIDFile = /var/run/teamviewerd.pid
ExecStart = /opt/teamviewer/tv_bin/teamviewerd -d
Restart = on-abort
StartLimitInterval = 60
StartLimitBurst = 10

[Install]
WantedBy = multi-user.target


This solved it for me on Ubuntu 16.04.2 LTS.

Posted by diehummel
Henagon

Re: Not ready. Please check your connection after upgrade to v12

thanks, but not for me.

starting too early cannot be the problem on my 16.04.2 system, as i have to restart it several times until it goes online.

br

Posted by Bloodhound
Henagon

Re: Not ready. Please check your connection after upgrade to v12


@diehummel wrote:

thanks, but not for me.

starting too early cannot be the problem on my 16.04.2 system, as i have to restart it several times until it goes online.

br


Just had a case when it did not work anymore with After=.
Reverted it and just put on my Ubuntu Mate 16.04.2 LTS:
ExecStart = /bin/bash -c "sleep 60; /opt/teamviewer/tv_bin/teamviewerd -d"
This seems to work fine.

There would be cleaner ways to do this via a systemd timer, but whis would not be a one liner anymore.