Posted by SWenning
Photon

Requires update but says none available

I am using TeamViewer on my MacBook at home to connect to my PC at work. At some point in the past week I have started getting an error message on my home computer about needing to update my TeamViewer. It says "Your partner is using a newer version of TeamViewer and you need to update your version of TeamViewer to establish a connection".

The problem is, when I'm in my TeamViewer, it tells me that there are no updates available and that the version I'm using (version 10.0.52680) is the most current and up to date. But it still will not let me connect. I tried completing shutting down the TeamViewer on both computers to see if that helps. The problem is I obviously can't be in both places/on both computers at the same time. Does anyone have any suggestions for what to try next? I am going on maternity leave in a matter of weeks and I desperately need to be able to access my work computer while I am gone.

4 Replies
4 Replies
Posted by abbie317
Electron

Re: Requires update but says none available

Hi, I am having the same problem, did you ever figure it out?

Posted by Community Manager
Community Manager

Re: Requires update but says none available

Hi there,

You have to make sure that your connection partner uses the same or an older version of TeamViewer to make a connection.

A connection from TeamViewer 10 is possible to another TeamViewer in version 10 or an older version like 9.x or 8.x. That means TeamViewer is backward compatible but cannot connect to newer versions.

If your connection partner has a newer TeamViewer version running, you can either update your own TeamViewer version to TeamViewer 13 or you can ask your partner to start a TeamViewer in an older version.

Please keep in mind: If you have a license for an older TeamViewer version, you will have to update your license first to make licensed connections with a newer TeamViewer version.

Thanks and all the best, Esther.

Posted by tbone1
Electron

Re: Requires update but says none available

My friend just got a brand new Dell Inspiron 7xxx 64bit running WIN10 Home. He has TV 14.5.1691 . This is the same version I am running yet TV gives me a notice that I can't connect to partner because he is running out of date. Tried re-bot, uninstall/re-install on BOTH out computers yet I still the same message. My friend can connect to my computer fine Any ideas on how to fix this?

Posted by Moderator Moderator
Moderator

Re: Requires update but says none available

Hi @tbone1 

Thank you for your message.

Can you please send me your email address in a private message? 

Looking forward to your answer and wish you a great day. 

All the best,
Natascha