Posted by jhovik
Photon

Surface Pro 4 connection [SOLVED]

     I'd been having an issue connecting to my microsoft surface pro 4 via TeamViewer after it goes to the lock screen and sits idle for a while. On TeamViewer, it appears its online and ready to connect to but when I try to connect, it ends up failing. I discovered it works fine if I'm logged in. I tried so many things, looked at online forums, and could never get it to work. I finally took another look at it and found the solution so I thought I would share. 

     I use the surface dock with an external monitor and use Ethernet via the dock for my network connection. In a prior effort to find a solution I changed a setting to make sure windows would not power down the network interface port. Coincidently there was a windows update that same day, and unknown to me, the setting went back to default so I assumed I had not found the solution.

  I recently tried to get it working using Wi-Fi and didn't have an issue so I revisited the power settings for the Surface Ethernet Adapter and that’s when I noticed it reverted to default settings. By default, it will turn off the Ethernet adapter after 5 minutes when idle at the lock screen. Here are the settings that need to be changed. 

  1. Right click on the windows icon in the bottom left corner (or press win+x) and select "Network Connections"
  2. Double click on "Surface Ethernet Adapter" then click on "properties"
  3. Click on "Configure" then go to the "advanced" tab
  4. change these options to "disabled"
  5. Energy Efficient Ethernet – disabled 
  6. Selective Suspend- disabled
  7. click "OK"

Now go to your power settings

  1. Left click windows button on bottom left corner (or press win key) and go to "settings"
  2. Click on "system" then click on "power & sleep"
  3. Make sure PC "Never" goes to sleep when plugged in
  4. There are some other settings you may want to activate as well, "stay connected to network while asleep", make sure it does not hibernate (under additional power settings/change plan settings/change advanced power settings/sleep/hibernate after) 

I find even with sleep turned off it will still go into a lower power state/sleep after being idle for a long time and turn certain devices off like the Surface Ethernet Adapter. That’s why it’s important to turn off "selective suspend".

Hope this helps others.

1 Reply
Posted by estock19
Photon

Re: Surface Pro 4 connection [SOLVED]

2. Double click on "Surface Ethernet Adapter" then click on "properties"

 

I get stuck on this step. The only thing I see on this page is the Wi-Fi connection.

Please help :/