Posted by Shayne
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I have version 12.0.77242 and it does the same thing occasionally.  Still looking for solutions.

UPDATE:  FOUND SOLUTION BELOW!

Posted by Shayne
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@kratjuh wrote:

I had the same issue. Both machines Version 12 and Windows 10 Pro, stuck in Initializing display parameters.

I was able to work around it: In TV client go to Settings -> Remote control -> disabled "Remove External Background" and selected "Optimal Quality" under quality. Then I connected and it worked again. Rebooted the machine to be sure.

Note: I use a Dutch version so the translation may be different in your TV.


This solution worked for me as well.  Thank you so much!

Posted by Chris2
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I had the same problem, and this fixed it for me:

1- Go into the properties for the connection (where you can assign an alias or change the password); 

2- Click on Advanced +   at the bottom.

3- Change the Scaling to "100% (original)".  

I also changed a few other settings (listed below), but I'm pretty sure the Scaling was the key.

Other settings I also changed:

- Remote Resolution:  Changed from inherited to 1280x1024 (smaller than my screen)

- Initial screen:  Changed from inherited to "1"

- Action settings:  

-- Authentication mode:  Changed from Inherited to Windows Authentication.  

-- Remote Input:  I think I might've set this to "Enable Remote Input" (or maybe it was already there).

Posted by thulasak
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

got it!

on the  TV remote host little window, hover over (or click) the new bulb to get info on multi user thingy. use the given alternate id (use same password ) and things should work without needing to tweak anything else!

woohooo!

Posted by simrick
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Unfortunately this doesn't work for me. I remote-updated my friend's computer from v11 to v12 and now I can't login. I suppose it would be easy enough to reboot the remote system, except for the fact that he is gone for 2 weeks. I had changed the power setting from never shutdown to shutdown after 5 hours. Maybe that caused the problem? I don't know. This sure is frustrating!

And now, after fiddling with display parameters, I get Authentication Rejected. UGH!

Posted by Chris2
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I don't see an option to edit posts, so I'm replying to my own post with a retraction, of sorts; the thing described below, which I thought had fixed the problem, was not actually what fixed it.

It turns out that the reason TeamViewer was sticking on "Initializing display parameters" was that TeamViewer on the system I was connected to was set to only allow connections when someone was logged in; what had fixed it was that one of my colleagues had remote destopped into the machine.  As soon as he logged out, the problem came back.

The fix was actually to uninstall TeamViewer, delete the TeamViewer registry key (from HKEY_Local_Machine > Software > Wow6432Node > TeamViewer), and reinstall with "Allow Unattended Remote Access" selected.  There might've been an easier way to do that, but I knew that way would work when I recommended it to my colleague, and it did.  (No restart of the server on which TeamViewer was installed was necessary.)

My apologies to anyone I gave false hope / led astray with my premature "MISSION ACCOMPLISHED!!!"  :smileyembarrassed:


@Chris2 wrote:

I had the same problem, and this fixed it for me:

1- Go into the properties for the connection (where you can assign an alias or change the password); 

2- Click on Advanced +   at the bottom.

3- Change the Scaling to "100% (original)".  

I also changed a few other settings (listed below), but I'm pretty sure the Scaling was the key.

Other settings I also changed:

- Remote Resolution:  Changed from inherited to 1280x1024 (smaller than my screen)

- Initial screen:  Changed from inherited to "1"

- Action settings:  

-- Authentication mode:  Changed from Inherited to Windows Authentication.  

-- Remote Input:  I think I might've set this to "Enable Remote Input" (or maybe it was already there).


 

 

Posted by thulasak
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

 


@simrick wrote:

Unfortunately this doesn't work for me. I remote-updated my friend's computer from v11 to v12 and now I can't login. I suppose it would be easy enough to reboot the remote system, except for the fact that he is gone for 2 weeks. I had changed the power setting from never shutdown to shutdown after 5 hours. Maybe that caused the problem? I don't know. This sure is frustrating!

And now, after fiddling with display parameters, I get Authentication Rejected. UGH!


yeah got to have rdp or physical access to remote host.

 

Posted by Mulsambe
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

It doesn't work for me either.
I have upgraded and rebooted all my machines (4 PCs).
And now, I am no longer able to log from any one to any other.
Very sad...

Posted by thulasak
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@Mulsambe wrote:

It doesn't work for me either.
I have upgraded and rebooted all my machines (4 PCs).
And now, I am no longer able to log from any one to any other.
Very sad...


don't you have rdp or physical access to them?

 

Capture2.png

 

maybe pic above will give some clues.

this is when i rdp to remote host. NOT using teamviewer.

i click the bulb to popup info box.

sorry. i had to erase some info.

 

 

Posted by reeyon
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@Djago wrote:

I'm having the same problem BUT I can give TV programmers a hint:

1 Try to connect with TV and get the Initializing display parameters window

2 Connect via RDP to the computer. At the same moment TV will connect! You'll have both remote connections: TV and RDP

3 Sadly, if you disconnect RDP, TV will give you a message informing that it "at this moment you can't capture the screen. It can be due to the user fast switch..." (or something like that; I have the program installed in spanish)


Same problem here. TV version is 12.0.77242. 

Posted by reeyon
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@reeyon wrote:

@Djago wrote:

I'm having the same problem BUT I can give TV programmers a hint:

1 Try to connect with TV and get the Initializing display parameters window

2 Connect via RDP to the computer. At the same moment TV will connect! You'll have both remote connections: TV and RDP

3 Sadly, if you disconnect RDP, TV will give you a message informing that it "at this moment you can't capture the screen. It can be due to the user fast switch..." (or something like that; I have the program installed in spanish)


Same problem here. TV version is 12.0.77242. 


Not only that. When user is not logged on (user signed out from server), the TV will goes off as well and not able to connect anymore. It shows "offline" in my TV contact list. 

The host has Hyper-V installed. TV is running on VM.

Posted by thulasak
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@reeyon wrote:

@reeyon wrote:

@Djago wrote:

I'm having the same problem BUT I can give TV programmers a hint:

1 Try to connect with TV and get the Initializing display parameters window

2 Connect via RDP to the computer. At the same moment TV will connect! You'll have both remote connections: TV and RDP

3 Sadly, if you disconnect RDP, TV will give you a message informing that it "at this moment you can't capture the screen. It can be due to the user fast switch..." (or something like that; I have the program installed in spanish)


Same problem here. TV version is 12.0.77242. 


Not only that. When user is not logged on (user signed out from server), the TV will goes off as well and not able to connect anymore. It shows "offline" in my TV contact list. 

The host has Hyper-V installed. TV is running on VM.


yes i think it meant to behave that way.

see and study the pic below.Capture2.png

so use the first id given by TV if you like to connect without rdp (or another user) already connected.

(this first id is different from shown as 'Your ID ->')

 btw i'm using latest TV version with which i had the same issue as you guys. now solved by simply using the given alternate id.

 

 

 

 

 

 

Posted by Hillandale
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

So I am having the same issue and I am in my 7 day trial period of the corporate licence...starting to reconsider the move to TV...stability of the remote control feature is mission critical for support team so if it does not deliver that, the rest does not really matter.  Any suggestions?  am i over reacting?

Posted by douglerner
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I'm sorry I can't explain what I did to fix it, but I visited my friend's house, restarted his computer, tweaked with some system settings on his Mac, and when I came home I was able to connect to his computer via TeamViewer again!

But I don't know what I did to fix it.

One issue though: Each time I disconnect his computer gets logged out, and he has to login again, which confuses him (he's 98 years old).  If I reconnect I can see the login screen and login.This didn't used to happen. How can I end our session without him logging out? Anybody know?

 

Thanks,

 

doug

Posted by reeyon
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Thanks @thulasak
This is really solved my issue.

Posted by MichaelG
Trigon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Unfortunately, I cannot connect via RDP to my remote computers because of the firewalls.
Has anyone who consistently has this issue submitted a bug report?
It happens too rarely for me to duplicate the issue. Yet, I cannot take the chance of moving my company to TV if it starts happening on a computer 2000 miles away. 

Posted by simrick
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

In my case, someone finally was physically at the machine. There were multiple dialogue boxes open of "This has been a free session...", from every time I tried to connect after remote updating from v11 to v12. Once all those boxes were closed, I was able to connect. We did not even have to reboot the system - just closed all those boxes.

Posted by Muplor
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

For any one still experiencing this problem here is how I solved it.

I was getting this hang error when connecting to a TViewer unattended host. happened on 3 core servers.

When setting it up and linking it to your account it will actually do so for the ACTIVE session e.g whoever is logged on at that time. That means you need to RDP on to that link in order for TV to work - as soon as you disconnect from RDP, then your Teamviewer will go pop too!

To solve this you need to open the Team viewer host options and then renter your details as it will appear to have lost them (looks like a bug). It will then create a second link in your teamviewe program with a different connection ID (the one used for remote monitoring of servers).

Then just delete the first one you made and the second one will operate fine.

 

Really stupid way of connecting up unnateneded hosts Teamviewer!!! This does not happen if you use the Full Program to setup annatended access -but for me I didnt want the host to be able to remote to anywhere else.

Hope this helps someone!

Posted by samuraitakaro
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hello all,

it is stupid but with my case, i don't need to do any thing.

put monitor cable and start your server and check sever can start then unplug monitor cable you can remote normally.

Hope this help for you!

 

 

Posted by Senior Moderator Senior Moderator
Senior Moderator

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hi Everyone,
I would just like to clarify that I believe we have 2 separate issues in this thread. One is a connection issue, the other is to do with terminal servers having multiple ID's
   
As Thulasak said, this has to do with Server ID's and User ID's when working with client servers.
When using a terminal server, when a user logs out, their client is essentially set to "off". They come back online when you log back in. This is to save system resources.
To overcome this, The full version AND host will both install automatically with "Enhanced user management". This means that each user will have their own ID, but this will show as offline when they log out, or you will get connection issues when connecting if they are not actively using the session.
To overcome this, open "About TeamViewer" and connect with the Server ID. This will take you to the login page and you can then log in as any user from here.
I am sorry for any confusion.
-Scotty
Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?
Posted by EVServices4u
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

OMG, same problem... how do I fix this?

Posted by EVServices4u
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

How did you fix this problem....

Posted by Muplor
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Read the forum posts and it tells you a variety of fixes

Posted by EVServices4u
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

How do you make sure the password is the same?  Do you click on your name at the top and choose "edit profile"?  I don't see any password reset either to make sure both passwords, on my screen and online at teamveiwer.com are the same?

Posted by Muplor
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

If you are using the Host Only download:

Whatever you set the password on your remote end PC to intitially when running the setup program Just use that when connecting for Teamviewer from your PC

If you are using Teamviewe full on the host and on your remote PC, then you need to setup "unattended Access" and again use the same password on both ends. 

If you cant rememer the password, uninstall on the remote machine and start from scratch.

Posted by EVServices4u
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hello,

I need help.. I am not sure what you mean by RDP?  I'm not using a TV.  I'm trying to log on to another computer outside my home.  Where do I find the "Team Viewer Host Options".  Are you saying its under Extra Menu, Options?  Do I need to reset my passwords under the Computers and Contacts Tab?  I am so confused... I'm a single mother and really rely on this to work and I have had several problems since I have been using it.  If you can help me, I would appreciate it.  I am not very technical but I can follow directions on my own.. I did try to reset my password but it is asking me to enter my new password which I did but then it wants my old one which it is not accepting.  Ughhhh

Posted by Muplor
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

It sounds like the password you need resetting is the password on the PC you want to connect to.

This is not the password that you use to login to Teamviewer and access PCS but a different password that you set when you first made the "link" to the remote PC.

if you cannot remember the password to connect to the remote PC that you used to use, your best bet is to physically get on to that PC (Or get a friend in the building to do it, or RDP (remote desktop in to the PC using the windows software).

 

You will then need to remove the software on that remote PC and reinstall it and in the process set up a new password. With this new password you will then enter that in on your PC at home and your remote link should be back in action.

Posted by YszLH
Henagon

Re: Teamviewer initializing display parameters and hangs - Version 12.0.x

To Scotty. At end of your recent answer you wrote :::
"To overcome this, open "About TeamViewer" and connect with the Server ID. This_will take you to the login page <etc.>."

» What TeamViewer flavour does this pertain to ? On_my free license v12.0.78313, all that "About TeamViewer" states is :::

Version: 12.0.78313
Date: May 23 2017 13:21:44
TeamViewer ID:
License: Free
Copyright © 2005-2016 TeamViewer GmbH

How for heaven's sake will any of that take anybody to a login page ??
Many thanks for any clarification.

Posted by dgitter
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Interesting observation.   When I am hung withthe display params message, if I make an RDP connection, TV suddenly completes it;s connection.  I can then drop RDP and TV stays connected.  Really weird.

Posted by reverseswing
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@Shayne wrote:

@kratjuh wrote:

I had the same issue. Both machines Version 12 and Windows 10 Pro, stuck in Initializing display parameters.

I was able to work around it: In TV client go to Settings -> Remote control -> disabled "Remove External Background" and selected "Optimal Quality" under quality. Then I connected and it worked again. Rebooted the machine to be sure.

Note: I use a Dutch version so the translation may be different in your TV.


This solution worked for me as well.  Thank you so much!


This worked for me as well. I don't get why this would happen though. it was fine and then all of a sudden the next login got stuck.

Posted by amster
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Yes this is the answer for me, i.e. change the resolutions settings to something defined in advanced at the remote computer:

 

Remote resolution, Scaling, Initial screen, Quality, Authentication Mode, Remote input to:

1920x1080 (for me), 100%, 1, automatic, Windows authentication, Enable remote input

 

BOOM

Posted by amster
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Ok no really, I have a workaround. This is stupid but it works.

So when you install on a remote virtual server, teamviewer doesn't do your standard install like it does on your home PC. If on your remote server, you go to about- you will in fact notice TWO team viewer ID's.

One is:

Teamviewer UserID

other is

Teamviewer ServerID

The UserID is for the session that you logged in to when you installed the program.
The ServerID is for the logon page of the server.

the workaround is, add remote connections to both.

Connect first to the serverID so you see the windows login. Then connect again to the same computer, but the UserID and it will take you straight into the machine...

I KNOW, mental :(

Posted by amster
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

please ignore me, it doesn't work. I wish I could delete the posts. The explanation on the server and the user ID still stands as per others.

Posted by Nuhoglu
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hello

Today immeditaly I have the same problem after a few log in and log out due to my internet connection and now my screen is stuck to initializing display parameters message. Is there a way to solve this problem from my remote computer?

 

Thank you

Posted by doomy
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I will share what fixed the issue for me - I'm using TW in a non-english language so the labels might not be completely accurate, but hopefully it can still help.

in the My Computers section right click on the computer you are trying to connect to, then in the upper right corner of the popup click the settings icon, then select  Properties. In the dialog that appears, click Advanced settings. Change the first select field Remote desktop resolution to value Do not change. Then click OK.

this just fixed the problem for me

Posted by freshmetrics
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I find opening a second connection usually solves the problem. It will prompt to say there is already a connection open, but just carry on anyway. It's a pain, and needs sorting Teamviewer !

Posted by scubajwd
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@reverseswing wrote:

@Shayne wrote:

@kratjuh wrote:

I had the same issue. Both machines Version 12 and Windows 10 Pro, stuck in Initializing display parameters.

I was able to work around it: In TV client go to Settings -> Remote control -> disabled "Remove External Background" and selected "Optimal Quality" under quality. Then I connected and it worked again. Rebooted the machine to be sure.

Note: I use a Dutch version so the translation may be different in your TV.


This solution worked for me as well.  Thank you so much!


This worked for me as well. I don't get why this would happen though. it was fine and then all of a sudden the next login got stuck.


This worked for me also...TV after weeks of reliable service just out of the blue started failing to connect with " initializing display parameters"

Posted by so5719
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Update and solution

My connection from work to the headless Mac Mini was to a resolution not supported by my Mac Mini / TV SET even if turned off. So after i changed the resolution to a compatible resolution everything worked fine and still works

Hope it's helpful

Posted by GW1
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Since I upgraded to Version 12.081460 I have the same problem. Any fix available?

Highlighted
Posted by DiegoG31
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

I have the same issue with V12.0.8140.

 Please fix.

11 Replies
Posted by duane
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

This seems to happen pretty consistently to me when my PC is rebooted.  I can no longer connect to it with TV until I log on to the PC the first time.   This seems to happen whether I'm trying to connect using TV on another PC or with the IOS app.

For a test I rebooted the PC and tried to connect with my iPad.  It hung until I logged on to the pc. Then it connected.  After that it works until a reboot.  

Using current version of TV on ASUS pc running Windows 10 pro with current updates  

 

Posted by MattArmstrong
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

hi all,

I had this problem alot. In my case I was connecting to a machine but like most here it would hang at initialise display parameters. 

Both machines are Windows 10.

In my case the problem was the machine I was connecting to already had an RDP session established to it. Once I closed the RDP session to the machine, team viewer connected perfectly.

Posted by cbusylol
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

This has started happening to me once I've upgraded work laptops, from a consumer range i5 Win 10 Home to a i7 Win Pro.

In my experience it will crash when attempting to use the Window login screen on the remote laptop and will not allow me to reconnect (stuck on initializing video adapter). Sometimes I can get in, but explorer.exe will stop working soon into the session. If I disconnect then it requires a reboot of the remote system altogether (which I have to do through a different, better remote management suite that I subscribe to)

I use the same monitors, same USB dock, as I did the previous system. The difference between the two is the older system had a primary display on the laptop of 1366x768 and two 1920x1080 screens, and the new laptop is all three displays at 1920x1080.

This would be funny if these services like TV haven't become so laughably expensive. All of them have skyrocketed in subscription costs and there are more issues than ever (not to mention the features get chopped year after year unless you pay more for restructured packages). This goes for Logmein too, not just TV.

 

 

Posted by paulp
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

This problem has been on the list for ages without any definitive slution. What totally amazes me is the virtual silence from TV staff.  I used to think that German SW was really superior but no more.  Where are you TV? 

Posted by kqfflo
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

Hi,

I've faced this many times as well. In case you do not need to blank the targets screen I use this workaround:

  • Simply do not install the TeamViewer Display Driver

In case you see this or a similar screen asking for the installation of this driver you can prevent this issue by hitting [X] instead of using the buttons. See screenshot below (I know it's in German :smileywink: )kqf_close_driver_notification.png

Please keep in mind, that you may not be able to use all the "benefits" the driver offers.

Cheers,
Florian

Posted by richzeroes
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

I was getting a hang at "initializing display parameters". I had previously been using Windows Remote Desktop on this machine and it had no monitor attached to it. Once I hooked up a monitor, TeamViewer connected properly. Then I disconnected the monitor, tried again and it again connected properly.

Posted by bjoern
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

the new version 12.0.83369 fix this problem... :)

Posted by GeeZed
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

No, this problem started for me on version 12.0.83369.

The problem O.S. is SBS 2008

Posted by TheAssailer
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

This problem keeps occuring to my server as well.

Posted by GeeZed
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

My problem was a weird one, which is fixed now.  I will explain what happened to me and what I did to fix it.

I reboot the server one evening and after the reboot the server didn't come back online in my TeamViewer computer list.  So I remoted in to the server using RDP and everything looked fine except the TeamViewer ID for the server had changed. Strange! 

I updated the TeamViewer ID for this server in my computer list and then tried to remote in to the server again with TeamVeiwer, but this is when I saw the "initializing display parameters" hang for the first time.

I then uninstalled TeamVeiwer from the server, making sure to tick the box saying "Remove Settings". This removes most of the Registry Entries. 

I also deleted the TeamViewer appdata folders at these locations:
C:\Users\<your username>\AppData\Local\TeamViewer
C:\Users\<your username>\AppData\Roaming\TeamViewer

Finally I reinstalled TeamViewer.  This time the Server received its old orginal ID number!  Very weird.  Once it had its orginal ID everything went back to normal - No "initializing display parameters" problem.

I hope this helps someone