Posted by reidco
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

FIXED THE ISSUE

The issue I have with Version 12 is when I try to reconnect to my computer after closing out a session, the program hangs up and doesn't connect.  I never had this issue until I upgraded to Version 12.  I uninstalled Version on all of my computers and installed Version 11.  This has solved my issue and no more problems.

Posted by reidco
Henagon

Re: Initializing Display Parameters????

 FIXED THE ISSUE

The issue I have with Version 12 is when I try to reconnect to my computer after closing out a session, the program hangs up and doesn't connect.  I never had this issue until I upgraded to Version 12.  I uninstalled Version on all of my computers and installed Version 11.  This has solved my issue and no more problems.

Posted by DPBaker57
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

 I had the issue again today. I even tried to RDP in and it had that locked up too. When I got on the system directly Teamview was "Not Responding" and had to be restarted.

Posted by ISMAEL097
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hi Guys

Here is the solution please thank me later, Good Luck all

teamv.PNG

Posted by reidco
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

That totally makes sense.  However, I have downgraded to Version 11 which works and has not problem and I feel there is no benefit to me to upgrade and risk it not working while I'm away.

Posted by JD2525
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Remove remote wallpaper just worked for me. Thank you.

Posted by DPBaker57
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I have had remove remote walpaper set for a very long time. My Teamviewer 12 still hangs with "initializing display parameters"

What else do I try?

Posted by ISMAEL097
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

try to remove other options as shown in the screen shot

Posted by jrs
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I have DisplayFusion running on my Windows 10 box and I get this exact problem.  However, if I check the 'Remove remote wallpaper' while connecting from another PC it's fine.  My problem now is that I'm trying to use a Chromebook to connect (which is the same as logging into TV via the web, I believe) and there is no way to specify connection options and thus I cannot remove the remote wallpaper and the hang occurs. 

If I'm able to click on the desktop on the home computer (testing this at home, first) it crashes DisplayFusion and let's the connection succeed.  That's interesting but not particularly helpful if I'm actually trying to use this while remote :)

This all begs a couple questions:

  1. When will this get fixed?  I'm happy to revert to TV11 if I must, but geez.  I'm on 12.0.83369 and it's clearly been happening for a while
  2. When will the Chromebook/web version of TV12 provide the ability to control some options, like 'Remove remote wallpaper'?
Posted by mono6020
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I am having the same stupid problem and it makes me SICK!!

everything used to work perfectly until 2 days ago. the first connection after restarting the remote PC gets me half way through entering the password on the remote windows-login screen then a short flicker and everything freezes. after that every subsequential connection attempt just stays at initializing display parameters. last thing i did was updating nvidia drivers. OS is win10 pro 1703. all apps (incl. TV) on the latest version. NO WAY TO FIX THIS BUT TO RESTART THE TV SERVICE ON REMOTE MACHINE. are you fkn serious??

i am so looking forward if microsoft comes with a teamviewer alternative which works FLAWLESS. too much hype on this **bleep**ty little trojan style teamviewer piece of **bleep**code.

Posted by ISMAEL097
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Go to device manager and disable the building GPU and it you will be fine

Posted by mono6020
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

what is a building GPU? do you mean the built-in GPU, the onboard graphics adapter of my mainboard? thx for your answer

Posted by ISMAEL097
Digon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

yes

Posted by Jon
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I haven't had this problem in a long while, but now I updated both my client and the remote machine, and now I get this all the time again :mansad:

Posted by tyrannomac
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

jbclifton has the fix.  You need to get on the machine you are trying to control and do as jbclifton said below.  There are going to be two different server IDs.  One is for direct administration of the machine, the other is for multi-user mode...when there is one person using RDP and the other is using TeamViewer.  If you get the message "initializing display parameters" you are trying to use the multiuser ID.  You need the other one.

  • Got to the host host machine (the one you are trying to control). likley you will have to use RDP to do that
  • look at the box 'Your ID' on the left. to the right of that box i have an ! (in blue) that has a hover tag saying "enhanced multi user support...."
  • read that box and it basically states that the Teamviewer ID you see ISN'T the ID you need to administer the box
  • i changed mine to the ID they say you need to administer the machine and it works.
Posted by iamchuck
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@tyrannomac wrote:

jbclifton has the fix.  You need to get on the machine you are trying to control and do as jbclifton said below.  There are going to be two different server IDs.  One is for direct administration of the machine, the other is for multi-user mode...when there is one person using RDP and the other is using TeamViewer.  If you get the message "initializing display parameters" you are trying to use the multiuser ID.  You need the other one.

  • Got to the host host machine (the one you are trying to control). likley you will have to use RDP to do that
  • look at the box 'Your ID' on the left. to the right of that box i have an ! (in blue) that has a hover tag saying "enhanced multi user support...."
  • read that box and it basically states that the Teamviewer ID you see ISN'T the ID you need to administer the box
  • i changed mine to the ID they say you need to administer the machine and it works.


That's the fix! Worked for me thanks!

Posted by Orion13622
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Having the same issue while trying to connect to a Windows 10 Professional PC from another Windows 10 Professional PC.  While it doesn't happen every time, the only solution I have found is to restart the remote PC and then it may work a few times.

I am currently using version 13.0.371 on both PC's.
This issue started back in version 12, and it appears that the programmers have not investigated the issue that is causing this, and just pushed another version out.  This makes this software unreliable.

Programmers, please do some quality checking on your end and resolve this issue before you release version 14...

Posted by Columbia2011
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Also have the same issue! Hang continues over 2-3 minutes and remote session initialized. My opinion is TeamViewer Server which negotiates and initializes a session between IDs. 

I have an open support case 3586410. No really feedback. 

Posted by HawYNPunch
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Disable Fast User Switching to resolve the initializing display issue.

Posted by Columbia2011
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Where? In Windows (In the Registry Editor) or Teamviewer options? Please show a screenshot.

Posted by oldman_logan
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I discovered the issue for me. Teamviewer did this when my remote computer was awake but the user profile was either locked or logged off. In this case, teamviewer can only work when the user is logged on. A solution to this would be to setup Unattended access. With this, teamviewer is able to display the Windows Log on screen or lock screen that enables you to enter the local machine credentials (if user is logged off or locked) and then control it. 

Highlighted
Posted by Rusitoweb
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hello

In my case I tried all the alternatives that I could read in this post, but none solved my problem. Finally reading the manual of teamviewer 12. recommended to disable the option USE UDP in case of continuous connection failures

  Option menu - advanced - advanced network configuration (on the host computer).

With this change the problem was solved.
I hope it is helpful for everything.
Sorry for my english I'm using

Posted by sk33t3r
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Did you guys setup UNATTENDED ACCESS?  I made that mistake just now.  After setting up UNATTENDED ACCESS, I am now connected

Posted by CF
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

The reason  is probably that you installed teamviewer from within an RDP connection. If you do that, you need to make sure you get the right Teamviewer ID, the SERVER one, which you can find if you rightclick the teamviewer icon and then about.

Posted by JimNvnJr
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

If I need to connect with RDP in order to make TV connect, then why do I need TV?

Posted by DVS_MUNK
Photon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hi Guys,

i had this problem when connecting to my VM, its a simple fix you just need to setup Unattened access.

Connection > Setup Unattended access... > Next > 

enter a computer name of your choice & set a password you will use to connect > Next

Then if not already create a free TV account or sign in using your existing TV account > Finish

Then on main TV screen under remote control you will see Unattened access you need to select Assign to account, once selected enter email of your TV account

and thats it your done!!!

 

Posted by Clafer2017
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Hello : I have the same problem. The only way to connect to remote station is conecting to another PC in the same costumer and running Remote Desktop to the first PC. Then Teamviewer open in teh first PC. But if you minimize or close Remote desktop Teamviewer stop working.

Please someone to tell us how to setup the remote to have no problem to connect

My Teamviewer version is in both sides 12.0.95388

Posted by DasGolem
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

This is my problem also

Posted by joygilfedder
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503/12.0.72365

no RDP connected but teamviewer still freezes at initialising dispaly parameters, any other ideas

Posted by jimg903
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I'm using TV 12.0.9538

Remote client has Host mode istalled.

Local client has Full version installed.

I have dozens of installs, this one client is the only one that exhibits this message.

Here's what I did to fix it:

1.  Identify the TeamViewerID

     a. On my local computer from Computers and Contacts Right-Click on the computer that is exhibiting the error message.

     b.  Click on the gear in the upper right corner and click on Properties

     c.  Make not of the TeamViewerID (the 9 digit number)

2.  Under Control Remote Computer where it lists the Partner ID you should see an alias of your TeamViewerID.  (The name of the remote computer).

     a.  Replace the name of the remote computer with the 9 digit TeamViewerID from Step1 and Connect

I've been fighting this issue on one system for 2 years.  This works for me. 

Posted by Trin-iT
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

Thank you, "Remove External Background" is the culprit.

Why on earth is this feature on by default? I've had this happen so many times and been annoyed with it very often. 

Posted by idsej
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

"Remove External Background" is NOT the culprit. I have toggled it on and off and I still get the "Initializing display parameters".

There has yet not been a single fix in this thread.

Posted by tkuhmone
Trigon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

still occasionally this error on connection attempt "initialising display parametrs" and connection is not made. Manually interrupt and then try another time, overrides issue temporalily. I use 14.2.8352 preview build (windows)....

Posted by hoogw
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I solved the same problem by change display device to old sony TV (2009).

This issue only happen if you connect to some kind of moden monitor device.

If the remote device HDMI port have no wire, or the HDMI wire did not connect to a monitor,

Teamviewer will NOT working. I realize you must connect the HDMI wire to a real device and the device must turn power on.

If I connect to ASUS monitor 2017, it will freezing hanging as "initializing display parameters." for ever. 

If I connect to old 2009 sony TV(HDMI), solve the freezing problem. 

So the issue is caused by the display device that you connect to. 

Just try some other moniter, or TV, specially old Full HD tv, always solve this problem. 

 

Posted by hoogw
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

I solved the same problem by disable screen saver, disable any kind of standby.

Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

i think it's because mainly teamviewer cannot wake up the screen, so if the screen went to standby mode, teamviewer will not initialize the display.

the only fix i could find in this is to keep your display awake at all time. disable it from the power settings to never turn off display.

( Off course, you can turn off the power button on your monitor, but on unbuntu, you must disable screen saver and disble turn off display after 10 min, keep display on all time)

This is the ultimate solution. 

 

Posted by briangw
Electron

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503


@hoogw wrote:

I solved the same problem by disable screen saver, disable any kind of standby.

Teamviewer only connects when a monitor is attached and display is on, so to say screensaver or power save are the cause. As soon one uses the system, it wakes up, and so the display, and teamviewer does work again.

i think it's because mainly teamviewer cannot wake up the screen, so if the screen went to standby mode, teamviewer will not initialize the display.

the only fix i could find in this is to keep your display awake at all time. disable it from the power settings to never turn off display.

( Off course, you can turn off the power button on your monitor, but on unbuntu, you must disable screen saver and disble turn off display after 10 min, keep display on all time)

This is the ultimate solution. 

 


Teamviewer DOES NOT need the monitor on to work. I leave my server's monitor off all the time unless I need to go to the basement to interact with it. When I'm done, I shut it off. I've been using it this way for many versions of TV. I just recently swapped out PCs for my new server and started getting this issue. On my old server with the same version of TV, it worked with the monitor always off. Going to try some of the things suggested in here but I can assure you that you do not need your monitor on for this to work. 

Posted by jbmac05
Henagon

Re: Teamviewer initializing display parameters and hangs Version 12.0.71503

As someone else suggested, opening a file or folder on the target Mac seems to get around the problem for me, at least between two Macs.  Hope TeamViewer and Apple can get this issue resolved.