Posted by oxotnik
Henagon

There is no sound from the remote computer

On both computers 12 Team Viewer. On the remote computer WinXP x32, on my Win8.1 x64 is established. Why I have no sound from the remote computer and the Computer Sound button is inactive? Drivers on a sound of WinXP stand - Realtek.

71ad4-clip-6kb.png

20 Replies
Posted by Franzaudio
Digon

Re: There is no sound from the remote computer

Same over here

Posted by Franzaudio
Digon

Re: There is no sound from the remote computer

I did some tests on this with three machines:

A. Win10 #1
B. Win10 #2
C. OSX Sierra

A can listen to B and viceversa
C can listen to both A and B
Neither A or B can listen to C (the option is greyed out as in the OP screenshot)

I suspect this might be a limitation of Sierra/OSX
Any info/workaround would be greatly appreciated

Thanks for this great program

Posted by Former Staff Katharina
Former Staff

Re: There is no sound from the remote computer

Hi oxotnik, hi Franzaudio, 

Thank you for your posts!

You were actually on the right track. There are certain operating systems that cannot send system sounds, which is why TeamViewer cannot transmit any computer sounds in those cases.

Operating systems that cannot send systems sounds are Windows XP and all Mac operating systems.

I hope this answers your questions!

All the best, 

Katharina

Did my reply answer your question? Accept it as a solution to help others, Thanks!
Posted by Marty39
Photon

Re: There is no sound from the remote computer

Thanks, Katharina. Hope I'm not hijacking a thread.

I'm sitting at a Mac Mini running El Capitan, and when I use TeamViewer 12 to remote control a laptop running Linux Mint and TeamViewer 12 I get no sound, though streaming audio from the web is playing on speakers connected to the laptop.

You didn't say Linux can't send sound. Maybe Mac OS can't receive sound? All the audio options I can find in TeamViewer are enabled. Am I missing something?

Posted by KenJ
Henagon

Re: There is no sound from the remote computer

Here the remote computer is Win 7 and the local computer is Win 10. Sound used to work a while ago under TV11. Sometime after upgrading both machines to version 12, I realized I was not hearing any sound from the remote computer's sound source.  I have both configured for "full interaction and "share ... music" - nothing is "grayed-out". But it does not work.

Highlighted
Posted by FastThenLeft
Henagon

Re: There is no sound from the remote computer

I'm having problems with remote software from Win10 -> Win10 and Win10 -> Win7.  Used to work with Teamviewer11 but doesn't work with Teamviewer12.

Posted by Izel
Photon

Re: There is no sound from the remote computer

The remote pc is an apple and my laptop with which I am connecting is a lenovo with windows. 

I cannot hear the sound. The earphones are plugged in on the remote pc as to not bother the other people in that office. 

please help me find  a solution.

Posted by Riwa125
Photon

Re: There is no sound from the remote computer

I have the same problem. I am remote controlling my Win 10 desktop frome my Chromebook, but there's no audio. Have everything enabled, blah, blah, blah. Is this another case of OSX not being able to recieve sound? Or did I do something wrong? All help appreciated!

Posted by neverseen
Digon

Re: There is no sound from the remote computer

Hi Katharina,

 

That's not true. Windows XP can definitely send system sounds or so to say, it's definitely possible for an application running on an XP-Machine to capture system sounds in 3 ways. Either by using StereoMix, or by virtualicing a secondary soundcard that captures the sound and also passes it through to the primary/physical one, or the probably most intelligent method is by using a kernel driver like for example NCHSoftware does with thair soundtap streaming audiorecorder. The real problem is that TeamViewer uses the Windows Audio Session API's loopback device which is in fact not available in XP and also blocked in some Systems for security reason. So the TeamViewer Team simply didn't  chose the best way while programming the sound streaming functionality.

 

All the best,

Peter.

Posted by neverseen
Digon

Re: There is no sound from the remote computer

A possible but maybe a bit uncomfortable workaround should be the following: on the XP-Machine press windows+r, enter "mmsys.cpl", click okay, select the recording tap and chose "Stereo Mix" as your default recording device, click apply and then okay, then establish the teamviewer connection, enable VOIP and enable the microphone on the remote (XP) and the speaker on the local (8.1)-Computer.

Posted by drdra
Photon

Re: There is no sound from the remote computer

That is it! Stereo mix can even be hidden, you have to be sure to right click on the panel with recording devices and unhide everything. Than you can enable it. 

Posted by EdwinGZ6795
Photon

Re: There is no sound from the remote computer

I have got the same problem too.
The local computer is in Windows 7 and the remote computer is in Windows 10.
I remember when I'm using TV11, there were voices from the remote computer.
But after updating, I cannot hear any voice from the remote computer.

Hope someone can help me.

Posted by ekpegleg
Electron

Re: There is no sound from the remote computer

I have equal problems:

  1. Sound on Mac OS 10.12.5 is OK (checked, microphone OK)
  2. I runs TeamViewer 12.0.78517 (Sound on Mac OS is OK, checked, microphone OK)
  3. I runs a TeamViewer Remote session to Windows 10 (Sound on Mac OS break down, microphone break down)

Please find a solution.

Posted by koorpreest
Henagon

Re: There is no sound from the remote computer

Same problem!

Remote PC - Win 8.1, my PC with which I am connecting is win 10. 

I cannot hear the sound since i've updated to TV12!

Posted by Peter5
Henagon

Re: There is no sound from the remote computer

Mine is a slightly different problem. I'm using Macs at each end, but my view of the remote's audio and video windows is blanked out so I am unable to un-mute the mike or turn on the video. A user on the remote machine can do this, so there is no actual problem with sending A/V.

Posted by koorpreest
Henagon

Re: There is no sound from the remote computer

i just noticed that it works again!

Posted by catnamedmac
Digon

Re: There is no sound from the remote computer


@Peter5 wrote:

Mine is a slightly different problem. I'm using Macs at each end, but my view of the remote's audio and video windows is blanked out so I am unable to un-mute the mike or turn on the video. A user on the remote machine can do this, so there is no actual problem with sending A/V.



I am experiencing similar problems between Macs using TeamViewer 12. The remote Mac can hear me and if video is on can see me as well. However, I cannot hear any audio from the remote Mac. There are no audio controls displayed on the remote computer and the remote video controls are not active on that computer. I am running macOS Sierra.

Previous versions of TeamViewer did not experience these audio problems. It is unacceptable that a key functionality of TeamViewer is inoperable and a solution needs to be provided.

Posted by stevedonato
Digon

Re: There is no sound from the remote computer as of March 2018 tv13 & tv11

Here it is March 2018 and still no sound. I downgraded to version 11, as others said sound on remote worked on that version but, not for me. I installed tv11 on 2 laptops, both linux mint 18 no sound on remote. I also tried current v13 on linux to linux and windows to linux and linux to windows all NO sound on remote. basically this product has not worked as expected for the past 3 years with no remote sound. issue goes back to 2016. I was able to by pass this problem locally when both machines are in the same house using bluetooth earphones paired to the host, but not a real solution. I suggest we look for a product that works, maybe from open source

Posted by IMR
Photon

Re: There is no sound from the remote computer

"Operating systems that cannot send systems sounds are all Mac operating systems." Are you trying to find a solution.? Not a small chance ? This is a real problem !

Posted by mavinece
Electron

Re: There is no sound from the remote computer

open the teamviewer remote software installed in any cellphone or device. There are 3 icons consist of connect, computers ,chat. Make sure open the computer icon at the top 3 dotted icon click it will appear two option settings and help then next click settings. Look for advanced play computer sound make slide to on. Sound will be heard from browser. Thanks me