Announcements

Are you new to TeamViewer and Home Office and do you need some help? Check out our FAQ here.

Highlighted
Posted by
Henagon

Using company VPN blocks TeamViewer

I hope to use TeamViewer to remotely access (unattended) my company desktop at home #1 when I am at home #2. This works fine so long as my company desktop is not logged into the company VPN, which I must do to gain access to company resources (ie, do my job). When the company desktop is logged into the company VPN, using TeamViewer from home #2 fails to do unattended access, saying that the TeamViewer software is not running on the company desktop at home #1. When I get back to home #1, it's clear TeamViewer is running and the TeamViewer screen says "Not ready. Please check your connection." After I log out of the company VPN, the TeamViewer screen then says the connection is ready.

When I am at home #2, the company desktop at home #1 will not be logged into VPN, so I will be able to use TeamViewer to get access to the company desktop. But I suspect (have not tried it yet) that once I log into the company VPN on the company desktop thru a TeamViewer session, it will then block/terminate the TeamViewer session and I won't be able to do anything on the company desktop (I could probably use Windows Remote Desktop after this but I'd really prefer to stay with TeamViewer.) Any ideas how to resolve this issue?

5 Replies
5 Replies
Highlighted
Posted by
Henagon

Re: Using company VPN blocks TeamViewer

You can change the settings of Incoming LAN connections to "accept" and access the other one with IP.

Highlighted
Posted by
Henagon

Re: Using company VPN blocks TeamViewer

Thanks for the help! Unfortunately, I am ignorant of networking in general and TeamViewer specifically (just tried it out 2 days ago) and will need to be spoon-fed about how to do what you suggest. I am using Windows 10 Pro.

Highlighted
Posted by
Henagon

Re: Using company VPN blocks TeamViewer

Click on Extras, then Options. Under Network settings on the TeamViewer Options window,  you will see Incoming LAN connections. On your home #1, set it to accept as below.image.pngThen, open Command Prompt on home #1 and paste the below command
ipconfig | find "Address"

 Take a note of the number values (000.000.000.000) next to "IPv4 Address". Open TeamViewer on home #2 and type the number value acquired from home #1 (000.000.000.000) under Partner ID and you should be able to use TeamViewer locally.

Highlighted
Posted by
Henagon

Re: Using company VPN blocks TeamViewer

Thanks for the spoon-feeding! Unfortunately, these easy-to-follow steps did not work. Still could not connect from home #2 while company desktop at home #1 was logged into company VPN.

Highlighted
Posted by
Henagon

Re: Using company VPN blocks TeamViewer

**bleep**. My company's McAfee service has decided that TeamViewer is a malicious app and has automatically uninstalled it.