Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows built with our developers here.

Highlighted
Posted by
Henagon

I cannot update TV14 on CentOS 7.3 because TV host conflict with TV14.

I tried to update TV old version to TV 14 on campus cluster in which CentOS 7.3 was installed. I uninstalled TV host, and following your instruction on your website. When I upgraded TV, I received following error message below. Any suggestion with details would be highly appreciated.

 

Loaded plugins: fastestmirror, langpacks, priorities
Examining ./teamviewer_14.5.5819.x86_64.rpm: teamviewer-14.5.5819-0.x86_64
Marking ./teamviewer_14.5.5819.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package teamviewer.x86_64 0:14.5.5819-0 will be installed
--> Processing Conflict: teamviewer-host-14.5.5819-0.x86_64 conflicts teamviewer
Loading mirror speeds from cached hostfile
* base: mirror.es.its.nyu.edu
* cm-rhel7-7.3: updates-us-east.brightcomputing.com
* cm-rhel7-7.3-updates: updates-us-east.brightcomputing.com
* epel: fedora-epel.mirrors.tds.net
* extras: mirror.es.its.nyu.edu
* updates: mirror.es.its.nyu.edu
100 packages excluded due to repository priority protections
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package teamviewer-host.x86_64 0:14.5.5819-0 will be updated
---> Package teamviewer-host.x86_64 0:14.6.995-0 will be an update
--> Processing Conflict: teamviewer-host-14.6.995-0.x86_64 conflicts teamviewer
--> Processing Conflict: teamviewer-14.5.5819-0.x86_64 conflicts teamviewer-host
--> Finished Dependency Resolution
Error: teamviewer-host conflicts with teamviewer-14.5.5819-0.x86_64
Error: teamviewer conflicts with teamviewer-host-14.6.995-0.x86_64
You could try using --skip-broken to work around the problem
** Found 27 pre-existing rpmdb problem(s), 'yum check' output follows:
anaconda-core-21.48.22.93-1.el7.centos.0.1.x86_64 has missing requires of fcoe-utils >= ('0', '1.0.12', '3.20100323git')
intel-advisor-2017-cli-17.1-486553.i486 has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-cli-17.1-486553.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-cli-common-17.1-486553.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-doc-17.1-486553.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-gui-17.1-486553.i486 has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-gui-17.1-486553.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-advisor-2017-gui-common-17.1-486553.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-cli-17.1-484836.i486 has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-cli-17.1-484836.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-cli-common-17.1-484836.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-doc-17.1-484836.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-gui-17.1-484836.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-inspector-2017-gui-common-17.1-484836.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-mkl-common-c-132-2017.1-132.noarch is a duplicate with intel-mkl-common-c-132-2017.1-132.i486
intel-mkl-ps-common-132-2017.1-132.noarch is a duplicate with intel-mkl-ps-common-132-2017.1-132.i486
intel-mkl-ps-common-f-132-2017.1-132.noarch is a duplicate with intel-mkl-ps-common-f-132-2017.1-132.i486
intel-vtune-amplifier-xe-2017-cli-17.1-486011.i486 has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-cli-17.1-486011.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-cli-common-17.1-486011.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-collector-32linux-17.1-486011.i486 has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-collector-64linux-17.1-486011.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-common-17.1-486011.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-doc-17.1-486011.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-gui-17.1-486011.x86_64 has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-gui-common-17.1-486011.noarch has missing requires of lsb >= ('0', '3.0', None)
intel-vtune-amplifier-xe-2017-sep-17.1-486011.noarch has missing requires of lsb >= ('0', '3.0', None)
[root@bustard downloads]# cat /etc/redhat-release
CentOS Linux release 7.3.1611 (Core)

1 Reply
Highlighted
Posted by
Tetragon

Re: I cannot update TV14 on CentOS 7.3 because TV host conflict with TV14.

hi,

from the provided output:

Error: teamviewer-host conflicts with teamviewer-14.5.5819-0.x86_64
Error: teamviewer conflicts with teamviewer-host-14.6.995-0.x86_64

your attempt to uninstall teamviewer-host did not work.

br
Roland