Logging into Debian

Posted by Bazzzer
Henagon

Logging into Debian

When I try to login to Teamviewer Debian, it throws a Segmentation fault, referring to line 693.

I've tried uninstalling & reinstalling a number of times, with the same problem.

Incidentally, it seems to block me loging into LXDE, causing a loop back to it's login box. When I uninstall Teamviewer, it works OK!

Appreciate help / advice as I'm a complete Linux novice..teamviewer-debian-problem (Large).jpg

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Bazzzer
Henagon
Solution

Re: Logging into Debian

Hello Daniel,

After much hassle, and much frustration, I managed to install Teamviewer with a working LXDE.

Basically, I uninstalled the full version of Teamviewer, and stripped down LXDE to it's basic form, (purged it) then installed Teamviewer Host for Debian, which I eventually found on your website, and, amazingly all worked together. I was then able to launch Homeseer (which was what it was all about) from within LXDE.

So all is well.
Barry
PS
No other desktops were installed, and the version of Debian was the recomended one from here:
https://forums.homeseer.com/showthread.php?t=162813

2 Replies
Posted by Staff
Staff

Re: Logging into Debian

Hi @Bazzzer,

the crash in 'teamviewer setup' is known, will be fixed.

Do you want to use the headless mode or are you just trying to assign the device? You can also do that in the options dialog - at least if it starts. Do you have another desktop installed, besides LXDE that works?

On the LXDE issue: I just tried it on Debian testing (buster). LXDE does not even start for me when TeamViewer is not installed. What Debian are you on?
I then tried LXQt, which works. (But it does not support the tray icon)

Linux Developer
Highlighted
Posted by Bazzzer
Henagon
Solution

Re: Logging into Debian

Hello Daniel,

After much hassle, and much frustration, I managed to install Teamviewer with a working LXDE.

Basically, I uninstalled the full version of Teamviewer, and stripped down LXDE to it's basic form, (purged it) then installed Teamviewer Host for Debian, which I eventually found on your website, and, amazingly all worked together. I was then able to launch Homeseer (which was what it was all about) from within LXDE.

So all is well.
Barry
PS
No other desktops were installed, and the version of Debian was the recomended one from here:
https://forums.homeseer.com/showthread.php?t=162813