Not ready, please check your connection

Highlighted
Posted by
Neutron

Not ready, please check your connection

I am trying to use TeamViewer 14.1.3399 on Arch (manjaro) Linux at home, to remotely connect to my work computer, which is an Ubuntu Linux system also running TeamViewer. I have all the login credentials and stuff, but my home system says "Not Ready. Please check your connection". It won't allow me to log in or attempt to connect to anything.

Internet is working fine. I don't have a firewall for outgoing connections. I am able to ping master1.teamviewer.com as well as other servers. If I tell it to accept incoming LAN connections, then the status changes to "Only LAN connections are possible" but that is useless, since the computer I want to connect to is remote.

There is a setting "assign to an account" which I have not done, since this is my home computer and I'm not interested in allowing remote management or access to it. I can't find any explanation or documentation of this setting.

I don't know what to look for in the logfile. I see things like

2019/02/03 19:57:48.696 30134 -- GX0 Opening local TCP connection to 127.0.0.1:5940, tcp?
2019/02/03 19:57:48.697 30134 -- GX0!! Local TCP connection failed with error 111

and

2019/02/03 19:57:58.695 30134 -- GX0!! WorkingProxyListener::WorkingProxyResultHandler failed: 1
2019/02/03 19:57:58.695 30134 -- GX0! WorkingProxyListener::WorkingProxyResultHandler: setting default value ProxyType::Undefined

Things I have tried without  success:

  1. Setting DNS to google servers
  2. systemctl restart teamviewerd.service
  3. kill all teamviewerd to maek sure it is good and dead, then restart
  4. google searches on the topic
1 Accepted Solution

Accepted Solutions
Highlighted
Posted by
Neutron
Solution

Re: Not ready, please check your connection

Huh, after all that wall of text, I got it working...

I gave up on the TeamViewer client and went back to the website. I had created a new login to post in the community but had not signed into the main website at teamviewer.com. When I tried to sign in using my work credentials, it prompted me to add my browser as a trusted device and sent a Device Authorization email that gave me the option to register either an IP address or my device as a trusted device; I did the latter.

Wondering if that would have some effect, I tried restarting the teamviewer demon like this:

  • systemctl restart teamviewerd.service

but that had no effect. So next I tried killing the daemon completely and restarting from scratch. After doing that, teamviewer connected with a green light, knew who I was, and allowed me to connect to my remote system.

So the steps that I followed to make it work (on linux) were:

  1. Sign into Teamviewer website using work email and password
  2. Authorize my home computer using the email sent to my work account.
  3. sudo killall teamviewerd
  4. systemctl start teamviewerd.service
  5. start the UI

Note that it was necessary to start the teamviewerd service separately, as a step preceding the teamviewer UI. Without doing this the UI does not connect. But I think the key was the device authorization.

Since the UI management console link doesn't work when it is not connected, I had to go to the browser as a separate step and type in the URL manually. It would be nice if the UI told the user the device is unauthorized and gave a hint how to fix it.

View solution in original post

11 Replies
Highlighted
Posted by
Neutron
Solution

Re: Not ready, please check your connection

Huh, after all that wall of text, I got it working...

I gave up on the TeamViewer client and went back to the website. I had created a new login to post in the community but had not signed into the main website at teamviewer.com. When I tried to sign in using my work credentials, it prompted me to add my browser as a trusted device and sent a Device Authorization email that gave me the option to register either an IP address or my device as a trusted device; I did the latter.

Wondering if that would have some effect, I tried restarting the teamviewer demon like this:

  • systemctl restart teamviewerd.service

but that had no effect. So next I tried killing the daemon completely and restarting from scratch. After doing that, teamviewer connected with a green light, knew who I was, and allowed me to connect to my remote system.

So the steps that I followed to make it work (on linux) were:

  1. Sign into Teamviewer website using work email and password
  2. Authorize my home computer using the email sent to my work account.
  3. sudo killall teamviewerd
  4. systemctl start teamviewerd.service
  5. start the UI

Note that it was necessary to start the teamviewerd service separately, as a step preceding the teamviewer UI. Without doing this the UI does not connect. But I think the key was the device authorization.

Since the UI management console link doesn't work when it is not connected, I had to go to the browser as a separate step and type in the URL manually. It would be nice if the UI told the user the device is unauthorized and gave a hint how to fix it.

View solution in original post

Highlighted
Posted by
Photon

Re: Not ready, please check your connection

I am on Lubuntu 18.04.2 and encountering a similar issue. This only started after upgrading TV to 14.1.18533. I am not sure how to activate my device as I think my email has been confirmed.... starting the service did not fix the issue. I checked port 5938 fwiw

nmap -p 5938 teamviewer.com

Starting Nmap 7.60 ( https://nmap.org ) at 2019-03-02 17:29 EST
Nmap scan report for teamviewer.com (13.95.16.245)
Host is up (0.10s latency).

PORT     STATE    SERVICE
5938/tcp filtered teamviewer

Nmap done: 1 IP address (1 host up) scanned in 1.41 seconds
Highlighted
Posted by
Henagon

Re: Not ready, please check your connection

Hello I have similar experience, and I found that the daemon is not a working method even after authorizing the machine. This takes me weeks to debug. Eventually I turn to the tarball and just run the TV program and it works. I am using a Centos.

Highlighted
Posted by
Photon

Re: Not ready, please check your connection

Thanks for this, the key for me was:

  1. sudo killall teamviewer

Had some extra processes running in the back ground from previous starts. 

Highlighted
Posted by
Photon

Re: Not ready, please check your connection

The solution that worked for me:

On Teamviewer, Go to Extras > Options 

Enable "Start Teamviewer with System"

Click Apply

Reboot Your PC

Posted by
Digon

Re: Not ready, please check your connection

My old laptop linux system(s) were already running Teamviewer 12 and 13 sucessfully.. (I don't use them that much hence the old versions). However, when I tried to connect today from my Windows 10 laptop it refused because version 14 is incompatible. So I updated the linux system to version 14, and immediately got this error - same after a reboot. Looking on the Teamveiwer site, my laptop was already in the list of computers though showing offline. I found that I still had to run these three steps (thank you @barfoo ):

 

  • sudo killall teamviewerd
  • systemctl start teamviewerd.service
  • start the UI

 

 

1 Reply
Highlighted
Posted by
Henagon

Re: Not ready, please check your connection

Finally! I had to dig through way too many threads to find this. My solution was slightly different:

1. sudo killall TeamViewer (had to be capitalised like this)

2. systemctl restart teamviewerd.service (not sure if simply starting it would have done the trick)

3. Start TeamViewer from menu like normal.

I have no idea why this works, because restarting the computer did not help.

Highlighted
Posted by
Electron

Re: Not ready, please check your connection

**bleep** @Fabian42, it works for me too, the key was the capitalized TeamViewer command

Highlighted
Posted by
Photon

Re: Not ready, please check your connection

That worked for me too, thanks a lot!

Highlighted
Posted by
Electron

Re: Not ready, please check your connection

In Archlinux you have to activate the daemon with the command:

sudo teamviewer --daemon enable ... the console output is something like:

    Sun 19 Apr 2020 07:51:32 PM CEST
Action: Installing daemon (15.4.4445) for 'systemd' ...
installing /etc/systemd/system/teamviewerd.service (/opt/teamviewer/tv_bin/script/teamviewerd.service)
Try: systemctl enable teamviewerd.service
Created symlink /etc/systemd/system/multi-user.target.wants/teamviewerd.service → /etc/systemd/system/teamviewerd.service.
systemctl start teamviewerd.service

 Then just run Teamviewer.

Ensure that the file /etc/gdm/custom.conf has the line 'WaylandEnable=false'  uncomented.

Highlighted
Posted by
Photon

Re: Not ready, please check your connection

I had this same issue and this completely worked for me. 

Thanks for the solution

Jon