Highlighted
Posted by andxnagy
Digon

Re: Not ready. Please check your connection in Ubuntu

Complete removal did not help either (xubuntu 16.10 64 bit) :(

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Not ready. Please check your connection in Ubuntu

Dear andxnagy,

Thank you for your feedback.

Let's check if you're having issues resolving DNS.

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4

Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart

Let us know if that solution works for you.

 

Best regards,

Christian Cay

Did my reply answer your question? Accept it as a solution to help others, Thanks.

View solution in original post

13 Replies
Highlighted
Posted by Taki
Digon

Re: Not ready. Please check your connection in Ubuntu

Posted by Community Manager
Community Manager

Re: Not ready. Please check your connection in Ubuntu

HI @andxnagy

did Taki´s solution help you?

Thanks,

Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

9 Replies
Highlighted
Posted by andxnagy
Digon

Re: Not ready. Please check your connection in Ubuntu

Hi,

sorry for my late response ... but the solution to use a non-installed version (TAR.XZ) did not solve the problem ... however I tried another temporary "solution" and added a TW extension to Chrome in linux - what helped to connect via web browser.

The original problem still exist - i.e. when I reboot my laptop sometimes it starts with "Lan mode" only ... and the only solution I found so far is to reboot 2-3 times till the connection is normally established with the TW server and I can log-in to my account.

Best regards,

András

Highlighted
Posted by Community Manager
Community Manager

Re: Not ready. Please check your connection in Ubuntu

Thank you @andxnagy for your reply.

I hope, we will find a solution for you in the Community. I know, that there a quite a lot Linux experts in this Community!

Otherwise, we can ask @ChristianCay 

Thanks again,

Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Not ready. Please check your connection in Ubuntu

Dear andxnagy,

Thank you for your feedback.

Let's check if you're having issues resolving DNS.

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4

Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart

Let us know if that solution works for you.

 

Best regards,

Christian Cay

Did my reply answer your question? Accept it as a solution to help others, Thanks.

View solution in original post

Highlighted
Posted by andxnagy
Digon

Re: Not ready. Please check your connection in Ubuntu


@ChristianCay wrote:

Dear andxnagy,

Thank you for your feedback.

Let's check if you're having issues resolving DNS.

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4

Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart

Let us know if that solution works for you.

 

Best regards,

Christian Cay


Dear Christian,

Thanjk You for the suggestion ... I have not changed the DNS servers, but added them to the "IPV4 Settings" - "Additional DNS servers" in the "Network Connections" ... after that I restarted TeamViewer 7-8 times and all of them connected properly (i.e. the problem seems to be solved).

Best regards,

András

Highlighted
Posted by slavikgreen
Photon

Re: Not ready. Please check your connection in Ubuntu

restart helps. Ubuntu 16.04. Teamviewer 12.071510

Highlighted
Posted by ack0329
Trigon

Re: Not ready. Please check your connection in Ubuntu

Here ism a solution for general network (DNS, Server, Connections, Loading, Teamviewer ...)  issues which solved the Teamviewer "Not Connecting".  I realized that this issue was originating from a service called ‘systemd-resolved’. This is a DNS caching and validating service that comes pre-installed with Ubuntu 17.04

The solution came from tjis website

https://www.hecticgeek.com/2017/04/ubuntu-17-04-systemd-dns-issues/.service NetworkManager status

Go to the Update section half way down

Highlighted
Posted by ack0329
Trigon

Re: Not ready. Please check your connection in Ubuntu

Re: Ubuntu Linux refuses to connect to Teamviewer servers

After solving the issue as per my previous post, I had some other network issues from my messing around with it and I re-installed Ubuntu-Gnome 16.04.3 (the  newest of course) and ...

All is fine now.

(perhaps uinrelated but logging into the "Default" session instead of Gnome or the other 3rd option, solved some issues as well - heck if I know why, but it may be worth a try)

Highlighted
Posted by kinza
Electron

Re: Not ready. Please check your connection in Ubuntu

thank you! 

Highlighted
Posted by kinza
Electron

Re: Not ready. Please check your connection in Ubuntu

Thank you (Y)

Highlighted
Posted by WizKI
Electron

Re: Not ready. Please check your connection in Ubuntu

@ChristianCay wrote:
Dear andxnagy,

Thank you for your feedback.

Let's check if you're having issues resolving DNS.

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4
Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart
Let us know if that solution works for you.

 

Best regards,

Christian Cay

Dear Christian,

Thanjk You for the suggestion ... I have not changed the DNS servers, but added them to the "IPV4 Settings" - "Additional DNS servers" in the "Network Connections" ... after that I restarted TeamViewer 7-8 times and all of them connected properly (i.e. the problem seems to be solved).

Best regards,

András

 

Hello, all,

I've tried this solution on my Linux Manjaro and it works. But after each PC reboot I need to manually restart the teamviewer daemon in the terminal.

I tried to add the restart command in ~/.xinitrc, but no effect. I also tried to add a shell script in the ~/.config/autostart, but it doesn't work either.

Could you suggest me anything?

Kind regards,

Kirill

Highlighted
Posted by shinanqu
Henagon

Re: Not ready. Please check your connection in Ubuntu

I have the same issue.

I tried Google DNS, restarted the service many times, signed in with the browser and authorized my device, reboot etc. Can't make it work.

It worked previously on other OS, like MX Linux. But on Manjaro it just doesn't want to connect.

System:    Host: manjaro-2019-11 Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Xfce 4.14.1 
           Distro: Manjaro Linux 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 
           IF: wlp1s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter>