Highlighted
Posted by Kaleb
Henagon

TeamViewer_Desktop crashes on incoming connection: TeamViewer 14 on Ubuntu 18.04

Like the subject says: when there is an incoming connection, TeamViewer gets through the handshake, then TeamViewer_Desktop crashes. Relevant excerpt from the log:

Negotiating session encryption: client handshake received
Negotiating session encryption: client handshake received
Negotiating session encryption: server handshake sent, encryption established with AES key length 256
HandleSigChld: Child was dumped: 1744 signal 11
ProcessControlBase[4]: Process 1744 in session **Please do not post TeamViewer IDs** has terminated

(1744 is the PID of TeamViewer_Desktop)

Brief history if it's relevant:

  • was on Ubuntu 12.04 LTS. Everything worked fine until when trying to connect I got an error that TeamViewer on the remote server was too old.
  • Updated TeamViewer, but it wouldn't start due to something with the getRandom that some other people had problems with.
  • Upgraded to Ubuntu 14.04 LTS. Reinstalled TeamViewer and could connect, but after logging in, it would hang and reconnect just left me with something about trying to initialize the display. (some point in here I tried various versions of 14)
  • I dug into the logs and found some suspicious stuff (like a QT 5 X11Extras missing and the package not being found on the standard source lists)
  • Upgraded to Ubuntu 18.04. Reinstalled TeamViewer. It crashes on connect.

Let me know if it would help to post the logs, or core/stack dump. Please help me.

 

EDIT: It's also potentially noteworthy that this is somewhat of a headless server. I say somewhat, because  I've stuck a couple of resistors in certain pinholes of the VGA port, so the computer thinks it' connected to a monitor and starts up X normally (or at least it did in 12.04).

1 Reply
Posted by Kaleb
Henagon

Re: TeamViewer_Desktop crashes on incoming connection: TeamViewer 14 on Ubuntu 18.04

UPDATE: So, I have gotten things to work, mostly, with the following work-around:

  1. remove the remote server from my list of partners (the entry added by running "teamviewer setup" [same thing as assigning it to your account in the GUI, I think] on the remote server is invalid... well more specifically, it won't connect using the server ID)
  2. Install RDP on remote server and port forward appropriate ports (really just get some other way of accessing the server graphically)
  3. remote in using RDP and launch TeamViewer
  4. Open options and set your password to access that machine; hit OK
  5. note the listed User Id
  6. back on the client, add a new remote server
  7. use the User Id you noted and the password you created and name it what you want
  8. Now it connects successfully (As long as the Teamviewer GUI is open... See Edit2 below)

So, I think this is still a bug, since connections using Server Id crash. I would like to get this back to where I can use double-click to connect, but at least this gives me access for now.

EDIT: I just realized double-click still works. I just had to manually click "Connect using password" once, I guess... So, even though there's either a bug in TeamViewer or something wonky with my setup, I will mark this as the solution since it gets things working for me in the end.

EDIT2: Some of you may have realized my folly here... This only works if you open the TeamViewer GUI on the remote machine. So, this doesn't actually solve my problem, as I'm unable to connect after reboot. I need to be able to use the Server Id instead of the User Id.