Announcements

TeamViewer 14.5 has been released. See the Change Logs here.

Posted by dmc_dtc
Digon

Teammviewer 13.0.6634 not working on fedora 26 64 bit

 Hi,

I've just upgraded from teamviewer 12 to teamviewer 13.0.6634 on Fedora linux 26, and the service teamviwerd is starting but the gui fails, i just get this message and nothing

bas# teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

bash#

uname -a
Linux ascendancy 4.12.14-300.fc26.x86_64 #1 SMP Wed Sep 20 16:28:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I've downloaded /teamviewer_13.0.6634.x86_64.rpm and installed it with rpm-i /teamviewer_13.0.6634.x86_64.rpm and no deps problems

here is logfile

2017/12/25 17:27:22.405 11143 140624037141824 G   LogindSessionInfo: New session LogindSessionInfo [id=1 user=root state=user active=1 reliable=1 infoId=2212294583] [path=/org/freedesktop/login1/session/_31 TTY=tty1 seat=seat0 display= vtnr=1 owner=[SysUser: root [uid=0, gid=0 home=/root gecos=root shell=/bin/bash]] idle=1(1513780808191110) active=1 type=tty class=user state=active timestamp=1513780809523267 service=login defaultCG= leader=1834 audit=1 remote=0 rHost= rUser= killProc=0]
2017/12/25 17:27:22.407 11143 140624037141824 G   SysSessionInfoManager: observing sessions from logind is marked as reliable
2017/12/25 17:27:22.407 11143 140624037141824 G   SysSessionInfoManager: Session Information provided by VT [priority: 2]
2017/12/25 17:27:22.407 11143 140624037141824 G   FBSessionObserver: Framebuffer device /dev/fb0 has 8bit depth. Only 32bit and 16bit are supported.
2017/12/25 17:27:22.407 11143 140624037141824 G!  FrameBuffer: Cannot access /dev/fb0, frame buffer support unavailable
2017/12/25 17:27:22.408 11143 140624037141824 G   SysSessionInfoManager: own session cache set to '4294967295'
2017/12/25 17:27:22.408 11143 140624037141824 G   Running on Qt 5.9.2
2017/12/25 17:27:22.457 11143 140624037141824 G   Initialised XRandR extension 1.5 (base=88 error=145)
2017/12/25 17:27:22.532 11143 140624037141824 G   MonitorInfo: [XRandR 1.2] CRTC DVI-I-0 1280x1024@60Hz [1920, 176, 3200, 1200] - 1
2017/12/25 17:27:22.532 11143 140624037141824 G   MonitorInfo: [XRandR 1.2] CRTC DVI-D-0 1920x1080@60Hz [3200, 120, 5120, 1200] - 1
2017/12/25 17:27:22.532 11143 140624037141824 G   MonitorInfo: [XRandR 1.2] CRTC DP-0 1920x1200@60Hz [5120, 0, 7040, 1200] - 1
2017/12/25 17:27:22.532 11143 140624037141824 G   MonitorInfo: [XRandR 1.2] CRTC HDMI-0 1920x1080@60Hz [0, 120, 1920, 1200] - 1
2017/12/25 17:27:22.532 11143 140624037141824 G   Virtual Desktop [0, 0, 7040, 1200]
2017/12/25 17:27:22.536 11143 140624037141824 G   InterProcessBase::SecureNetwork created
2017/12/25 17:27:22.537 11143 140624037141824 G   AutoLogin::Login: enabled: 1
2017/12/25 17:27:22.537 11143 140624037141824 G   WindowsSessionStateManager(0x1e8a930) state 0
2017/12/25 17:27:22.537 11143 140624037141824 G!!!Own session could not be resolved, unable to startup, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!! ConfigurationHub::HandleRegistrationResponse(): registering for feature 5 failed with error 2, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!! ConfigurationHub::HandleRegistrationResponse(): registering for feature 6 failed with error 2, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!! ConfigurationHub::HandleRegistrationResponse(): registering for feature 9 failed with error 2, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!! WorkingProxy::Listener::WorkingProxyResultHandler failed: 2, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!  WorkingProxy::Listener::WorkingProxyResultHandler: setting default value ProxyType::Undefined
2017/12/25 17:27:22.537 11143 140624037141824 G!! WorkingProxy::Listener::WorkingProxyResultHandler failed: 2, Errorcode=11
2017/12/25 17:27:22.537 11143 140624037141824 G!  WorkingProxy::Listener::WorkingProxyResultHandler: setting default value ProxyType::Undefined
2017/12/25 17:27:22.537 11143 140624037141824 G!! ConfigurationHub::HandleRegistrationResponse(): registering for feature 10 failed with error 2, Errorcode=11
2017/12/25 17:27:22.538 11143 140624037141824 G   interprocessbase::SecureNetwork destroyed
2017/12/25 17:27:22.540 11143 140624037141824 G   Shutting down System DBus

Also tried as non root user, same thing

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by J_Reis
Trigon
Solution

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Likely you have done so, but just to cover all bases, did you restart X using lightdm. For myself, I actually installed xfce to see if TV would work with a DE installed. Then rebooted (which brought me to lighdm), after logging in (through lightdm) and having xfce load, I started TV and it worked. I then logged out (returned to lightdm) and logged into jwm (the WM in which TV hadn't been working) and TV then worked in jwm as well. Ultimately as long as my X session was launched through lightdm TV worked. If I dropped to console and used startx—TV was back to the behavior I described originally—where no GUI would appear.

Entirely possible you're issue is different, hopefully you'll get some real tech support at some point. Just thought I'd chime in with what (little) I know.

3 Replies
6 Replies
Posted by J_Reis
Trigon

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Perhaps this is the same (or closely related to) the issue I was having and posted --here--. The symptoms are the same, with teamviewrd returned via ps. and the same output to terminal that you descirbed. 

12-20-2017_01-25-07pm.png

No GUI would ever materialize. Some details are available in that thread linked, but the issue was eventually resolved by installing lightdm—I assume any display manager would work. You didn't mention anything non-standard regarding your X session, but if you aren't running with the usual Gnome/KDE type of arrangement, you might want to experiment with different session management.

Posted by dmc_dtc
Digon

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

I do use startx to login into my session, but in the meantime i've also tried teamviewer 13 on my other machine (mac pro with fedora 27) and it is the same result. On that machine i have lightdm and gnome3 and same happens there also. And on my system i have installed lightdm and still doesnt work?

Highlighted
Posted by J_Reis
Trigon
Solution

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Likely you have done so, but just to cover all bases, did you restart X using lightdm. For myself, I actually installed xfce to see if TV would work with a DE installed. Then rebooted (which brought me to lighdm), after logging in (through lightdm) and having xfce load, I started TV and it worked. I then logged out (returned to lightdm) and logged into jwm (the WM in which TV hadn't been working) and TV then worked in jwm as well. Ultimately as long as my X session was launched through lightdm TV worked. If I dropped to console and used startx—TV was back to the behavior I described originally—where no GUI would appear.

Entirely possible you're issue is different, hopefully you'll get some real tech support at some point. Just thought I'd chime in with what (little) I know.

3 Replies
Posted by dmc_dtc
Digon

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Apparently you are right, as soon as i rebooted with lightdm enabled it worked. But it is no solution since i cannot use lightdm on both machines, and i cannot believe this is dependency, i would understand in sense of libraries needed, but for teamviewer to work only if lightdm enabled it is incredible for me. Thank you Sir for your reply, but i guess i will have to find some other solution for desktop sharing now.

 

Posted by J_Reis
Trigon

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Oh, I quite agree. It seems like a very odd choice from the developers—though I'll grant it is possible there is some technical limitation that forces it, I cannot imagine what it could be. Still, it's a beta … so hopefully they'll take notice of the feedback here and be able to provide an alternative for us. I'm still hopeful the non-installed tar package will eventually work without lightdm and we'll be able to simply start it up ourselves (or by script) when we want it.

Glad we were able to identify your issue at least.

Posted by dmc_dtc
Digon

Re: Teammviewer 13.0.6634 not working on fedora 26 64 bit

Yes i Agree that identifing the issue is very important here, because i am sure others will have similar problem too, and i am sure teamviewer can work without lightdm/*dm, because version 12 did :) i suppose TV13 can also be made to work without such dependency... In any case thank you again and hopefully someone from teamviewer will see this post.