Announcements

Would you like to co-innovate with us? If so, we’d like to invite you to become product development partners with us. Read more about it in our announcement Launch of the TeamViewer User Focus Program

Posted by Swe007
Digon

Teamviewer on headless CentOS

Hi, I'm running a Windows 10 laptop and a CentOS 6.5 remote server. I'm trying to get Teamviewer 12 setup to run on the CentOS server headless. When I have a monitor connected, everything works great - file transfers and remote desktop. However, when I reboot the computer without a monitor connected, the computer never shows up in Computer and Contacts as online, but I can SSH into the computer and it says Teamviewer is running. Anyone able to help with this?

6 Replies
2 Accepted Solutions

Accepted Solutions
Posted by Swe007
Digon
Solution

Re: Teamviewer on headless CentOS

Posted by Swe007
Digon
Solution

Re: Teamviewer on headless CentOS

As mentioned in the above post I marked as the solution, you need to alter the xorg.conf file. I added the section that creates a virtual display at the bottom like this:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseDisplayDevice" "none"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "off"    
    Option         "Stereo" "0"
    SubSection     "Display"
        Virtual    3840 1080 ****Your resolution needed here****
        Depth      24
    EndSubSection
EndSection
6 Replies
Posted by Swe007
Digon
Solution

Re: Teamviewer on headless CentOS

Posted by PJeasyIOeu
Electron

Re: Teamviewer on headless CentOS

Im getting the same issue on CentOS 7 , when no monitor is conected i cant get teamviewer to load 

Posted by ylluminate
Digon

Re: Teamviewer on headless CentOS

This issue really wasn't ever solved and so I put an appropriate question up that pertains to CentOS 7 right here.

Posted by Swe007
Digon
Solution

Re: Teamviewer on headless CentOS

As mentioned in the above post I marked as the solution, you need to alter the xorg.conf file. I added the section that creates a virtual display at the bottom like this:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseDisplayDevice" "none"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "off"    
    Option         "Stereo" "0"
    SubSection     "Display"
        Virtual    3840 1080 ****Your resolution needed here****
        Depth      24
    EndSubSection
EndSection
Posted by ylluminate
Digon

Re: Teamviewer on headless CentOS

That is not the solution. Even upon adding this the system still complains:

The framebuffer console seems to be unavailable or has the wrong format. Please make sure that /dev/fb0 is accessible and it is configured to 32-bit depth.

Posted by josephlm
Henagon

Re: Teamviewer on headless CentOS

Where is the xorg.conf file found?