Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by Chris204

Android Host - Can't transfer files to SD card


I wanted to use TeamViewer to transfer a file from my desktop PC to the external SD-card in my android phone. This doesn't work and gives me the following error:


I'm using theTeamviewer 12 on my PC and Host for Samsung 11.0 on my android phone.

The Phone is a Samsung Galaxy S7 with Android 7.0

4 Replies
Posted by praveenvvas

Re: Android Host - Can't transfer files to SD card

Dear all

 I have a strange issue here. I m connected to my windows 7 machine through my samsung galaxy A7. I wanted to copy some files over the Wireless lan to my android phone. I can copy files to only my phone memory and I m not ale to write to SD Card. When I copy to SD card suddenly screen will flash and no file is copied. Need help.

P.S : Antivirus disabled on Win 7 machine.


Praveen Vincent Vas

Posted by Rodrigokaruk

Re: Android Host - Can't transfer files to SD card

One way is create a Folder Download using teamviewer in SDcard/Android/data/

Posted by Moderator Moderator

Re: Android Host - Can't transfer files to SD card

Hi Chris204,

Thank you for your message.

As of right now TeamViewer RC only supports file transfers with the primary external storage. In this case Android defines the built-in memory as first external storage (external just means "not the system storage"), so the you can only upload/download files from/to this storage.

Our developers are aware of this situation and are already working on a solution.

Right now there is no (easy) workaround to fix this issue, but if you are an expert and your device is rooted there is a chance for you to create your own navigation: creating a symlink ( in your first external storage pointing to the sdcard.

Unfortunately, we do not support this workaround and have only provided it as a temporary workaround for your perusal.

Please let us know if you have any additional questions...

Best regards,


Posted by MichaelOpatz

Re: Android Host - Can't transfer files to SD card

We have now Teamviewer 14 (in connection with Sanasung S8+, Android 8.0.0) and this problem obviously is still not solved. When it will be solved?