Posted by CC-Nordic

TeamViewer 14 fails to uninstall

Hi, we're having an issue when trying to uninstall TeamViewer 14. We've tried both manually on each client as well as using a deployment tool (PDQ Deploy) to uninstall via a msiexec command line.

We get the following error:


We are doing the uninstall with domain admin privileges.

Does anyone else have this issue?

3 Replies
Posted by jdoty

Re: TeamViewer 14 fails to uninstall

I am having the same problem.  I was doing an install of the host on a test box so I could generate my .Reg file and 13 didn't uninstall.  So I uninstalled 13 from the control panel and then then tried to uninstall 14 as well, but it would not uninstall.  It gives me a 1603 error.  I tried the MSIEXEC.exe method and added a log which is where I got the error.  A little help would be great.  I don't want to have to reimage the box and start over if I don't have to.  We are a corporate license. and this is version 14.1.9025 (custom host).

Thanks in advance.

Posted by HeinM

Re: TeamViewer 14 fails to uninstall

Use the following:

Rem Uninstall Teamviewer
c:\windows\system32\sc stop TeamViewer
c:\windows\system32\ping -n 2

c:\windows\system32\taskkill /f /im TeamViewer.exe

c:\windows\system32\Taskkill /F /IM TeamViewer_Service.exe
c:\windows\system32\ping -n 2

msiexec /uninstall C:\Teamviewer\Teamviewer_host.msi /qn
msiexec /uninstall c:\Teamviewer\Teamviewer_full.msi /qn
msiexec /uninstall c:\teamviewer\TeamViewer_Support-idc*.msi /qn
"C:\Program Files (x86)\TeamViewer\TeamViewer_Service.exe" -uninstall
"C:\Program Files (x86)\TeamViewer\TeamViewer.exe" api --uninstall
"C:\Program Files (x86)\TeamViewer\uninstall.exe" /S
"C:\Program Files\TeamViewer\TeamViewer_Service.exe" -uninstall
"C:\Program Files\TeamViewer\TeamViewer.exe" api --uninstall
"C:\Program Files\TeamViewer\uninstall.exe" /S

c:\windows\system32\ping -n 30

C:\Windows\System32\wbem\wmic product where vendor="TeamViewer" call uninstall

c:\windows\system32\ping -n 30
c:\windows\system32\reg delete "HKLM\Software\TeamViewer" /f
c:\windows\system32\ping -n 2

cd "%temp%"
if exist *teamviewer*.* del *teamviewer*.* /s /f /q

c:\windows\system32\reg delete "HKLM\Software\TeamViewer" /f
c:\windows\system32\reg delete "HKCU\Software\TeamViewer" /f
c:\windows\system32\reg delete "HKCU\SOFTWARE\Wow6432Node\TeamViewer" /f
if exist "C:\Program Files\Teamviewer" rd /S /Q "C:\Program Files\Teamviewer"
if exist "C:\Program Files (x86)\Teamviewer" rd /S /Q "C:\Program Files (x86)\Teamviewer"
if exist "%LOCALAPPDATA%\Temp\TeamViewer" rd /S /Q "%LOCALAPPDATA%\Temp\TeamViewer"
if exist "%LOCALAPPDATA%\TeamViewer" rd /S /Q "%LOCALAPPDATA%\TeamViewer"
if exist "C:\Teamviewer" rd /S /Q "C:\Teamviewer"

c:\windows\system32\ping -n 15


Posted by jdoty

Re: TeamViewer 14 fails to uninstall