TeamViewer IoT is hiring! Check out the open positions here!

Posted by truevoice

Wont install

Hi I am trying to install teamviewer on my raspberry pi dietpi and the instructions seem to be for advanced users because i cant seem to get it right can anyone help me please we would like to purchase if we can get it to work.

5 Replies
Posted by truevoice


Has anyone managed to get teamviewer to work on dietpi please need help

Posted by TeamViewer Staff
TeamViewer Staff

Re: TeamViewer

Hi @truevoice,

Please give more details whether you mean TeamViewer IoT or TeamViewer product?




3 Replies
Posted by leewilmus

Re: TeamViewer

Hi I have used this instruction to install on my raspberry pi/dietpi

And everything seems to work but when I connect it authenticates then nothing happens can you help me please we really want to get this working so that teamviewer can be our choicen supplier.  At the moment we using Realvnc but we want to move

Posted by TeamViewer Staff
TeamViewer Staff

Re: TeamViewer

Hi @leewilmus

Thank you for your enquiry. 

Can you clarify, what happens after the authentication process? If you see a blank window, this means, that your webserver is not configured properly.

Please see the following manual for more details:

TeamViewer IoT connects you to a web interface running on the remote device to control a machine connected to your device. 

If you want to have full remote control (desktop access) of the dietpi, please install TeamViewer Host from

Please do let us know if you have any further questions and we will be happy to assist you.

Posted by Nooby1234

Re: TeamViewer

I’m having a similar problem.... ( I’m a novice) that the TeamViewer iot deb file that I installed seemed to work but didn’t ask me for the TeamViewer permission part? I have the desktop icon installed but when I double click it loads with the command box and then dissapears with no TeamViewer codes?
I’ve tried uninstalling and reinstalling abd using code I found to do an update. Tried the Linux 32/64 but deb files that both appear with a box saying ‘package cannot be found to perform this task’ any ideas ?