teamviewer.com link icon
or
Ask The Community

Mac Mojave with old version Team Viewer 11

Good evening, I work with a MacOS Mojave version 10.14.6. My boss and I need to work with TeamViewer 11, he is able to work with it with no problems because he has windows operating systems. I cannot operate on my mac with with old version of teamviewer, how can we do? is there a way to work on the mac with older versions of teamviewer? Thank you 

Tagged:

Comments

  • JeanK
    JeanK Posts: 3,846 Moderator

    Hello @FedeRubino,

    Thank you for your message and welcome to the TeamViewer Community! ?

    Unfortunately, macOS Mojave is not compatible with TeamViewer 11.

    2020-09-08 10_14_05-Clipboard.png

    You will need to use at least TeamViewer 14 on both devices to get a functional remote control experience.

    More information here: How to control a Mac running macOS 10.14 or higher 

    I hope this could help. ?

    If not, do not hesitate to ask your questions here. ?

    Best regards

    Jean

    French Community Moderator
Sign In or Register to comment.