teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Failed connection due to false claim of the remote teamviewer is running an old version

I have updated my TeamViewer to the newest version  15.10.5 (bcaa34a2a33) ,  I am using MacOS 10.15.3. I already checked the operating system and TeamViewer version on both my device and remote device and  there are supported. But the connection still false and it claim that " the remote teamviewer is running an old version".
I tried every solution: quick Team Viewer, restart devices..., but it't still not work
I  am use teamviewer in vietnam, are there any restrictions in my country.
Could someone help me fix this issue.image.png

Comments

  • JeanK
    JeanK Posts: 4,718 Senior Moderator

    Hello @khang165

    Thank you for your message and welcome to the TeamViewer Community! ?

    If you are using the free version, you must use the latest version on both sides of the connection.

    You will find all the information you need in our Knowledge Base article here: Enjoy using the best version of TeamViewer we made so far! - How to proceed? 

    Note: If the hardware used on the local or on the remote side of the connection is not compatible with the latest version (please see our compatibility article here: Compatibility macOS, there is, unfortunately, nothing we can do to make the free version work. We thank you in advance for your understanding.

    I hope this could help. ?

    Best regards

    Jean

    French Community moderator

     

    Soutenez-nous sur Trustpilot

    -----

    Support us on Trustpilot