teamviewer.com link icon
or
Ask The Community

Disable Audio for remote sessions with a policy

flospi
flospi Posts: 27 ✭✭
edited November 2021 in General Questions

We are currently migrating to Microsoft Teams. So when one of our support guys is talking to someone on the "phone" and that "phone" is also Microsoft Teams, TeamViewer will also add Audio to a remote session, which results in funny results.

So the question is: How can I deactivate audio for all TeamViewer Installation via the Management Console and Policies?

Second issue (which will be obsolete, when the above can be solved): As soon as the TeamViewer session is started, the volume in Teams drops so the support guys hardly understand the other side.

Comments

  • JeanK
    JeanK Posts: 5,593 Community Manager 🌍

    Hello @flospi

    Thank you for your message and welcome to the TeamViewer Community! ?

    I recommend you apply the policy Play computer sounds and music and set the Value to Disabled.

    2020-10-07 14_15_15-TeamViewer Management Console.png

    I hope this could help. ?

    If not, do not hesitate to ask your questions here. ?

    Best regards

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • flospi
    flospi Posts: 27 ✭✭

    Hey Jean

    This policy has been disabled since rollout and I do understand it differently. The manual says: "If activated, the remote computer sound is transmitted to the local computer."

    So, if the host plays a sound, it will also be transmitted to the supporter on the other side. I am talking about muting the microphone in the supporters Teamviewer, because it is not needed and only leads to confusion, echo and strange side-effects, when communication with the user on Teams already.

    So I guess it would be some setting in "Audio conferencing" and setting speaker and microphone to "No Device" or something:

    2020-10-08 07_46_24-TeamViewer options.png

  • JeanK
    JeanK Posts: 5,593 Community Manager 🌍

    Hello @flospi

    Thank you for your message. ?

    Indeed, I misunderstood your question here. Sorry for this. ?

    I'll double check it and come back to you in the next hour with further elements regarding having the microphone disabled as default.

    Best regards

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • JeanK
    JeanK Posts: 5,593 Community Manager 🌍

    Hello again @flospi,

    I discussed with our engineers and using the policy Play computer sounds and music with setting the Value on Disabled was not a bad idea. The important thing here is that this policy needs to be applied on all devices: on the local side and on the remote side.

    This policy will, on a TeamViewer perspective, disable all sounds. However, this will only apply regarding the TeamViewer data traffic, and therefore, Microsoft Teams will still be able to work in parallel so the support guys can talk with the supported guys.

    You could also manually Mute the microphone in the TeamViewer options on all devices, as you already mentioned.

    2020-10-08 11_15_57-TeamViewer options.png

    Alternatively, both users can also mute the TeamViewer in and output in the Windows volume mixer:

    2020-10-08 11_18_57-Volume Mixer - Speakers (Jabra BIZ 2400 II CC).png

    This also has to be done on both devices.

    I hope this could help. ?

    Best regards

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • curatrix_pl
    curatrix_pl Posts: 2 ✭✭

    Bit late to the party, but found the option

    Frustrated me for months this setting.

  • mbr_mnr
    mbr_mnr Posts: 2 ✭✭
    edited November 2021

    Hi Jean,

    Honestly the TeamViewer Policies never worked in our environment, I tried to disable Play Computer Sounds and Music on remote machines but never worked even when I see in the TV WebConsole the Plolicy applied properly.

    Now I'm trying to deploy the new Version of TV host 15.8.3, however the Play computer sounds an Music is not listed, you can only Mute the Volume from Audio conferencing.


    But you cannot export this setting into tvopt file, General, Security and Advanced are allowed to be exported.

    What about the Policy, why do I need to apply it to all Machines?

    Any suggestions?

    Thanks

    Brisk