teamviewer.com link icon
or
Ask The Community

Are you working with Insider Builds❓


Participate in our survey and get to know the new UI 👉 here 👈.

Trusted device email never received

2»

Answers

  • csterndds
    csterndds Posts: 1

    Same problem, how do I fix it? Who do I need to speak to to get my email off the anti-spamming list?

  • SNP_Administrator
    SNP_Administrator Posts: 1 Newbie

    Still an issue, also with random emails while others work. Already tried contacting support and they did nothing but run me in a circle. This is absolutely pathetic. There're countless other remote support providers on the market and we're going to explore other options because TeamViewer went from my favorite choice to a complete pile and I'm done pulling my hair out over their screwups.

  • bairdmw
    bairdmw Posts: 2 ✭✭

    I, too am experiencing this issue.

    How can a provider of software possibly not rectify this issue in over 3.5 years?? This is baffling and really makes me question their ability to develop this software. I am a paid subscriber and I cannot access my account on my PC after doing a clean install.

    To add salt to the wounds, when I tried to log in to this community forum with the account that I am locked out of, I was told I needed to click the link in the verification email to login. The vertification email that I'm not receiving and am here reading about. So, I had to create a new account simply to post on here to question why I am not getting verification emails so that I can access my existing subscription.

  • RyanKenney
    RyanKenney Posts: 0

    I know what the issue is, just got off the phone with support.

    If TeamViewer's email servers get a bounce back from a "trust device" email request that you ask for then it blocks ALL future requests that you submit.

    They had to go into their servers and allow my requests to be sent normally.

    Don't kill yourself trying to fix this yourself you need to call support.

  • ITRelasjonNorway
    ITRelasjonNorway Posts: 1 Newbie
    edited June 1

    It is soon 4 years, and we still have the same problem.

    Same stuff with login which does not work. It is insane. I guess many of us will start looking for alternativ software.

    Teamviewer; **bleep** get your **bleep** together and fix this bug. Or will you need another 4 years until 2025?