teamviewer.com link icon
or
Ask The Community

TeamViewer builds for aarch64/arm64?

MaltronCraft
MaltronCraft Posts: 2
edited December 2020 in Linux only

Hello, I am trying to get my Raspberry Pi 4 setup with TeamViewer.

My Pi is running Ubuntu Desktop 20.10 64-bit (64-bit is the only option for Ubuntu Desktop) but I can't start TeamViewer Host. It fails because it detects aarch64. I've tried many different things, including the non-arm builds for Linux.

If anyone can assist me and any other Raspberry Pi 4 users who run Ubuntu Desktop, please reply to this question.

Thanks! and Merry Christmas to anyone who sees this on 12-25-2020 :)

Answers

  • CRhamilton
    CRhamilton Posts: 2 ✭✭
    edited January 2021

    To add arm32 bit to the rchitecture use.

    sudo dpkg --add-architecture armhf

    sudo apt-get update

    sudo apt-get upgrade

    sudo apt-get -f install

    sudo apt-get install libxtst6:armhf


    Then you should be able to install the armhf version.


    This should make it work.

  • zBugi
    zBugi Posts: 1

    I did it but i still got an issue when i do sudo teamviewer setup

    The framebuffer console seems to be unavailable or has the wrong format. For connections to framebuffer consoles to work please make sure that /dev/fb0 is accessible and configured to at least 16-bit depth.

    $ cat /etc/default/grub

    GRUB_GFXMODE=1024x768x32

    GRUB_GFXPAYLOAD_LINUX=keep

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg

    $ sudo reboot

    after that i get an authentification error and then teamviewer says Connecting... like forever.

    When I run

    $ sudo teamviewer setup

    again the same issue appears