teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Raspberry Pi Host no control

PelicanMedia
PelicanMedia Posts: 14 ✭✭

I have a selection of Raspberry Pi's with the latest version of TV host installed.

After the last update, I have not been able to control these devices. I can view the desktop but unable to control/send receive files etc.

The version installed on Pi's:


The version installed on Windows laptop:


Originally installed from the .deb file here:

https://download.teamviewer.com/download/linux/teamviewer-host_armhf.deb


Entry in /etc/apt/sources.list.d/teamviewer.list :

deb https://linux.teamviewer.com/deb stable main


Some help, please? Or when will there be an update pushed out to fix this issue?

Answers

  • MShoeb_Hasham
    MShoeb_Hasham Posts: 2 ✭✭
    edited April 6

    the rest of my TeamViewer IDs are done, but I still can't access my 2 Raspberry pi 3 b +.  when connecting the connection drops or connects and the image is static.

    I have another pi 3 b + that is working perfectly.

    I tried to see if the problem was the internet connection but it is not.

  • TweetyTreiber
    TweetyTreiber Posts: 0 Newbie

    I second this issue.

    Since a distribution update yesterday Teamviewer fail to display in a Win 10 Client.

    Not quiet sure if there is a relation between both events, but likely.

    Seems the connection will be stopped imediatly after being established.

    If you need more detailed informations, don´t hasitate to ask

  • MShoeb_Hasham
    MShoeb_Hasham Posts: 2 ✭✭

    Tnks! Yes, I'm trying to access Pi from Win 10.

    Any way to solve the problem?

  • Just chiming in to say I too am having this problem after updating rpi

  • PelicanMedia
    PelicanMedia Posts: 14 ✭✭

    Yet again, another update pushed out with out testing. Typical TeamViewer attitude, "That will do, push to production".

  • matevzmrak
    matevzmrak Posts: 1

    Hello,

    Im occuring a problem after "sudo apt-get update & upgrade" on RPi4. Teamviewer remote control freezes after 3 seconds on RPi4.

    It also does not work after reset.

    Im using Teamviewer 15.16.8 on Windows

  • Sangin
    Sangin Posts: 19 ✭✭

    Same here. Do you know how to go back to a previous version?

  • Sangin
    Sangin Posts: 19 ✭✭

    Same here since 15.16.8 on Raspberry PI. Unable to connect from macOS or iOS.

  • PelicanMedia
    PelicanMedia Posts: 14 ✭✭

    Unless you know the URL to the previous version's installation file, no.

    For now, I'd just carry on banging your head against the wall!

  • Sangin
    Sangin Posts: 19 ✭✭

    Do you know if a register user open a bug? Do you know if Team Viewer employee monitor these Forum?.

  • PelicanMedia
    PelicanMedia Posts: 14 ✭✭

    You can always try, I've never had any luck with them.

    Monitor and take any notice are 2 different things.

  • Sangin
    Sangin Posts: 19 ✭✭

    Same here. Worked well before 15.16,8. Any idea to downgrade?

  • jiangxue
    jiangxue Posts: 1
    edited June 14

    Hello,           

    I want to provide some feedback on TeamViewer:           

    I use the windows computer as the main control terminal and the raspberry pie as the controlled terminal,           

    Software version: TeamViewer host_ 15.17.6_ armhf           

    After remote connection, about 3 seconds later, team viewer on raspberry pie flashes back           

    Hope to help me solve it. Thank you very much



    [logs removed per Community Guidelines]

  • BigLukowski
    BigLukowski Posts: 1 Newbie

    Same issue here. Did you find a solution yet?

  • sbalint
    sbalint Posts: 1 Newbie

    I have the same issue.

    Since the distribution update as I'm trying to log in to the rPI, aftre a few seconds the screen freezes.

  • TMRFE
    TMRFE Posts: 1

    Hey all - I had the same issue. I resolved it by running 15.5.5 which I pulled off an old pi. That seems to be stable on the new version of Buster. maybe the admin of this forum could have that posted here for folks to use

  • Sebaschd
    Sebaschd Posts: 2 ✭✭

    Hi, I use the TeamViewer Remote Access Licence to work remotely on several Raspberry Pi 4. It works perfectly on one of them but since 2021 May the screen freezes on my IMac and teamviewer shuts down on the raspberry Pi - the connection cuts.

    Is there anybody with the same problem? I would be really happy to get this problem solved because I actually pay for TeamViewer and it doesn´t work.

    I am happy about any idea.

  • Sangin
    Sangin Posts: 19 ✭✭

    Same here. Nobody seems to care at TeamViewer. TV unusable on Raspberry Pi for months.

  • Sangin
    Sangin Posts: 19 ✭✭

    Same here since 15.16.8 on Raspberry PI. I don't where to find version 15.5.5 as you propose TMRFE. Maybe Team Viewer Team must provide a reliable rollback version until the new version work.

  • Sangin
    Sangin Posts: 19 ✭✭

    @MShoeb_Hasham any news from TV?

  • bistwo
    bistwo Posts: 1

    Suddenly (within the last month) I have a few Raspberry Pi devices running Raspbian 10 that I cannot connect to. The connection seems to be successful, but within one second of connecting, the screen freezes. The connection does not terminate, the screen just freezes. TCP/UDP 5938 is open on both the remote and local sides.

  • Sangin
    Sangin Posts: 19 ✭✭

    Lots of post like this since TV 15.6 on this forum. Nobody seems to care. Look like a SegFault of the Host app.