teamviewer.com link icon
or
Ask The Community

teamviewer host dies as soon as connection is established on raspbery pi 3b+ after apt-get upgrade

evt
evt Posts: 3 ✭✭
edited June 2021 in Linux only

Hi commercial user here,

We have a number of remote devices (raspberry pi 3B+) that we need to periodically access using TeamViewer and we started noticing that as soon TeamViewer is updated through an apt-get upgrade to the latest version, then we are unable to access it any more. The session initiates but immediately freezes and after a few minutes it gets cancelled. On a local test device we can also VNC to we can see that as soon as the connection is established the TeamViewer service is killed and it needs a reboot to re-instantiate. We are still able to access the devices via the web client but we would like to have this issue resolved since the web-client capabilities are limited i.e. missing file transfer etc.

We have noticed the issue for versions on the pi newer than 15.16.8 and we are currently running version 15.18.5 on the windows desktop app

I have read on a few threads other users reporting similar issues such as:

https://community.teamviewer.com/English/discussion/38519/remote-screen-freezes-after-a-few-seconds

And have tried the solutions stated but with no luck.

Q1, Is this a know issue and if so is there a way to mitigate the issue, should we expect a new release about it ?

Q2 Is it possible to downgrade the host on the pi side to a previous working version ?


Thanks

Best Answer

Answers

  • Sangin
    Sangin Posts: 21 ✭✭

    Don't understand why TeamViewer are not responding. Your right unusable on RPi since 15.16.8. Nobody can provide an old version until the bug is fixed.

  • Sangin
    Sangin Posts: 21 ✭✭

    Any news @evt ?

  • evt
    evt Posts: 3 ✭✭

    Hi @Sangin ,

    They have replied in my emails but very slowly and so far they have only requested my log files, told me more or less to try what the link i posted here suggested and to upgrade both the sides, but with versions that i cannot for the life of me find anywhere .....

    I am extremely disappointed with the support so far. I think we will stop using their application very soon if this continues for long .

  • Sangin
    Sangin Posts: 21 ✭✭

    @evt the host app un Raspberry Pi seems to crash with a Segment Fault error at the connection. I deleted the .cache files and it takes more time to crash...

  • Vairn
    Vairn Posts: 1
    edited August 2021

    I have this on some raspberries and others work fine.

    I played around with the options on my PC, and disabled UDP for connecting, and the connection is a lot more stable on the raspberries.

    Also try disabling sound too, and turning on Hardware accelleration.

  • Sangin
    Sangin Posts: 21 ✭✭

    Yeah. Saw a libpulse (pulseaidio) error but not able to solve it. See an EasyAccess error too.

  • Jolo2112
    Jolo2112 Posts: 1
    Answer ✓

    Hi there,

    had the same issue with Raspi 3B+ and latest teamviewer-host version. I managed to solve this by downgrading to an old version:

    • Uninstall teamviewer host: sudo apt-get purge teamviewer-host
    • Downloading a "stable" version. Following worked fine for me:

    sudo wget https://dl.teamviewer.com/download/linux/version_15x/teamviewer-host_15.5.3_armhf.deb

    sudo wget https://dl.teamviewer.com/download/linux/version_15x/teamviewer-host_15.1.3937_armhf.deb

    sudo wget https://dl.teamviewer.com/download/linux/version_15x/teamviewer-host_15.5.6_armhf.deb

    • Install one of those above, e.g. by: sudo apt-get install teamviewer-host_15.5.3_armhf.deb (I personally installed it via GUI by using monitor, mouse, keyboard)
    • Login teamviewer-host using your credentials
    • Disable auto-update: sudo teamviewer repo disable
  • evt
    evt Posts: 3 ✭✭

    Hey @Jolo2112,

    This is the only "solution" i also could manage to find.

    It is horrible that we have to resort to older versions non upgradable of the application in order to have it working as expected (and paid ) ....

    Also TeamViewer support failed totally to provide any useful assistance. I only got the same answers as here and on other threads and at some point they stoped all together .

  • Sangin
    Sangin Posts: 21 ✭✭
    edited September 2021

    Thanks. I think the last working version is 15.15.5.

    Uninstall TeamViewer

    sudo wget https://dl.teamviewer.com/download/linux/version_15x/teamviewer-host_15.15.5_armhf.deb

    sudo dpkg -i teamviewer-host_15.15.5_armhf.deb

    Don't forget to remove the TeamViewer in /etc/apt/sources.list and the TeamViewer file in the directory /etc/apt/sources.list.d

  • KreAch3R
    KreAch3R Posts: 1

    After searching and reinstalling everything for 5 hours, thinking my pi was the problem, I found this thread and the version 1.5.5.6 worked for me. Amen, thanks brother.

    Can't believe I have this error for a month or so, couldn't find the trouble to troubleshoot it and TeamViewer didn't fix it. It just doesn't work whatever you do.

    Thank god they didn't also break backwards compatibility.

  • Sangin
    Sangin Posts: 21 ✭✭

    who will told us the version that fix the problem since everybody stops the automatic updates at 15.15.5 :-)

  • tanutapi
    tanutapi Posts: 1 Newbie

    I'm running on 15.25.5 on my Raspberry PI. I have to disable "Play computer sounds and music" to make it works.