teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

Issue with display from remote host

Hi,

I've been using TeamViewer at home for few months without issues up till today. My set-up:

Primary laptop (Windows 11 Pro Insider Preview with additional screen via HDMI), connected via wifi to router provided by ISP.

Secondary laptop (host, Windows 10, 10.0.19043), connected to same router via ethernet cable. This laptop is connected to tv set via HDMI and used to watch from internet sources.

Problem:

After connecting, I'm stuck with "Connecting to" screen. Even though I can take actions on remote computer, I have no vision on my Primary's screen. Alternatively I get only white screen. Manipulating control bar creates artefacts (see below). On tv screen I see that I can normally operate the remote Secondary, but I'm blind on the Primary machine. It happened once yesterday, after reconnecting everything worked fine, today everything worked fine until few hours ago, since then issue is impacting me consistently each time I try to connect.sni


I tried:

  • both TeamViewers are up to date
  • disabling hardware acceleration on Primary did not help
  • restarting both machines did not help
  • restarting Teamviewer service on both machines did not help
  • sfc nor dism returned no problems Primary machine
  • detaching additional screens from either machine, trying to meddle with View settings (quality or resolution) - none of these helped.

Any suggestions other than reinstalling TeamViewer on Primary?

Answers

  • b0son
    b0son Posts: 2 ✭✭

    I have the same issue, also on a win11 machine. I'm in the dev channel, problem occurred with the latest insider preview (22478). Tried reinstalling on both the win11 machine with the problem, and the win10 machine I was trying to connect to. No change. Can connect to the win10 machine with another win10 machine without issue, so it seems to be the latest win11 build that's the problem here.

  • buckowski
    buckowski Posts: 6 ✭✭

    I have same the issue. Problem is on computer with Win11 build 22478.1012. Due to my testing windows version of remote controlled PC is irrelevant. Problem is on primary computer (I want to connect from and control other PC). If I try to connect to this computer there is no problem.

    On my "backup" laptop I've got Windows 11 22000.194 and everything works just fine. Looks like there really is problem with Win build 22478.

  • buckowski
    buckowski Posts: 6 ✭✭

    I've just tried to revert to older windows build - and now with build 22471.1000 everything works.

  • Kevinh1
    Kevinh1 Posts: 1

    I have the same problem, was working Saturday, then last night I was getting the same screen as above. I tried installing new version on both computers and rebooting...

    I just reverted bat to 15.21.5 ( it was the first version I found...), still no luck.

    My mouse is connected and moves on the remote computer but I can not see the remote computer desktop on my main computer.

  • buckowski
    buckowski Posts: 6 ✭✭

    You don't have to revert TeamViewer version but Windows build.

  • Rafal_Sz
    Rafal_Sz Posts: 2 ✭✭

    I confirm, rollback to 22471.1000 build of Windows 11 solved the issue.

  • ElrondIT
    ElrondIT Posts: 3 Newbie

    Issue appears to be fixed in build 22483 dev