TeamViewer 11 error connecting to Windows 11 22H2

Options
Larry_Talbot
Larry_Talbot Posts: 1
edited May 2023 in General questions

I'm noticing that TeamViewer 11 seems to be having difficulty connecting to Windows 11 release 22H2 for an unknown reason. What happens is that the following error message is displayed:

Unable to connect

A connection could not be established.

Reason unknown.

This is with the latest build of TeamViewer 11 on both ends, 11.0.259193. TeamViewer Host is installed on the remote Windows 11 system, the full version of TeamViewer 11 locally.

Doing some online searching found suggestions to disable UDP to overcome some connection problems but this made no difference. I realize that TeamViewer 11 is an older version but until now it has worked fine. Is there a fix for this or is this the end of the line for TeamViewer 11?


.

Answers

  • Ying_Q
    Ying_Q Posts: 2,625 Moderator
    Options

    Hi @Larry_Talbot,

    We are happy to have you in our Community for the first time. 🙌

    Please note that according to the TeamViewer software and Operating System Compatibility article 📑, the latest officially supported version of Windows is Windows 10.1703 with TeamViewer v11.

    As the compatibility of TeamViewer and Windows 11 (22H2) is still under review, we kindly ask you to visit our TeamViewer Community regularly to check the compatibility update on Windows 11 (22H2).

    Moreover, we highly recommend updating your TeamViewer software to the latest version and enjoying the powerful features and stronger security.

    📌Hint: Before updating your TeamViewer, please double-check if your license includes the use of the latest TeamViewer version.

    For the latest information about TeamViewer promotions and specials on updating the license, our dedicated agents from the TeamViewer Sales Team ☎ are available and happy to guide you.

    We hope you find this information helpful. If you need further assistance, please do not hesitate to contact us again.

    Have a great journey with TeamViewer also in the future!

    Best,

    Ying_Q

    Community Moderator/中文社区管理员
  • MCEStaff
    MCEStaff Posts: 3 ✭✭
    Options

    I too have been having trouble with a lot of my endpoints and just left a question about it here in the forum. I thought you might have had the explanation here but then I remembered at least one laptop with Windows 10 and 2 servers with Windows 2016 are giving me the same error.

    My workstation does have the latest Windows 11. Reloading on a Windows 10 machine would be difficult because TeamViewer will then want to reactivate and will use up one of my few remaining reactivations.