Remove Assignment Prompt when installing Host via Mass Deployment

AntonDobschensky
AntonDobschensky Posts: 18 ✭✭
edited February 16 in Deployment & Integrations

Currently, when Host config is set to use Managed Groups, you will receive a prompt when running the Mass Deployment command line to install a Host client.

As a large organization trying to deploy this to ~1000 devices via SCCM we need this to not prompt. This prevents Host deployment to unattended devices, requires a firmwide

communication for something that in the past we've done behind the scenes and adds in a point of failure for those users that always click the wrong thing.

I understand the security concerns but this currently makes the Managed Groups feature completely unusable. We would love to be using the Managed groups as it adds more granular control with who can access what, but we cannot with the prompt.


Best Answer

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍
    edited June 2023 Answer ✓

    Hi @AntonDobschensky,

    Thank you for asking this here. I allowed myself to merge both of your posts.

    The reason why a prompt is showing after the installation is that the parameter Use Managed Group assignment of your Host is enabled.

    To solve your issue, you need to disable this parameter like in this video:

    You can also follow these steps:

    1. Sign in to https://login.teamviewer.com/.
    2. Go to Design & Deploy.
    3. Edit your custom Host.
    4. Untick the Use Managed Group assignment parameter and save.
    5. Redeploy your custom Host on your devices.

    You will see that no prompt will show to confirm the group assignment.

    For your deployment, I recommend following our user guide here:

    Mass deployment - Overview

    Let me know if this has worked for you!

    /JeanK

    Community Manager

Answers

  • AntonDobschensky
    AntonDobschensky Posts: 18 ✭✭

    Will a new version address the problem that you cannot use Use Managed Group assignment when mass deploying Host versions due to the prompt asking if its ok to assign to the group? It makes the new Managed Group feature completely unusable when deploying this to unattended machines or without firmwide communication and instructions.

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍
    edited June 2023 Answer ✓

    Hi @AntonDobschensky,

    Thank you for asking this here. I allowed myself to merge both of your posts.

    The reason why a prompt is showing after the installation is that the parameter Use Managed Group assignment of your Host is enabled.

    To solve your issue, you need to disable this parameter like in this video:

    You can also follow these steps:

    1. Sign in to https://login.teamviewer.com/.
    2. Go to Design & Deploy.
    3. Edit your custom Host.
    4. Untick the Use Managed Group assignment parameter and save.
    5. Redeploy your custom Host on your devices.

    You will see that no prompt will show to confirm the group assignment.

    For your deployment, I recommend following our user guide here:

    Mass deployment - Overview

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • Theseis
    Theseis Posts: 3 ✭✭

    Same Here, please fix it ! it's impossible to use management group with this configuration

  • WCSD_DOT1
    WCSD_DOT1 Posts: 5 ✭✭

    I am having the same issue. I am using the new web.teamviewer.com site...i do not see an option to turn that group assignment off. Why are there two web interfaces? Cant you just provide simple deployment directions for SCCM that instal silently with no user interaction?

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hi @WCSD_DOT1,

    Thank you for asking!

    If you are using the new interface, the solution is to use the rollout configuration.

    We explain how to proceed in our deployment guide: 📄Create a rollout configuration - 6/10

    With the rollout configuration, you can define the groups and the managers of the devices you are rolling out.

    Hope this helps!

    /JeanK

    Community Manager

  • LasseHansen
    LasseHansen Posts: 1

    Hi @JeanK


    I am using the new interface, and have followed you guidance.

    But I don't see any solution for the Account Assignment prompt.

    I would like to deploy TeamViewer without any user interaction. Please let me know what to do.

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hi @LasseHansen,

    I've talked with our engineers and come back with (hopefully) the solution. 🙂

    When using the new interface and deploying TeamViewer via script, it is important that the rollout configuration in the module's settings is set to None.

    Please give it a try. You shouldn't see the pop-up; the installation should occur without user interaction.

    Looking forward to hearing from you.

    /JeanK

    Community Manager