teamviewer.com link icon
or
Ask The Community

[Update] TeamViewer 13

DanielStmDanielStm Posts: 224 Staff

TeamViewer 13 and TeamViewer 13 Host for LinuxTeamViewer 13 and TeamViewer 13 Host for Linux

Dear fellow penguins,

it is with great pleasure that today I can announce the availability of TeamViewer 13 for Linux. TeamViewer Host for Linux PCs is now a regular product. It also serves as the foundation for the native TeamViewer 13 (full) for Linux, which we release as a preview today. Highlights:

  • native client, no more Wine
  • native 64 bit packages, no more 32 bit dependencies
  • DEB and RPM repositories for convenient updates

A new Chapter
In vino veritas, but in Qt we trust. For many years, TeamViewer for Linux was based on Wine. The growing user base and demand as well as technical limitations of that approach lead to the decision to start over with a native, Qt-based user interface. The development has been going on for a while now, starting with the Host for Raspberry Pi in 2016 and adding the Host for PC earlier this year. TeamViewer and TeamViewer Host now share most of their code and integrate more seamless into modern desktop environments than ever before, and we will continue to improve the user experience in future updates.

Features & Updates
The TeamViewer preview includes all the features that were already present in the TeamViewer Host: Incoming remote control, incoming file transfer, account assignment as well as DEB and RPM repositories. Additionally this first release includes the Computers & Contacts list - allowing quick access to your servers, colleagues and friends - and, of course, outgoing remote control. The StatusNotifier (tray icon) toggles the Computers & Contacts list on mouse middle-click if the desktop supports it (KDE Plasma: yes, Gnome: no). Obviously, some features are still missing, but we plan to add them soon. You can expect frequent updates via the repository. We are interested to hear from you which ones you think should have priority. Please take the survey.

A Note on Wayland
Sign In with Xorg instead of WaylandSign In with Xorg instead of WaylandOn Wayland, currently only outgoing remote control and incoming file transfer are supported. If you need incoming remote control, you have to sign in with classic Xorg.

From a developer perspective, we would be more than happy to leave the archaic X11 technology stack behind and jump on the new and shiny Wayland train. However, that is not as simple as it may seem. By design, Wayland does not provide an interface to do remote control (screen capturing, mouse and keyboard emulation). This is to keep the Wayland core lean. The idea is that the compositor provides these interfaces, which could mean that TeamViewer would have to implement different interfaces for every desktop environment we want to support. This is unfortunate, but it's even more unsatisfying that these interfaces are not available yet. The closest to having something useful is Gnome, so it is likely that it will be the first desktop where we can support Wayland. To summarize: Yes, we want Wayland support, just as much as you, and we will work on it. I just wanted to let you know that it's a bit more complicated than 'just make it happen', as it is for the other features.

Final Words
If you are interested in RedHat and CentOS, please also have a look here.
If you are using Gnome and TeamViewer does not appear in the notification area (or tray), you might want to install KStatusNotifierItem/AppIndicator Support plugin. Ubuntu has that extension by default.

As always, packages are available via repositories and on the TeamViewer Linux download page.

 

Survey

Open survey in a new window if you can't see it. (Or disable blockers like uBlockOrigin)



 

All the best,
Daniel

Linux Developer
«13

Comments

  • Any chance for a armhf / Raspberry build of the client? Give thumbs up if you like it!

  • I am asked for password when I try to connect to my machines in my computer contacts, and there is no password they are accesed fine from chrome or windows or linux 12 version

    HandshakeClient::Connect: [remote ID: 30, remote connection ID: 0] invalid private key, Errorcode=2
     S RetryHandle::HandleRetry(): Trying resend to 30 failed with error SecureNetwork:4, not retrying (0 retries would remain) BCmd: CC=37 CT=1
     S!! ConfigurationControllerImpl::HandleConfiguration(): error SecureNetwork:4 on configuration request,

  • On debian buster with kde/plasma

    1. Starting/working very good.

    2. No toolbar on computers list / can't search on list

    3. No toolbar on window when connected to other computers

    4. No chat

    5. All computers on list are showing as online.

  • No toolbar for me too. Using XUbuntu 17.04 64 bit and connecting to another Linux machine with XUbuntu 16.04 LTS 64 bit.

  • Really want to try it out, but I cannot install it in Jessie because it depends on Qt libraries >5.5 while latest version in repos is 5.3.2-4. The host works because it depends on Qt >5.2. Will the final version of the client require Qt 5.5?
  • marmomarmo Posts: 1

    @DanielStm Thanks for your work on this version!

    2 quick questions:

    1. is there any way to send CTRL+ALT+DELETE wihtout the toolbar? I couldnt see it.
    2. Is the repository auto configured on ubuntu when i installed the preview?
      (i see that it is and enabled the preview releases using sudo teamviewer repo tv13)

     

  • nditndit Posts: 9

    First, thanks for the good work.

    This is a step in the right direction, and I am vary pleased to see you do this us linux-users.

    Even though I wasn’t prepared for the first release to be so much of a "work in progress", I can accept that for a foreseeable future, since I have high hopes this will be so much better than the old wine-implementation. The native TV-app is very snappy and fast, I like what I see.

    BUT, until we have a way to send CTRL-ALT-DEL (via bar or other workaround), it’s almost useless for me. 80% of the clients I connect to are windows servers.

    Also, at least for me, the interface does not look scaled wright (see attachment), and menu text is invicible

    /David
    Distro: Ubuntu 16.04.3 LTS
    DE: XFCE

    screenshot

  • I'm running here an uptodate arch linux with gnome. I downloaded the current version of Teamviewer 13 from here and ran the included binary. Teamviewer starts up, but it says I've got no internet connection. I can't activate my license and via "Computer & Kontakte" in the right corner I can't log into my account. Needless to say: My internet connections works fine.

  • DanielStmDanielStm Posts: 224 Staff

    @JustACommonUser
    Debian 8 is no longer officially supported. Currently, you can enforce installation if all Host dependencies are satisified (and you know how to do it), but:
    - It will not open the Computers & Contacts list on Jessie (please do not submit bug reports)
    - We will most likely really depend on 5.5 features in 2018, maybe spring, maybe fall. As we don't want to bump dependencies within a major release, we did that now.

    @marmo
    Your welcome! We enjoy that very much ourselves. Developing with Qt is 90% awesome.
    Ctrl-Alt-Del: Unfortunately no, there is not. But...
    We hear your feedback, and we are seriously thinking about timely update for toolbar/Ctrl-Alt-Del.
    You don't need to change anything with the repo configuration. You just disabled stable and TV14 updates... :robotsad:
    Restore the default with: sudo teamviewer repo default - see explanation with teamviewer help.

    @ndit Thanks for the flowers, we'll try not to disappoint you :robotembarrassed: :heart:
    Never saw missing texts in the menu. I just tried to reproduce it with my colleague, with Ubuntu+XFCE and Xubuntu 16.04.3. From the style it looks like you actually have Xubuntu? (Yes, there actually seem to be differences). Anyway, we couldn't reproduce it on both.
    Can you try to play around, maybe restart (system and/or Gui, close via tray icon), change resolution, DPI, (TeamViewer) language? Also, what is your system language? Please PM me with the results.

    Linux Developer
  • DanielStmDanielStm Posts: 224 Staff

    Hi @Chrissss, thanks for your feedback!

    I can confirm that as a bug in the non-installed tar package. Which means, it's currently only functional when installed. Please understand that other things might have priority, but we'll look into it.

    What you can do until then:
    install the tar-package via ./tv-setup - if you don't want the daemon to run all the time, you can stop/disable it when not needed. (run teamviewer help after installation)

    Arch Linux: As you know we don't officially support it, but I assume they will soon pick up TeamViewer 13 and create packages.

    Gentoo: speaking of inofficial ports, I was contacted by a Gentoo maintainer and expect they'll have TV13 package soon.

    Linux Developer
  • When i try to connect to computers to my list/contacts I get request for password but there should be no request!

    2017/12/04 15:46:32.291 xxxxxxxxxxxxxxxxx S Negotiating session encryption: server handshake received, encryption established with AES key length 256
    2017/12/04 15:46:39.132 xxxxxxxxxxxxxx S CGatewaySession[39]::EndSession(): Session to 294266006 ended. Estimated capacity=2936kBit/s, Latency=115ms
    2017/12/04 15:46:39.132 12762 xxxxxxxxxxxx S UDP: create udp connection was not successful: UdpHolePuncher shutting down: (*)
    2017/12/04 15:46:39.132 12762 xxxxxxxxxxxxxxx S! RemoteSession[39]::AddRequestedCarrier(): request carrier UdpToPartner failed!

  • Hi.

    I use Ubuntu 16.04 and I am frustrated.

    The toolbar do not appear and I cannot login on my Windows hosts because I cannot do a CRTL + ALT + DEL.

    The problem is that I am not a BETA user, to test it. I need a final version working. I have aquire it it for working purpose, not to be a BETA tester.

    Do you have the solution? All Ive tried not worked.

    Thank you.

    Andre

  • Read the previous post! This is a preview version, if you need this feature install a Windows virtual machine (under virtualbox/vmware/qemu ecc) and install a windows version of teamviewer else return to version 12

     
  • DusanDusan Posts: 1

    I have same problem. Without ctrl-alt-del this product is useless. We have premium licence ,we are bit confused and downgrade back to 12 is our way. But how to downgrade our quicksupport modules back to version 12 till ths issue will be sorted out. Please HELP

  • SkyrSkyr Posts: 2

    The new release runs fast and smoothly on Debian Testing + KDE.

    I agree with others, though, that the ability to send Ctrl+Alt+Del should be top priority on the missing feature list.

    Hope we'll get the old toolbar back soon, as I need to switch between different monitors of the remote system, too.

    Anyway, I'm very pleased to see that Teamviewer does not forget about the Linux users! Thanks for that!

  • DanielStmDanielStm Posts: 224 Staff

    Dear @andrearvs, @exactt@Dusan, @Skyr,

    we sincerely apologize for the inconvenience caused by missing Ctrl+Alt+Del..
    I have to admit we completely underestimated the demand for this little detail, just as much as we overestimated the demand for Wayland.
    That's why we do this community thing and specifically ask you in the survey which features matter most to you.

    We have already decided to do an extraordinary, intermediate update soon, bringing Ctrl+Alt+Del back. A few other details might also see minor improvement.
    We are really commited to straighten this out. My word on it.

    Daniel

    P.S.: @Dusan, I'm not certain what you mean by how to downgrade, but you can always get older versions here. If that doesn't answer you question, I'd recommend to call our support hotline or PM me. Again, sorry for the rough transition.

    Linux Developer
  • The update look promising. Resizing seems much less buggy. Also the "Del" key works (after so many years). Haven't tried the numbers on Mac machines (which were a PITA) yet.

    It seems the arrow keys + home/end don't work (most of them convert to typing a "q")

    Missing things for me :

    • Ability to switch between my clients' screens
    • Right click in the contacts list to send an "invitation" to my clients so they only have to click "accept" rather than spelling passwords (difficult for some non-english users). Also ability to edit a computer's properties or to add a new one.

    Haven't tested that horrible behaviour in TV12 where it would "steal" the sound/microphone and make skype+TV sessions impossible (sound too low or continuous echo/larsen).

    Thanks for working on a native solution for us Linux users and keep up the good work.

     


  • @DanielStm wrote:


    [...]

    Gentoo: speaking of inofficial ports, I was contacted by a Gentoo maintainer and expect they'll have TV13 package soon.


    Gentoo package: https://bugs.gentoo.org/621818

  • It does not work with dark themes already.

    Here is a screenshot with the Adapta theme on KDE:

    image.png

    And so it looks with Adapta-Nokto (Dark theme):

    image.png

    As you can see, there is some text "missing". But it's not missing, I guess it just has a hardcoded color.

  • DanielStmDanielStm Posts: 224 Staff

    Hey @Bleuzen, thanks for the pointer!
    @ndit, are you also on a dark theme? (Which?)

    This should be an easy fix.

    Linux Developer
  • Working good for me on Kubuntu 17.10 only gripe is no toolbar to do things like file transfer. I actually prefer the new Qt interface a lot and not having buttons everywhere near the main interface, but I would prefer some way to show a toolbar when I do need to transfer files.

  • Beside the CTRL+ALT+ENTF musthave thing I really need three further things to work seriously with TV13 on Linux:

    1. Searchable Computer&Contact List: With over 200 Hosts you really need to search the list with keywords or you need wasted minutes to find the correct host
    2. The name of the connected host in the window title: If you have several parallel sessions open and only see "TeamViewer <3>", "TeamViewer <4>", "TeamViewer <5>" in the title you absolutley lost in space. "where I am?"
    3. Filetransfer is important. Not as important as the other points (at least for me) but indeed somewhat important

    I hope the other points gets serious attention too because TV13 currently is really unuseable for me on Linux.

  • DanielStmDanielStm Posts: 224 Staff

    @mfernauThe window title should be the simplest, can be done very soon.
    Searchable C&C I expect for Q1 2018.
    Filetransfer: possible for Q1, but don't pin me down to that.

    Linux Developer
  • It looks that TV13 for linux will be usable not faster than february or march 2018. Maybe better idea will be to give users TV13 in old way with wine until new version will not be compleltly ready? Maybe using wine is not so good like qt but it works for now (with the most importent tools we need).

Sign In or Register to comment.