teamviewer.com link icon
or
Ask The Community

Wake On LAN Not Working Using Mobile Devices (Android & iOS)

trace
trace Posts: 7

I'm unable to WOL using mobile devices, both Android and iOS, while connected to my LAN via wifi using TeamViewer ID (not public address) to my main Windows 10 PC.  I can WOL with a laptop over wifi to the PC with no problems.  WOL worked months ago with Android but I haven't tried using it until the past few days.  I have never been able to get iOS devices to work.

Here are the logs from my Android device:
2018/01/13 05:03:27.908 3082-3101 I/TeamViewer WoL: WakeOnLanRequest RequestWakeup: 70XXXXXXX (28XXXXXXX)
2018/01/13 05:03:27.908 3082-3082 I/TeamViewer GroupMemberListComputerViewModel::WakeUpDevice() wake up requested
2018/01/13 05:03:29.318 3082-3101 E/TeamViewer PListManagedDevice::WakeupAsync: Wakeup 70XXXXXXX was not successful. Wakup was not configured
 
I'm unsure what the 28XXXXXXX ID in the parentheses is as there is no device associated with it.

Tagged:

Comments

  • trace
    trace Posts: 7

    I will also add that using a dedicated WOL app on the mobile devices work so I know WOL settings are correct on the PC.

    The PC is running Windows 10 Pro with OS build 16299.192 and Teamviewer v13.0.6447.

  • trace
    trace Posts: 7

    Surely I'm not the only one experiencing this.  Is anyone else able to use WOL on mobile devices?

  • I have the same issue.  About 6 months ago or so WOL from my Android phone worked fine.  After and update it seems it stopped working.

  • t0ji
    t0ji Posts: 2 ✭✭

    Was there ever a fix to this? I cannot get WOL to work from an android device, windows device works fine.

  • MaXi32
    MaXi32 Posts: 4

    How do you setup Wake On LAN.

  • trace
    trace Posts: 7

    No, it's still not working for me.

  • MaXi32
    MaXi32 Posts: 4
    If you can give me the way how you setup Wake On LAN, I can try helping you.
  • trace
    trace Posts: 7

    On my PC I open Teamviewer and go to Extras>Options>Wake-on-LAN (Configure)>Other Teamviewer within your local network>Add Teamviewer ID.

    On my phone I open Teamviewer and select Computers then tap the power button beside my computer.  It never wakes up.

    I do notice when I wake my computer up Teamviewer says it's waitng for a connection (I guess since the computer was asleep it didn't have an internet connection so it has to connect again).  I don't know if that has something to do with it.

  • In order for Wake on LAN to work properly, the very first thing is you need to verify that your network interface card or motherboard supports Wake on LAN feature. If it does, you need to enable it in BIOS. If it does not, there is nothing you can do about it except changing your hardware.

    Then, next step is you need to open the firewall port number 9 (the standard Wake On LAN port) in operating system that you want to wake it up.

    You also MUST open the port 9 in your router that connected to the device that you want to wake it up. Check something called Virtual Server / Port Forwarding menu in your router and enable port forwarding there.

    Use static IP. Do not use DHCP or Dynamic IP. If you only want Wake On LAN to work within your network, it is recommended to use static IP address for the device you want to use Wake On LAN. You also can set static IP for the device through router if your router support this. Normally it's called DHCP Address Reservation in router menu.

    If you want to be able to wake your computer outside your network for example using your mobile phone with the Wake On LAN client, it is recommended to use Dynamic DNS server example the free Dynamic DNS from afraid.org (you don't have to pay). There are more services such as no-ip etc. But I prefer afraid.org because it's free! You can create a free account there, and connect the account in your router to get static IP from the service. For example, you have your account link trace.ddns.net. login this feature in your router put the URL, username and password.

    After you have done setup this, when you want to wake on your pc, you only need to specify the host as trace.ddns.net (no more using IP. The benefit is that when your router restarts, you don't have to specify new IP, the Dynamic DNS service help updating the current IP from your router). and if it requires a port, the port is 9. and also specify the MAC address for the device you want to wake up. Now you can wake your PC anywhere you want using any Wake ON LAN clients such as teamviewer.

  • trace
    trace Posts: 7
    Thanks for the in depth response.

    The only thing I haven't done is open port 9 but that's for using the "Public access" option, not "Other Teamviewer within your local network" option.

    As I've previously stated this worked in the past. I can use other WOL apps with success.

    I've been tunneling into my network via VPN and logging into my router to wake my computer. It's not as simple as I'd like it to be.
  • I have the same problem, i tried everything but it doesent work.

  • GlhMaxi
    GlhMaxi Posts: 1

    Same here. I tried everything but it doesn't work.

    It's 2020 and still no fix to this.

    :(

  • Reverence
    Reverence Posts: 2 ✭✭

    2021 and I'm still seeing an issue. Was setting up WOL on my new PC so I could wake it up from the Teamviewer Android app, and for the life of me I couldn't get it to work. Thought it was the WOL settings on my PC that were the problem. But I downloaded the wake on LAN app from the android store and that was able to wake my PC up no problem on port 9.

    However, any time I try to wake the PC from the teamviewer android app, nothing happens. Like someone else alluded to, it seems when I try to do this through teamviewer, when I decide to manually wake the PC it gives a teamviewer error message about not having an internet connection.

Sign In or Register to comment.