teamviewer.com link icon
or
Ask The Community

Can't connect to Android device from Linux

mandrivnyk
mandrivnyk Posts: 1

Can't connect for remoteControl/Sharescreen from Linux to my Android Phone.

From Mac/Windows it works as expected.

Steps: 

1. Open TeamViewer on Ubuntu desktop.

2. OPen QuickSupport on Android device

3. Entering ID to Partner ID field on TeamViewer.

4. Press Connect

5. On Android device new dialog appearing: "Would you like to allow <name> to remote support your Android device?". Press "Allow" button

6. On Android device showing spinner for 5-10 seconds

7. Android device show main screen with my ID and status at the bottom: "Ready to connect"

What is wrong? Need assist, Let me know if you need additional details

Host:

OS: Ubuntu 17.10

TeamViewer version: 13.0.9865

Date: Feb 12 2018 15:30:36

Client device:

Android: 8.1.0

Device: Nexus 6P

QuickSupport version: 13.1.8602 QS

Host version: 13.1.8602 HM

Tagged:

Best Answer

«1

Answers

  • RalphFox
    RalphFox Posts: 1
    edited March 7

    Had this problem as well.

    Host:

    OS: Ubuntu 16.04

    TeamViewer version: latest as of 16/07/2018: 13.1.8286

    Date: May 30 2018 15:56:29

    Client device:

    Android: 8.0.0

    Device: Samsung Galaxy Note 8

    QuickSupport Samsung version:  latest as of 16/07/2018: 11.0.4766 QS

    Host version: latest as of 16/07/2018: 13.1.8752 HM

    Tried using same network and different networks. (pc and phone on same wifi network, pc on cable or wifi, and phone on 4G.)

    Please bear in mind that I can connect from my home to this ubuntu computer, and can connect from ubuntu to my home as well, and can connect on my home to my phone as well(over wifi on same network or 4g).

    More info:

    Using my Wifi and 4G:

    Connecting through "HOST" app on phone(replaced possible private info with XXXXXXXXX):

    [removed per Community Guidelines]

     I can provide more logs/detailed info if needed.

  • Any news for this issue? I got the same issue on ubuntu 18.04.1
  • Well the round about solution is using android emulator in ubuntu 

    with team-viewer installed in it. And voila there you go you can solve your 

    problem till team-viewer gets a solution to it.

    -- Madhavan Pallan

  • Any suggestions for an android emulator?

  • I have the same issue on the 18.04. I did notice that if I called up the properties dialogue for the phone it displays a password box which appears to be able to accept input. The Windows version of teamviewer connects without any password for the phone so maybe the linux version is configured differently with respect to secuity?

  • Linux 18.04 ubuntu to android-8 still not working. Same problem as described in original post.

    connects, get spinner on android and "connecting" on Linux, then ready to connect on android with failure. 

    I was going with teamviewer because vnc servers/clients on android/ubuntu require root access on android which is a pain even with the great work by the xdadev folks.

  • Brano
    Brano Posts: 4 ✭✭

    Same problem here, can connect to Android from Ubuntu TV 14.2.8352

    Android sees incoming connections but then it never connects.

  • csl1
    csl1 Posts: 1

    As a corporate customer we also have this issue. I can't see an obvious way of opening a support case with this corporate account, so I can escalate this issue. Is this the only support mechanism with TeamViewer (this forum)?

     

  • timrsfo
    timrsfo Posts: 5

    I tried for an hour trying to resolve this issue on my Ubuntu 16.04 box. I thought it was a Sumsung Add-on problem, S10

    I finally switched to an old Win7 box and it worked, unfortunately that solution does not work for me. 

    Linux Teamviewer V 14.2.8352 FREE

    Has Teamviewer made a decision not to support Linux?

  • JuanTP
    JuanTP Posts: 2 ✭✭

    I'm suffering from the same issue

    Fedora release 30 (Thirty)

    teamviewer-14.6.995-0.x86_64

  • AlenaC
    AlenaC Posts: 833 Moderator
    edited March 7

    Hello all,

    hello @csl1 ,

    thank you for your post. Welcome to the community.

    Does this issue still persist? Since you wrote that you have a license, could you please send us your log files in a ticket explaining the issue, please?


    Our dedicated team will have a look at it as soon as they have the information

    Thank you very much

    Best, Alena

     

    Spanish Community Moderator :)

  • Since you say you have no Mobile device support on Linux at the moment do you still need log files ? As you seem to be aware this doesn't work and have already reproduced this.

    Also why does this just fail silently, shouldn't it say you can't connect your Linux box to Andorid when you try? Also shouldn't any client connection to any other client, seems pretty shoddy that this isn't the case!

     

     

  • AlenaC
    AlenaC Posts: 833 Moderator

    Hi @simpz ,

    thanks for your post. 

    No, we do not need the log files anymore. I made a mistake, sorry.
    That is why JuanTP´s answer is marked as Solution.

    As soon as we release this feature, we will inform you.

    Best, 
    Alena 

     

    Spanish Community Moderator :)

  • iamit
    iamit Posts: 2

    Is there still no solution for linux to use the remote mobile supprt? having this same problem right now... Most of our developers (at least our android developers) use linux (ubuntu), so quit a missing link for us.

  • onex
    onex Posts: 2

    What are we paying for?

    There is no Linux support for Android devices.
    There is no working QuickSupport for Linux anymore.
    Connecting to old Windows client versions from Linux fails (black screen)

    A lot of non working stuff for a subscription product like this :(

  • When was this problem solved to use from linux to android mobile In which version is it resolved?

  • onex
    onex Posts: 2

    It's the end of March 2020 and the Linux Quick Support is still the non working version* 11.0.95210?

    SERIOUSLY?

    Beside the missing linux quick support, Linux -> Android isn't working either ...
    Very very bad!

    * doesn't support actual desktop environments.

  • dzidek23
    dzidek23 Posts: 2

    Still not working... I thought it was only me

    I have tried today to connect from Linux Mint 19.3 to Huawei EMUI 8.0.0.43

    Using TeamViewer for Linux 15.4.4445 was trying to connect to QuickSupport 15.4.61 QS, the host was connected and prompted for approval of connection and when confirmed the viewer would disconnect. On another attempt viewer has stated that another session is already opened, and refuse connection.

    I was however able to connect from 15.4.60 CL (Huawei EMUI 9.1.0) existing on the same network as linux device, host responded without any issues and connection was fine.

  • m_gruber
    m_gruber Posts: 2 ✭✭

    @JuanTP: You should definitely consider fixing this or at least bring up a pop-up message when connecting to Android devices telling the user that this is not supported yet.

    Before finding this thread I spent several hours troubleshooting why I'm unable to connect to an Android device while the Windows version of Teamviewer worked.

  • glab
    glab Posts: 1

    Problem still persist with teamviewer 15.9.5 on Ubuntu 16.04 with business licence.

    Connection seems established but not window appears.. if you try again to connect there is a popup saying that the connection is already established..

  • e-patrick
    e-patrick Posts: 1

    "Unfortunately there is no mobile device support for Linux at the moment."....

    Given the fact that this statement is over a year old right now, shouldn't there be any progress? I spent a couple hours trying to find the reason why the connection to my android device just failed silently. When the desktop app shows "ready to connect" I do indeed expect it to be ready to connect... Would it really be so hard to at least provide a message saying "Sorry, we don't fully support the OS that you're on."?

    That's really not user friendly.

    BR,
    /Patrick

  • Connection issue to Android devices is still reproducible with TeamViewer version 15.13.6 on Ubuntu 18.04.

    In the mean time, I'll second the request others have made: would it be possible to throw an error message when attempting to initiate a connection to a mobile device rather than silently timing out?

  • FedonKadifeli
    FedonKadifeli Posts: 2 Newbie

    Still same problem here...

  • madcamqld
    madcamqld Posts: 1

    Give this a try. (Sorry if I seem to be explaining this to a young child. I just want to make sure that no steps are missed. 😀)

    Install VirtualBox on your Ubuntu system. https://www.virtualbox.org/wiki/Linux_Downloads

    Make a Mac BigSur Virtual Machine on your system. https://techsprobe.com/install-macos-big-sur-on-virtualbox-on-windows-pc/

    NOTE: There is no license to buy for Mac Big Sur.

    I recommend a 100GB dynamic disk option. Wont use 100GB, unless you fill it up.

    Do all the updates on the Mac VM.

    Go into Safari Web Browser. (Not the App Store - As a search for TeamViewer comes up blank)

    Go to TeamViewer web page. https://www.teamviewer.com/en-us/

    Click on the "Download for Free" button.

    It will download a .dmg file. (Kind of like a disk image file / zip file, that mounts as a drive)

    Go into "Finder".

    Go to "Downloads".

    Double click on the TeamViewer.dmg file to start the install process.

    I think you know what to do from there.

    See picture below for proof. (I'm using Ubuntu 20.10)

    Can't wait for android device support on the Linux version of TeamViewer.

    I suppose that you could us a MS Windows VM if you like, but I haven't tried it.

    Regards,

    Cam.


  • From the TeamViewer home page:

    "Control, manage, monitor, and repair computers, mobile devices, network machines and more – from anywhere, anytime."

    Suggested update:

    "Control, manage, monitor, and repair computers, mobile devices, network machines and more – from anywhere, anytime... unless you use a Linux client". You're very welcome! Stay safe :-).

    If it is that they don't want to expend resources to include what they apparently believe is an inconsequential environment (Linux), perhaps they can share the program requirements for so doing to the community, select the best piece of code as a template, and refine the requirements. Iterate until the module meets internal QC requirements, incorporate into code base. Does this help?

  • koresh_fishkin
    koresh_fishkin Posts: 1 Newbie

    Same here.

    My device is Samsung Galaxy Tab A7, Android 11. My PC, Linux Debian 10. This combination doesn't work.

    But from Windows 7 to Android does work.

  • This is getting ridiculous. I asked support over a year ago and they said they'd fix this issue in a future version. How long do we have to wait? I'm using a supported version of Linux and a Samsung Tab Active3. I'm a paying corporate customer. Doesn't seem like they are working on this at all. It used to work in previous versions of Teamviewer but they evidently broke something. Our support staff use a mix of Windows and Linux. What? I'm meant to scrap our Linux systems because of this app? I'm using Teamviewer because they're partnered with IBM and this is what IBM uses for remote support in MaaS360.

  • Ashark
    Ashark Posts: 5 ✭✭

    Again I suffered from this! Wanted to help a person with android. And the behavior was exactly the same as in first message. After several hours I remembered that I already found that bug several years ago. And yes, from Windows virtual machine to Android it works as expected.

    What a heck!

    Would it really be so hard to at least provide a message saying "Sorry, we don't fully support the OS that you're on."?

    Exactly! Why do not at least make a warning? Many useless hours of people's life could be saved.

    When I wanted to report that when I first found it, I did not commented here, because I though "me too" comments do not add much value. However, after the problem hangs for so long, probably this at least will help them to realize that problem does really exist.

  • KIEWOON
    KIEWOON Posts: 2 Newbie
    edited December 2021

    There is another easy solution for this problem.

    I had the same problem and spent hours to debug this due to no error and warning message by the App. Eventually I realized that TeamViewer don't support Andriod mobile connection to Linux PC when I tried to connect Android mobile to Windows PC.

    [removed per Community Guidelines]

    I guess this could be a strong justification (competitor pressure) for TeamViewer to speed up the support for Android mobile to Linux PC.😊