link icon
Ask The Community

Why Can't I Control my Android Device?



  • dece
    dece Posts: 1

    Same issue - Moto X4 running Android 9

  • kostas1
    kostas1 Posts: 1

    Hello i would like to ask if there is any add on for Zebra TC56. I am trying to remote control a device from quicksupport but there is no functionality and i am limited to view only.

    Thank you

  • Picard
    Picard Posts: 1

    Downloaded the latest version of TeamViewer Host, got it up, but (like many others) it's only showing the screen and NOT allowing any kind of remote control.  When I clicked the little eject icon in the bottom right and clicked on the keyboard it said: "Remote side does not support remote input".

    So despite Motorola being on the list of compatible devices, it's not working.

  • Nagmet
    Nagmet Posts: 4

    Please remove TeamViewer from BlackBerry World. On BlackBerry10 this application does not work anymore. And disable the ban in the android application for use in BlackBerry10 devicesIMG_20190623_204505.png

  • btingle1
    btingle1 Posts: 1
    Worked like a charm. Thank you.
  • Tomb1
    Tomb1 Posts: 1

    When connecting to Android 5.1.1, we have to 'allow' and then imediately select 'home' icon otherwise the tablet freezes and shuts down.

    Juniper Systems, Mesa2 tablet

    Any idea please?  Thank you

    JRHPM Posts: 2 ✭✭

    Hi @Scotty 

    Nokia (HMD) is in the list of fully supported manufacturers. As you may see from the comments at the Google Play Store's "Add-On: Nokia", which is required to unfold the full capabilites on Nokia 8 smartphones, there is a malfunction during the installation process for this add on. (Google Play Store: TeamViewer Add-On: Nokia) It does not install.


    Add-On: Nokia does not installAdd-On: Nokia does not installPlease review the "Nokia" add-on for Nokia 8 and let us know, when it works! Thanks!


  • Hello,

    Can I use TeamViewer with Mi Box S (Android 8.1)?



    • Output Resolution: 4K (3840 x 2160)
    • CPU: Cortex-A53 Quad-core 64bit
    • GPU: Mali-450
    • RAM: 2GB DDR3
    • Storage: 8GB eMMC
    • Operating System: Android TV

    Wireless connectivity

    • Wi-Fi: 802.11a/b/g/n/ac 2.4GHz/5GHz
    • Bluetooth: 4.1


    • Video decoder: [email protected],VP9, H.264,MPEG1/2/4,VC-1,Real8/9/10
    • Video Format: RM,MOV,VOB,AVI,MKV,TS,Mp4,3D
    • Audio decoder: DOLBY, DTS
    • Audio Format: MP3,APE,Flac
    • Image decoder: JPG,BMP,GIF,PNG,TIF
    • Support Language: Global


    • HDMI2.0a: 1
    • USB2.0: 1
    • Power Interface: 1
    • Audio Out: 1


  • Why Teamviewer (from my Pc) can not Remote-control my Asus device (Smart-phone): Zenfone Max-plus(M1) X018d(Zb570Tl) - even if Teamviewer-host & Add-on_Asus(y) are already installed (but Screen-sharing is Ok)? 

  • Is there a list of devices that are known to work with TeamViewer Host? I would like to buy a device that is known to work.

    I know there already is a list of manufacturers but unfortunately that is not enough. Both Motorola and Huawei are on that list but both my Moto G7 Play and Nexus 6P does not work with TeamViewer Host. 

  • I see Lenovo Android devices are supported for remote control. Whereas I am only able to view my device when I connect to the host.

    Host Details : Lenovo A6 Note, Android Version 9, Android Security Patch Sep 5 2019. Also I tried Installing the available Lenovo addons for android.

    I tried connecting  the host from Android Galaxy S9+ running Android 9 and Windows 10 PC, but I am not able to remote control the device. Also on the Windows, team viewer pops up a message  "device supports screen sharing only teamviewer".

    Is this a know limitation ? any solution to the issue?


  • I downloaded the latest Teamviewer version for Linux  and Android (both host and Quick Support). I'm getting an incompatible verisons error. I just downloaded each version right now.

  • Ditto. Moto X4 worked until upgrade to Android 9. Now have a non-dismissable notification re QS needing elevated access, which cannot be added through the UI. 

  • Hi There, 

    I am trying to be able to remotely control a Denso RF Scanner (running Android version: 7.1.2). I have been trying to get this working using the TeamViewer QS app with no luck at all. I can get onto the connection from the PC to the device, but it only allows you to veiw the screen and if you click, it puts up a big Blue Hand so that you could show someone where to click on the screen, but really I need to be able to control it remotely. I am a TeamViewer business user and would really like this to be supported, as we already use TeamViewer for a big part of our business. 

    Please if anyone has any advice or suggestions or needs any further information, please ask away.

    Thank you!

  • SKM1
    SKM1 Posts: 2

    The same problem with Moto G6 Play after system update.

    Any ETA?

  • Can you pls suggest me the best app for screen sharing on android? 

  • DFI
    DFI Posts: 2 ✭✭

    I'm having many of the similar issues. I'm using the latest licensed  version 15 manager and host on Samsung tablet running android 10. The host continues to go yellow on the manager. We tried many of the setting, leaving the tablet plugged into power and only having the screen shut off.  Also many apps we install from TeamViewer on the android goes black when we open it the first time. The user at the other end says it asking for permissions on new installed app. We cant see it. Try lexmark printer app...  if we roll the host back to version 11 would that work better? And will manager version 15 be able to access and manage the device?

  • i can not contol real me 5 with my phone because there is no supported add-on for this device kindly suggest the solution 

  • Nadin1
    Nadin1 Posts: 420

    Hello @Osamah

    Thank you for your message. 

    You can find a list of all supported manufacturers for remotely controlling Android devices here

    Unfortunately,  Realme is not supported yet. So please contact our team via this form: Contact TeamViewer BizDev and let us know which devices you would like to control remotely. This way, we may be able to provide you with a TeamViewer QuickSupport app to remotely control your device, soon.

    Thank you  in advance. 


  • rhanson
    rhanson Posts: 1

    Hello,  I cant make a post yet but, 


    I'm looking for the Add-On: Handheld (a)  apk file.  Can someone help with that?



  • sheluhhh
    sheluhhh Posts: 1

    Hi, I have a Real Me 3 pro and an Oppo F3 plus that I CAN control before. Just recently when I tried to access the phones, it says that only Screen Sharing is supported. What happened? Remote control works on my Samsung phone but not on those 2 phones now. I was able to do it before. Please help. 

  • Good morning everyone.

    I have an old Nexus 6 I would like to run unattended to run some automation task, but I would like to connect to it from time to time to check what's working and to schedule things and so on, while keeping it cabled and closed into a drawer.

    I installed host on the Nexus and the client on my note 10, the matter is that I can connect to the Nexus but just to watch the screen, if I try to tap nothing moves or works, it only shares to me the remote screen.

    I have a moto z play i use the same manner and it works on the Moto. On the Moto I had to enable some special access permissions, an elevated one, which are not showing on the Nexus.

    Is there any way to fix that?

    Thank you very much.

  • Hi,

    I am hoping to find some help here.

    I have just setup intune with teamviewer integration. However, I am experiencing the problem that I can only VIEW the screen of the Android device, but NOT CONTROL it.

    A have purchased a Teamviewer license separately for this, I have have the teamviewer connector in intune configured, and I have the QuickSupport app ( enrolled on devices. All phones are Samsung brand - S9, S9+, S10, S10+.

    What is my problem here? Why can I only view the screen, but not control anything?

    Any help appreciated. Thanks in advance!

  • hi

    for some reason the android tv host only supports screen sharing. but we know input and sound is also possible. for example in my favorite application for this:

     it would be awesome to have this implemented :D

  • Hello Scotty


    Why I Can't Control Android Device with Windows 10, I used to be able to remote any Android device., at the moment I can't even remote my Samsung S9 plus.

  • Rockowe
    Rockowe Posts: 1

    Hi Everyone  (Solved - Samsung - try this on your brand - may work)

    I was Getting the BLUE HAND instead of Proper Control.
    No Matter what the HAND Remained.

    I SOLVED this Problem in the following way.

    On Android (SAMSUNG S10 Note+) I had Quick Support loaded. If it is already there - ... I suggest Uninstall and reinstall
    ALSO for good Measure I Had teamviewer for Remote control also installed.

    On my PC (Windows 10)
    I had Teamviewer App installed (For PC)
    I loaded this Clicking on Windows then Teamviewer.

    Now here''s the Part they dont tell you -  ... and was IMPORTANT to do.

    On the PC APP,  Select EXTRAS,  > Options > Advanced > (Show Advanced options), then scroll down to  All Lines that say Access Control - and Select FULL ACCESS in the drop down Window. There are two of them (Advanced settings for connections... )

    Then Loaded Quick support....  on Android  (Waited for the Number)

    and entered the Number on my PC ... and CONNECT ...
    No More Blue Hand - ... and Full control.

    --- Hope this Helps-
    I dont know why SUPPORT from Teamviewer - did not Quickly Mention these controls.  (After so many requests for clarity)
    They are hidden - ...

  • tw_mama
    tw_mama Posts: 6

    I have been using the Teamview QuickSupport with the Samsung addon to manage my mother's Samsung Tab4 tablet running Android 4.4. It's worked great and has allowed me to operate her tablet remotely from my Win10 computer to solve problems she encounters. Since the last update to the Android Quick Support app (4/28/2020) I can no longer remotely control the tablet. I can successfully connect but all I can see is the device information (similar to what you see with the Windows Task manager). I cannot reach the GUI to operate the tablet remotely.

    TeamViewer has been an indispensible tool for helping my mother. With this latest update it has become worthless. Please help!!!!QuickSupport after 4/2/2020 update

  • hello,

    i have installed TeamViewer QuickSupport app on an android tablet i want to access to.

    i want to access from my Windows 10 PC, using Teamviewer 15.5.3 client.

    TVQS app is run on the tablet. a 9 digit code is generated.

    on the PC client, i enter the 9 digit code. the connexion is successfull as i can access to tablet's dashboard (battery level etc)

    but, the only feature available is to take manually screenshots on the tablet, and retreive them on the PC client. i don't even have the view on the tablet's screen with the "blue finger". and of course, no control.

    the android tablet is a low end tablet running android 5.1

    what is going on ? how can i get at least a display of tablet's screen with the blue finger ?



  • I m very new so apologies if i make or made any mistakes, when trying to control android cellphone Samsung galaxy A01 remotely , the only thing i m able to do is view the screen but I can't control it from any other system. Upon attempting to access galaxy A01 form my pc or an android tablet, it says "remote side does not support remote input". And just a blue (hand shaped) cursor appears on both screens, control and the host. Am i doing something wrong ? Please help. 

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!