Teamviewer Host Registry Edit

randizzle Posts: 1
edited May 2023 in General questions

We have created a MSI installed for our host installs. We are trying to change the Advanced Options then Access Control "Show confirmation" to the new setting of "Generate new"

We are not able to find where we can change the registry edit to make this change?

We think its located here but we have changed it from 0 to 1 and still its not changing properly on our host.


2019-02-19 15_35_23-TeamViewer options.png2019-02-19 15_35_56-TeamViewer options--.png


  • willsie_as
    willsie_as Posts: 2 ✭✭

    Did you end up finding a solution for this one?

    I imported the registry and can see these policies are HKCU\ but even if I import them manually it doesn't change anything. 

  • willsie_as
    willsie_as Posts: 2 ✭✭

    I figured it out....



    Cannot be made to a local registry from what I can tell.

    GPO it out imo. 

  • VicHMY
    VicHMY Posts: 4 ✭✭

    Hi randizzle and willsie:as

    i am having the same issue. I can not change it by using the SETTINGSFILE Parameter in the *bat file used for deploy.

    Did you finally manage to make it work?

  • SAComputers
    SAComputers Posts: 0

    try this location:


    and not:


    afer you import the reg key, run 2 command:

    net stop teamviewer

    net start teamviewer

    It should work.

  • VicHMY
    VicHMY Posts: 4 ✭✭

    Thanks @SAComputers but it doesn´t work...

    In fact I´ve generated a tvopt with the right configuration



    i run this simple command line

    msiexec.exe /i "%~dp0TeamViewer_Host.msi" /qb SETTINGSFILE="C:\Users\Supervisor\Desktop\TeamViewer MSI\Host_Settings.tvopt"

    and the parameter is not change as the registry editor variable is not changed from 0 to 1

    Any idea?

  • michaelnydegger
    michaelnydegger Posts: 8 ✭✭

    Same here with TeamViewer Host 15.44.6.

    I can enter the registry values "ChangeDynamicPassword"=dword:00000001 in "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer" and "HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer" - as well as "PasswordOnSessionEnd"=dword:00000001 into \MsgBoxDontShow.

    But if I open the GUI, the "Random password after each session" keeps unchanged. I've removed all the unused registry values and restarted the TeamViewer service. No luck.

    Any idea?