teamviewer.com link icon
or
Ask The Community

Get blackscreen to Server 2016 and 2019 (2008 R2 works)

I just get a black screen when I remote connect from Laptop (Teamviewerhost) to a server 2016 or 2019.

Server 2008 R2 works fine :)

Any known bugs with newer RDP protocol ? 

Any solution ?

 

kind regards...

Comments

  • Yuri_T
    Yuri_T Posts: 2,067 Moderator

    Hi @m0skito ,

    Thank you for your post.

    Have you checked if you use the server ID to the endpoint device?
    For more information, please read this article.

    Hope this will be helpful.

    All the best,
    Yuri

    Community Moderator/ コミュニティモデレーター
  • m0skito
    m0skito Posts: 2

    I just create a teamviewer session to my office laptop.From the office laptop i create a normal windows RDP session to different server (no teamviewer). 2008 R2 Server I get a screen, 2016 and 2019 not. 

  • Yuri_T
    Yuri_T Posts: 2,067 Moderator

    Hi @m0skito ,

    Thank you for your reply.
    Have you checked if you use the Server ID?

    You have most likely connected to / added the user ID rather than the server ID. On a server OS, there is always a server ID, additionally each user profile will have a unique user ID. The user ID is only online when there is an active RDP session (it also cannot minimised). The server ID is always online and accessible.

    To find the server ID, connect to the computer:

    (Full version) Help > About

    (Host) right click icon in system tray > About TeamViewerServer ID user ID.png

    Hope this will help you.

    Best regards,
    Yuri

    Community Moderator/ コミュニティモデレーター
Sign In or Register to comment.