TeamViewer is preparing for macOS Catalina

Esther Posts: 4,057 Former Community Manager
edited May 17 in Announcements

Hi all,

Apple started to roll out public betas* for macOS Catalina (10.15) and iOS 13, and iPadOS. Since yesterday mac users can test the new OS and explore the new features.

The public beta for the new macOS is of course fascinating news for a lot of us, and we are happy to let you know, that our developers are already working on making TeamViewer fully compatible with the new OS and we will let you know once we finished our coding and testing.

Of course, we are also updating our Knowledge Base article Which operating systems are supported? accordingly.

As we are not yet fully compatible, we can not guarantee a hassle-free TeamViewer experience on Catalina, and we recommend to not update to the new OS on your production environment if you need to work with TeamViewer.

*Background: A company shares a beta version with its user base to find and resolve issues and bugs more quickly due to the large test-group.

Thanks a lot and best,


Former Community Manager


Best Answers



  • pavelw
    pavelw Posts: 1

    Is it possible to download macOS Catalina version to test it ?

    Best regards, 


  • It appears that the latest version of Teamviewer for the Mac 14.5.1691 (I did not find a beta) does not function at the macOS Catalina login page. Even though both TeamViewer TeamViewer_Desktop are enabled in System Preferences-Privacy-Accessibility. Is it necessary to use another company's remote desktop utility just to get through Mac login? Any indication of when this feature may be added?

  • Vmax28
    Vmax28 Posts: 14 ✭✭
    The final version of Catalina is about to be released any moment. Is Teamviewer compatible with Catalina now?
  • Vmax28
    Vmax28 Posts: 14 ✭✭
    I am a paid subscriber. macOS Catalina is out. Would you please confirm, that TeamViewer is compatible with it by now.
  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi all,

    Autumn is always an exciting time in the software industry, and we all are waiting for new updates and versions for our favorite systems.

    After Apple published their Golden Master of macOS Catalina on Friday, they went live with macOS Catalina officially yesterday!

    As promised, we have been working hard through the summer on making TeamViewer fully compatible with the new macOS:

    We are excited to announce that the upcoming TeamViewer 14.7 release will be ready for the latest macOS Catalina.

    Currently, TeamViewer 14.7 is live as an Insider Build for open testings for all our participants of the Insider Program and all of you being excited to test our pre-releases :-)

    Note: We do not recommend using an Insider Build on your productive system!

    Until TeamViewer 14.7 will go live officially (planned for October 22nd, 2019), you can give your TeamViewer (<= 14.6) in Catalina's new security settings the necessary permissions to continue working with TeamViewer as usual. Please see our Knowledge Base article for more information on how to make the settings for Screen Recording, Accessibility and Full File Access.

    Please note that you can not change the security settings remotely as the security dialog can not be transmitted via remote software before adjusting the setting! It is required to change those settings locally one time.

    Thanks and have a great day,

    Former Community Manager

  • Interesting that your statement does not indicate any kind of commitment to updating TeamViewer to be compatible with MacOS Catalina. It reminds me of an old Chinese quote: "Talk doesn't cook rice".

  • Teamviewer is broken on catalina.  Furthermore, my personal account, which I use to help my mother, has been "flagged for commercial use".  A notice pops up that says I'll be disconnected after 5 minutes, but I get only 30 seconds.  Suboptimal - Time to find an alternative.

  • real19
    real19 Posts: 1

    I downloaded the insider build , gave all permissions including Screen recording, bbut I am still not able to control the screen on the Mac OS Catalina.  I can see everything though.

  • Hi Esther, today we have Octobre 16th an teamviewer is actually not compatible with Apples finally released Calatina ??? Hmmn, we can´t say you havn´t enough time to develop it :-)

    Cheers, Andreas

  • AlenaC
    AlenaC Posts: 895 Community Manager 🌍

    Hello @Kopetzki @real19 @parkcityj @AMCarter3 ,

    thanks for your posts. 

    Please read in this article how to give TeamViewer permissions on your Mac: How to control a Mac running macOS 10.14 or higher 

    Let us know, if you need further assistance

    Have a happy Wednesday :)

    Best, Alena

    Spanish Community Moderator :)

  • I can't even get logged into Teamviewer on Catalina

  • Alena, I'm completely lost.  Any help would be appreciated.  I have Catalina, I still cant get into Teamviewer.

  • Hello, 

    I've been using Team Viewer free account for years helping a friend. My computer is PC, friend is Mac. I'm running the latest TV 14.7, as is friend. Prior to Catalina upgrade on friend's computer running most current Mojave with TV, no problem. 

    Since upgrade, the problem is no cursor control over friend's Mac running Catalina.

    I can see friend's screen to help friend navigate.I have followed precisely the install for Catalina and have the correct settings in friend's preferences -> security/privacy -> Accesibility - for TV and TV Desk top, and full-disc access. All checked and double checked. With no go.

    I had friend uninstalled and reinstalled new TV version for Catalina. 

    While confirming the settings were set correctly, I noticed that at somepoint, someone had used google remote on friend's computer. The evidence was in friend's security/privacy settings. I had those setting disabled. I also attempted to uninstall Google remote, but the uninstall failed. I then attempted to reinstall google remote and again use the unistall. Again that uninstall failed.

    My conclusion is that there is some latent hook or setting from the Mojave upgrade to Catalina that prevents remote cursor control, some other third party conflict, and possibly an upgrade problem from Majave to Catalina as related to remote control software.

    One interesting observation, I was able to chat with technical support. I should not have been able to do that as I have a free account. After that chat, there was no resolution as I declared that I have a free account. Then, I logged into my TV client. The client reports free. Also, my pc is not a new device.TV did not recognize the device and I a had to validate.

    Final, information, I no longer have access to chat suggesting that my account my have been flagged as a commercial account when it is not.

    Thank all with help with cursor problem.

    I am prepared to run the log report app on both computers and submit zip file  to TV technical support.

    Feedback appreciated.




  • I spent an hour with Mac support level 1 and could not resolve no cursor on friend's mac air. Of note, I can not sucessfully connect with google remote desktop, nor the Google remote desktop uninstall fails. Interesting. The theory persists that third party app is problem - causing conflict with TV cursor functionality.  Note Catalina requires all apps to be 64 bit. Next step is level 2. Will report here in a timely fashion.

  • genio
    genio Posts: 1

    Still cannot control remote client, no mouse cursor.
    Already followed the guide here:**Please do not post TeamViewer IDs**

    Any urgent solution?

  • I also have the same problem with Catalina. I can see what appears on the monitor of the Mac which I would like to remotely control but I cannot interact in any way even though I have followed the guide mentioned and the privacy rights selected regularly. What do we have to do?

  • Please let me know if and how you got logged in> 

  • Same problem here, me and my friend are both with the last version of OS X Catalina and we download the last version of TeamViewer.

    We have three green lights in the check System Access.

    I can see remote computer screen but I cannot control it.

    We have spent more of an hour trying to fix that but even knowledge base did not help.

    Any suggestion?

  • Same issue, can view remote desktop but cannot control

  • Does anyone from TeamViewer care?!?

  • jbarnett12
    jbarnett12 Posts: 16 ✭✭

    i have followed all the instructions on the how to guide but after upgrading to teamviewer 15 I cannot control the mouse or desktop on my Mac with Os Catalina, i have checked all the privacy settings and they are correct. What  has version 15 broken?

  • JohnD
    JohnD Posts: 35

    Seeing the same thing, but with TeamViewer Host v15.0.8397 on macOS 10.14.6 (not Catalina).  The Check System Access dialog show all three components green.  Quitting and restarting TeamViewer Host or rebooting the entire machine has no effect, same thing:  you can view but you can't control the host.

    Seems to be a v15 bug.

  • JohnD
    JohnD Posts: 35

    I tried removing all the TV stuff from the Privacy tab in System Prefs, then re-adding them.  That seems to have worked to restore the ability to control the v15 Host machine.

    This seems like a TV Host v15 updater issue:  it's not updating the stuff in the System Prefs Privacy tab properly, and reporting that all is ok in the System Access Check dialog when it clearly isn't ok.

  • jbarnett12
    jbarnett12 Posts: 16 ✭✭

    My problem is that on my mac mini teamviewer is not showing up in Screen Recording and there is not way I can add it manually so I am stuck. This was after removing teamviewer and reinstalling it

  • I'm on a Mac, guest is on a PC.  The only thing he can see on my screen is the OS Catalina screen, which I don't even have on my monitor!  Further, the screen never changes for him.  Just a solid Catalina island. He cannot see my share 

  • Hello,

    TeamViewer 14.7.1965 v on Mac OS Mojave 10.14.2 won't connect to Teamviewer v 15.0.8379 running on Windows 7. When attempting to connect, I get the following error:

    "Your partner uses a newer version of Teamviewer. Would you like to update TeamViewer now to establish a connection?"

    When I click update, it it says I have the latest available version. This error just appeared today even though I was able to connect yesterday several times without a problem. No updates to either machine were made during that time. See a video of the error here:

    Any ideas? Thanks!


  • Thanks, I upgraded manually to version 15 on MacOS and that did the trick.