TeamViewer 15 is not staying signed in (Stateless VDI)


Hi all,

I have a problem with TeamViewer 15 not staying signed in despite the "Keep me signed in" checkbox being ticked on successfully signing in. I work in a Stateless VDI environment where I get a new random computer assigned to me everytime I log on to VDI (Windows 10)

In our environment I use VMware UEM to roam the files in %appdata%\teamviewer and %localappdata%\teamviewer. The registry settings under HKCU\Software\Teamviewer are also roamed using VMware UEM.

Any suggestions on how I can fix this issue? Now the users have to log in to Teamviewer everytime they log in to the VDI environment. If they don't log in to Teamviewer our license isn't used.



  • AlphaSeb
    AlphaSeb Posts: 2 ✭✭

    I have the same issue, in Windows Virtual Desktop 

  • Ballan99
    Ballan99 Posts: 0

    I have the same problem

  • MikeR92
    MikeR92 Posts: 1

    Same problem here with Azure Virtual Desktop and FSLogix Profiles.

    Did you ever find a solution for this?

  • PeaceByJesus
    PeaceByJesus Posts: 1

    I have this issue in ver. 15.29.4 and is an issue that sees complaints for Ver. 13 and 14 despite the reply (which I have not tried yet) for ver. 13 ( which states,

    Takeshi Posts: 23 Staff member 🤠

    September 2018 Answer ✓

    This is an issue with Logins to C&C list which are made via HTTP-Fast (80) are currently failing.

    This will be fixed with TV 14, it would already work with the insider, since this will use the router login.

    In the current version 13, you would need to create below registry key as a work around.

    For version 10 and higher use the following path:


    64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer

    DWORD registry key "AllowedConnectionProtocols" with the value of 12:

    For version 9 and older use:

    32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\Version?

    64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\Version?

    DWORD registry key "AllowedConnectionProtocols" with the value of 12:


    HTTP = 1

    HTTPFast = 2

    Port443 = 4

    TCP = 8

    The value for AllowedConnectionProtocols is created by adding the values for each of the protocols that should be enabled.


    HTTP and HTTPFast can be disabled now with AllowedConnectionProtocols = Port443 + TCP = 4 + 8 = 12.

    (*Also possible: if you want to disable only one connection protocol to subtract the number from 15)

    We apologize for any inconvenience this may cause.


  • Kaptinn
    Kaptinn Posts: 2 ✭✭

    Adding this DWORD was absolutely the solution for me, using version 15.49.3.