link icon
Ask The Community

Commercial use - Connection time out



  • I am getting the same

  • The same has happened to me yesterday and today. I remote into an old phone to help me with some personal stuff and my girlfriend needed help today and I couldn't connect as it said it had detected I am using TeamViewer for commercial use.

  • AEH
    AEH Posts: 5


    Stop with this problem and switch to the free  **Third Party Product**. 

    Works the same.



  • I got what looks like a automatic reply saying that they can't determine if my ID was being used for commercial use or not but no offer to reset it to free just a link to buy it.

    I have Never in all the years of using Teamviewer used it for commercial use.

    My activity with it revolves around my Daughter and her Kids PC, and now and then my sister and brother require me to help them out too. It also comes in handy when im trying out other setups on my own second PC. This Commercial use pushing for sales is a joke I'll be using something else in the future if they don't sort this I certainly won't be paying for TV for the little use I do with it.

  • To help my parents once in a while, even 10 euros a month is a lot.
    For now I am using other software which seems to me a good solution. If TV freezes again, I abandon it and use this new software (I don't mention names here)
  • **Third Party Product** is better
  • AEH
    AEH Posts: 5

    I don't prefer "third party", because Teamviewer is letting me down, despite their promises.

    As mentioned: I have sent the enduser declaration three times in the past weeks (not days) and heard zero.

    Sure it's a fine service to provide a free use for non-commercial use, but don't show off if you can't or won't deliver.


  • SandoHP
    SandoHP Posts: 11


    As a former developer I can tell you that developing software is an immensely complex process with thousands of variables. In reality, thousands of errors are made. Many of them will not ever surface as the conditions that trigger the error will not occur. Or they will only occur rather infrequently. Anyway, applications need to be thoroughly tested to remove the most obvious errors. I'm sure Team Viewer is tested but I imagine support for free users who've been marked as non-private users isn't TV's top priority. I'm glad someone found out what the problem is, but if nobody files a bug report through the proper channels it will never be corrected. It's nice someone makes mention of it here, but software gets better if users notify the developers!

  • Bonzadog
    Bonzadog Posts: 27 ✭✭
    Yes that is well-known...but I think TV read these comments. What is happening is the TV SW does not correctly determine whether the usage is private or not. In fact this would be difficult to determine. But TV needs to address this problem and get it fixed (new SW or payment) since one observes an increasing lack of sympathy with TeamViewer. @TeamViewer: How much longer are you going to persue this policy?
  • AEH
    AEH Posts: 5

    Dear SandoHP,

    I am sure you are completely right. It takes a ton of work and it will cost a fortune to develop such a complicated piece of software like TV. Hat off and all respect. 

    BUT, it seems that the TV boys have set their signals for commercial (mis-)use far too sharp. In my case, I only contacted one other TV-ID number, which is my old mother (next month 94 years old). She is still ramming her keyboard like mad and occasionally runs into trouble on her -very fancy & very fast- PC. So, as her only son, I help her on her way again. Happens around 4 to 5 times a week. And if I am blocked out by TV for abuse as a commercial party, that's not just a bug, that's a skyscaper-bug. Sure it's not TV's top-issue, but after weeks and three applications I call this bad service, even if that is free. Like I said: don't show off if you can't back-up your promise.

    But I did not wait for TV and found a very good solution in a really free alternative, which is really free. No more TV for me.

  • SandoHP
    SandoHP Posts: 11


    I'm sure it's annoying if you just support a private person and that route is cut off. I have no experience wit it myself - I support about five people in my circle without problems. I agree it would be best if TV addressed this issue. It's fine if people complain about it.

    I was adressing those people in particular, who think

    1) they have certain rights with regards to the usability of TeamViewer (as non-paying customers they don't), 2) that posting a complaint about 'commercial use detected' will solve their issue (it won't - they should read the sticky post about this subject) 3) that charitable/educational/non-profit work use constitutes non-commercial use (it doesn't, at least not in the eyes of TV - personally I think they should replace the word 'commercial' with 'non-private') or 4) complain about bugs at the wrong place (they should create a separate post indicating that they want to file a bug report).

    Of course alternatives exist - I think I can safely say I've taken a look at almost every alternative under the sun -  but in my experience they are either not as secure or not as feature-rich as TeamViewer. I don't use all of its features but I think it's nice to be able to chat with users while supporting them. (Surely you could use an app on your phone for that too). There are some programs out there that are feature rich too (but much more expensive), and some that are secure (but have different requirements, for instance that both parties use Chrome). All the best, Sando

  • AEH
    AEH Posts: 5

    Hi Sando,

    My last reply on this subject: TV provides you with the right on free use. So, you can't claim this, but you should be able to depend on it. And if I ask three time over by the enduser declaration for reconnection, it's rude or at least unpolite to ignore that costomer.

    Goodwill is an extremely valuable asset for a company and a lot of companies spend much effort and a huge amount of money to maintain their goodwill and/or expand it. I consider it as bad management if my company would drain that expensive goodwill through the back door. Even with non-paying customers. Because these free hitchhikers talk about my company on social media. Recommend my company to family & friends, and to their boss if he needs such software. 

    I studied marketing ages ago, in a time that marketing just was born. One of the first lessons was on goodwill as a very precious, but also dangerous comodity if not used properly.

    Hopefully this community messages will be read occasionally by some VT manager and hopefully he/she will pick up this clue.

    Thanks for sharing your thougths , have a nice day and stay safe !


  • Bebbspoke
    Bebbspoke Posts: 23 ✭✭

    Hi SandoHP... It would seem I've opened a can of worms!
    I am not aware as to whether you are a TV employee or a privateer... but it's quite apparent that you are effectively "on their side"....
    I too would support TV - I have been a privatw "free" user for several years with only a few issues over the period... but here is the major hassle; -
    You quite rightly state "but if nobody files a bug report through the proper channels it will never be corrected." - but if one is UNABLE to use the "proper channels" - because of a bug in the TV website programing...
    Then how else can the free user report the fault???

  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @Ady and @mr-b,

    We are sorry to hear about the issue you were experiencing.

    I just tried the step of Generate PDF and it seemed worked from our side. Could you please try again?

    If the error continues, please kindly provide the screenshot to help us to investigate further.

    Kind regards,


  • Olgayl
    Olgayl Posts: 1


    When I try to connect to teamviewer, I get a message about suspected commercial use. I only use teamviewer for personal purposes. This usually happens when I go out of town and the computer stays in my city apartment. Now when I try to connect to the computer from an Android smartphone I see a message: "Commercial use. Connection is blocked due to exceeding the time limit."

    What should I do to unblock teamviewer? I don't use it for commercial purposes.

  • Strech
    Strech Posts: 1

    When I try to connect from my telephone to laptop, I have just 1-2 minutes, then I see this screen:Screenshot_20200817-103808_TeamViewer.jpg

    Commercial usage. Connection is blocked. But I just connect for playing lineage, it is not commercial use.

    What should I do?

  • same thing for me
  • asofus
    asofus Posts: 1

    here happens the same, and is for personal use... nothing of professional use... :(

  • Bonzadog
    Bonzadog Posts: 27 ✭✭
    @TeamViewer Looking at all the numerous entries in the Community regarding non-commercial use, I feel that TV must either improve the Algorithm that determine whether the usage is commercial or not OR drop that and charge a small free for non-commercial users. But the current situation is causing a lot of bad PR for you.
  • Edira
    Edira Posts: 1

    I have free version, use non-commercial. I use only to help my father, only contact with one ID. The system tell me that I use for commercial. What can I do?

    Can you help pe me?


    @Bonzadog wrote:
    @TeamViewerLooking at all the numerous entries in the Community regarding non-commercial use, I feel that TV must either improve the Algorithm that determine whether the usage is commercial or not OR drop that and charge a small free for non-commercial users. But the current situation is causing a lot of bad PR for you.

    @Bonzadog wrote:
    @TeamViewerLooking at all the numerous entries in the Community regarding non-commercial use, I feel that TV must either improve the Algorithm that determine whether the usage is commercial or not OR drop that and charge a small free for non-commercial users. But the current situation is causing a lot of bad PR for you.


  • Bonzadog
    Bonzadog Posts: 27 ✭✭
    Hi, Annoying theis non-commercial business. You have to now fill this form They say seven days but in my experience it may well take more than the seven days TV says it will take Good luck.... BD
  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    I posted a few pages back that I used the reset form to request a reset.  I just wanted to say that, a week or so ago, I stopped getting the "commercial use" warning on the PC in question.  As far as I can tell, I never got an email or anything, it just started to work.  I thought if anybody was sitting around, not using TV because they assumed it was still broken, you might like to know that they may fix it without notifying you.

    To those who say the reset form isn't working: one user said that removing spaces from their Teamviewer ID fixed it.  (I agree, they should have a place to report bugs in their website.)

    To those who keep posting "HOW DO I FIX THIS" (and usually a 5-paragraph life-story along with it) without reading even a handful of preceding posts: before you post, read at least a tiny bit of this thread -- the pinned answer on the first page is currently correct!  Making this already-enormous thread even longer without adding any useful information helps no one.

    ETA: I just noticed from my email notifications, it looks like a lot of people are starting new threads, then the forum mods are merging theirs into this one.  Hopefully, those people are going back and reading the pinned answer.

  • arruga
    arruga Posts: 2

    TV support team confirmed by email to me that account was reset to free, but as sooon as I sign in, I immediately  I get the  "trial version" and the "expired" message, before even attempting to connect to any machine. It's as though my account is frozen in the "trial expired" state and the reset you mentioned hasn't taken place. Can't use it. Pleae help unlock it

  • mr-b
    mr-b Posts: 6

    In the end I used the alternate form to submit my TV ids online and they have now been reset. From another thread it turns out the form button issue may be with UK postcodes not being recognised. :-(

  • glazooh
    glazooh Posts: 1

    @JaneT14 wrote:

    I had the same problem with the system hanging at create pdf, discovered it was the "space" in the post code ie: "XX11 7PP" needs to be "XX117PP" - no space. It created the pdf, then you save it to your device and upload it.

    Yes, took me ages to realise that the US software didn't like the space in the UK postcode, once removed the .pdf went off quite happily. That was 6 days ago and I still can't use it.

    They now say '7 business days' to respond - the best part of 2 weeks which is ridiculous, I just googled and ran one of the fixes to delete all the stuff in Windows and now works fine again.

  • Goldenbouncer
    Goldenbouncer Posts: 4 ✭✭

    I use TeamViewer for private use and not commercial I have called and fill out the form but it will not generate pdf for me to send hope someone can help me

  • Bebbspoke
    Bebbspoke Posts: 23 ✭✭

    Hi Goldenbouncer - if, as I assume, you're from the UK - the reason that it will not generate a .pdf is there is a bug in the Teamviewer "report" software.
    To resolve your issue; - please note that when you fill in your "postcode" you should enter such as one CONTINUOUS string - i.e (say) your postcode is N23 3RZ it must be entered as N233RZ
    without the space.

  • bazbsg
    bazbsg Posts: 103 ✭✭

    This is one of my website pet peeves. They shouldn't bother checking the postal code if they don't know the rules for the postal code. This affected me when I lived in Singapore which has six digit postal codes and in the Philippines which has four digit postal codes. Many web sites insist on five digits.

  • Apologies if I'm in the wrong location, but this is my first posting.

    I have used the Teamviewer Free version for many years with no issues at all to link into my personal server at home when I am at work (not work related at all).

    This morning I am being informed that I am using it for Commercial use & it links me in for any about 1 minute.

    Is this becuase I am using it from work & if so, why has this started after numerous years of connecting from work to my homer server?

    Thanks in advance for any help given.

    Kev Solly

  • TotalPC
    TotalPC Posts: 87 ⭐Star⭐

    Hi @homersolly ,

    Information regarding your issue can be found at the beginning of the discussion here.

    In it there is information about falsely being identified as a commercial user and if that's the case you can request a reset using the links provided. The reason it has only just happened is because TeamViewer uses algorithms that does it's best to separate personal use from commercial use and you must have only just now hit that threshold.

    TeamViewer user since version 6 (2010). We used other remote software programs (TVNC UVNC PCAny) for many years before.