Commercial use - Connection time out



  • rrhandle
    rrhandle Posts: 0

    Been using the free version for a few years. Use it about once a month. Suddenly both the PC and Laptop are telling me I have to get a license. I have tried uninstalling it and install a new copy on the PC, but still getting the same message.

  • b_broody1
    b_broody1 Posts: 2 ✭✭

    I spent 2 weeks trying to cleared up the fact that I was not using Teamviwer commercially. Finally got that cleared, now it times me out a minute or two when I sign in.

  • liselotte
    liselotte Posts: 0


    I am using Teamviewer at my job and recommend it to customers but I do not have a professional account on my own computer.

    I have created a personal free account on behalf of my mother (87) who is a in a retirement home in France, so that I can occasionally operate her Android tablet remotely from Canada. I don't use it for anything else..

    Unfortunately, less than a minute after connecting to the tablet, I receive a "Timeout" message, followed by another saying "connection blocked after timeout. Your license limits the maximum session duration to a partner; immediate reconnects are blocked. please try later or upgrade your license".

    Do real "free" account exist ? As being blocked for one or two connections a month after less than a minute is not an option.

    Am I doing something wrong ?

    Thank you.

  • Jenni
    Jenni Posts: 5 ✭✭


    I am hoping someone can help me. I use TeamViewer for personal use but was flagged as commercial. I've submitted my request to reset my account twice since Nov 22 and when I go in to try to resubmit now, It says request pending but my last submission was 12/3. Any suggestions? I use TeamViewer to access my media center computer that is in a closet and to help my family with their computers and it's getting frustrating that I can't use it for more than 5 minutes!! ANY advice/suggestions would be VERY much appreciated.

  • SmTs
    SmTs Posts: 1

    Same problem. >_<

    My computer is running Win10 Pro (not joined to a domain or anything). That's the only "commercial" thing about me. Any idea if that's what they're detecting?

    If I still can't use Teamviewer to support my septuagenarian family members after another month, I'm going to look for alternatives. >_>

  • LTskier
    LTskier Posts: 0

    I left the free version connected overnight by accident, and now it kicks me out after 30 seconds of connection with the message, "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license. Connections to this partner will be blocked until xx:xx."

    Can tech support please help reset (?) my account so I can use it for personal use again? Trying again later just has the same quick disconnect issue.

  • smryoung
    smryoung Posts: 1

    Same problem here. I even tried changing my mac address and removing/reinstalling TeamViewer with the same problem. Can tech support please help reset my account too, so I can help Grandma get her new printer setup in time for xmas? Thanks!

  • beggar_amazing
    beggar_amazing Posts: 4 ✭✭

    Idk if you guys are experiencing this as well, but every time I post a new thread on this topic, they keep removing my post and pushing my comments over to this 196 page log document about commercial use. They have not responded to any of my inquiries at all (even to say "hey this might be your problem"). They also have not reached out to me in any capacity to tell me that they think I'm using it commercially.

    Does anyone know WHO to talk to in order to clear this up? Anyone have success out there?

  • Hello, I am using teamViewer for personal use only helping family an friends. Each time I trying to help a friend on their IOS device I am getting the message "In lest than 1 minutes, will be terminating the session".

    Is there something I can do to ne abke to have 5 to 10 minutes session.

    With regards!


  • mander2020
    mander2020 Posts: 5 ✭✭


    I am using for personal usage only and i keep getting flagged for commercial usagae and I cannot access my machiones for more than aminut and i get disconnected. How do I get coded as personal and not commercial user?

  • will not allow connection of a computer saying that connection access has exceeded the limit and connection is blocked.

  • arw01
    arw01 Posts: 1

    Having the same issue, there used to be a form you filled out and got ignored on. did that a couple of years ago and still have the same issue.

  • mander2020
    mander2020 Posts: 5 ✭✭

    Yeah, where is the form? There is no way to contact support.

  • how to fix error that says: license limits the max session duration to a partner and immediate reconnects are blocked

  • LeTroll
    LeTroll Posts: 0
    edited December 2020


    My TeamViewer ID has been suspected for a commercial use but I don't use it for that.

    Could you please make this message disappears?

    My ID is **Please Do Not Post TeamViewer IDs**.

    Thank you

  • I am retired IT and use TV to keep my family and friends running. I just completed a two day job on my Aunts computer and now I am being flagged as a commercial user. I am not. What did I do to cause the flag and how can I fix this going forward? I have used TV for years without a problem.

  • jkimgpi
    jkimgpi Posts: 0


    I am a free home user and I use TeamViewer for my computers. If i try to connect to any computer from my iPhone via the TeamViewer client, everything works perfectly but after one minute, it disconnects my session saying there's a timeout. I notice that each session is limited to only 1 minute of use. What is going on here and how do I fix this? This does not occur when I use the client from my Mac.

  • I am attempting to reset my TeamViewer usage due to incorrect flagging of commercial use. I have reset one of the three IDs that are connected to my account but this obviously has not fixed the problem. I would like to reset another one and I have followed the instructions to go to this site ( but I cannot submit another request for a second ID reset. The message at that site says that my request is already submitted and pending review. But it has been reviewed and I received an email today that it was reset. Now I need to submit for a second ID. How can I accomplish this when the site to submit a second ID won't let me download the PDF and submit it?

  • EFDisaster
    EFDisaster Posts: 0

    I assume that this near immediate "timing out" of my connections is because of suspected commercial use, I just started seeing it the other day. I try to do the reset procedure on the page that makes me log in and then "generate a PDF" but the form never generates a PDF, pushing the button does nothing, no matter what browser or operating system I am on. I actually had to hook up a monitor to the Mac Mini that I usually run headless and connect to with teamviewer to confirm that the form is just plain broken, no matter what. I'm a web design dinosaur from the 90s and early 2000s, so I will gladly fix your form if you promise to stop limiting my entirely personal use account.

  • qcisfirst
    qcisfirst Posts: 3 ✭✭

    I have enjoyed using this app for several years. I assist friends and family without any compensation... Now it has come to a screeching halt.. Suddenly I am a commercial/ business. I cannot get this reset either.. Does anybody understand the reason the algorithm is so inaccurate?

  • Vettescape
    Vettescape Posts: 1

    Seems like this a very common issue. I use the application strictly for home use to support my daughter and my parents. Happened to me in late 2019 and I went through the process of confirming I was using for non-commercial purposes and I received a confirmation that I was re-authorized. Now around the same time late in 2020 I started getting the messages and kicked out of my sessions again. Went through the approval process again and this time I was denied. Filled out the escalation paperwork and have heard nothing. Several follow-up emails have gone unanswered. Looks to me they are trying to purge users from the free service. Disappointing.

  • jth19900
    jth19900 Posts: 1

    I have this problem too

  • jb16384
    jb16384 Posts: 1
    edited December 2020

    For those accessing computers on their LAN and getting the 1 minute timeout, you can connect using a LAN IP address. (e.g.

    A **bleep**. But it works.

  • titan_mimas
    titan_mimas Posts: 1

    I have the same problem

  • Joe_Bosco_69
    Joe_Bosco_69 Posts: 4 ✭✭

    Trying to connect from a desktop to a laptop in the same house and on the same local network. The connection seems to begin normally, but as soon as I see the remote desktop, the sessions disconnects and I get an error message saying "Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license." When I try again after waiting thru the "penalty" period, it still doesn't work.

    I've used TeamViewer for years to support my elderly family members and to remote control my home PC when I've been traveling and rarely had trouble. But for the last year or so, it's been rendered almost unusable. I know I have a free, personal use license, but I've not abused the software for business use and couldn't even if I wanted to since I've been retired for 4 years. But I've always been given to understand that Teamviewer supports even its personal users, so I'd appreciate any help that might help me resolve this issue so that I can continue to use the product.

    Any insight would be appreciated.

  • Yea I am having the same problem, being wrongly flagged as a business just for logging into my different computers and my Dad's from time to time. I wasn't even logging in each day, maybe once a week and not even all devices each week. Probably once a week I log into a different device with TeamViewer. So I am not really sure how this is considered use as a business.

    What I believe happened, which **bleep** and is a bit Grimey if you ask me... The company was recently sold and bought. The new owner probably noticed that most people don't pay for TeamViewer and just use it for free instead. They probably decided to change the criteria for someone to be considered a business in order to create more money.

    It **bleep** for people like me and you actually don't use it for business or as a business yet we are being blocked and stopped from logging in. I can't login at all right now every time I try it gives me a popup with a link to BUY. Which I would do if I was a business.

    If they are going to keep trying to wrongfully charge me then I guess I will have to switch to another service that isn't trying to be greedy, Grinch, or scrooge lol.

    Best of Luck to You! (Reach Out to me on Youtube and other sites everyone... (@TechnicallySaved ) )

    PS - I've been dealing with this for months and I've had the access given back to me then taken away again, presumably because I was logged into one of computers for too long, not really sure the criteria but unfortunately again I am blocked from logging into my devices any my fathers. I really hope they aren't blocking me because I am logging into devices outside my home network, that would be ridiculous because family members need help from time to time, that shouldn't push your account classification into a business account.

    Follow all My Socials @TechnicallySaved (Facebook, Instagram, Youtube, etc) Twitter = @TechnicalySaved

  • XapoH
    XapoH Posts: 0

    The connection is automatically terminated one minute after connection. Then writes that the connection limit is exceeded. Non-commercial use.

  • Apparently, TeamViewer thinks that I am using the software commercially, even though I am only helping friends and family with computer problems. Is there any way I can get this fixed?

  • gurugary
    gurugary Posts: 4 ✭✭

    lots of people having this problem and the questions about it usually dissapear after a day or so. No answers yet.

  • Andy2712
    Andy2712 Posts: 1

    I have one computer that when I connect to it, the session times out after about a minute. If I try and connect again right away I get an error message about maximum duration to a partner computer and immediate reconnects are blocked. How do I fix this? It's getting really annoying trying to do anything.