link icon
Ask The Community

Commercial use - Connection time out



  • johnwmreed
    johnwmreed Posts: 5 ✭✭

    I have the FREE version of TeamViewer for my home network.

    I have been using two computers until recently. I have now added a third computer and installed TeamViewer FREE.

    Every time I connect to the new computer, I am timed out in less than a minute.

    What is wrong? I am limited to only two computers?

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    Well isn't this just wonderful, at a time when a lot of seniors homes are in covid lockdown .It would be nice if Team Viewer would at the very least acknowledge the problem .I use it to help my 90 year old father in-law . I thank you and appreciate that you allowed us to use free version, but this very disappointing and is adding to the covid stressfulness :(

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    I see that they are merging the posts, maybe if Team Viewer would be so kind as to respond to the problem.

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    Thank You for responding , I have performed the reset . Hopefully it is working by Mon

  • QuestionMark
    QuestionMark Posts: 2 ✭✭
    edited March 2021

    Seems support is literally non-existent so this is where I am now. I don't care if I sound like a clown.

    Teamviewer was working fine for several months but in the last three days, my connection drops within 15 seconds, and then I'm blocked for 2 minutes or so. The exact error message says

    "Connection blocked after timeout

    Your license limits the maximum session duration a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Connections to this partner will be blocked until (given time)"

    I uninstalled and reinstalled TeamViewer on both devices and nothing changes.

    Every single night, at 7-8 PM EST. I connect for about 1.5 hours and then connect for 5 minutes sometime the next morning. The computer I'm connecting to is not only on the same IP address as my computer, but it is literally 2 meters away from it in the same room. My only purpose for using Teamviewer is to play a videogame using two different accounts because that's what the videogame's meta demands.

    While I understand the need to regulate use of the free version in order to make sure that users don't abuse it without paying, I feel it is necessary to inform that whoever designed the support system for this service is most likely the least competent person on the planet. While I understand that my perspective is skewed because I am boiling with rage at the moment, this entire experience has been the most frustrating thing I've ever experienced in my life. And keep in mind my ISP is phenomenal so I'm doubtful that it was the source of the problem.

    I try to find a solution to my problem and responses on a website suggested that the best approach would be to contact support and wait because things take time. Reasonable

    I look up "TeamViewer support" on google, and the first three sites are 404s

    I look through the criteria for support to users who are experiencing timeouts, and can only find information related to suspected commercial use. I go through with it, and try to "get my Teamviewer ID reactivated".

    Then a browser pops up. It will prompt me to enter my email and password, and then it asks for permission to manage my account. I allow it, and then it proceeds to load for between 2-3 minutes before ultimately hitting me with a "504 Gateway Time-Out". Brilliant. Where are your servers.

    A little while earlier, I noticed that there's a small chat box in the bottom right corner of the screen. So I open it up, and its purpose seems to be to "Help you".

    Here's how that interaction went

    "What can we help you with today?"


    "Do you have a paid subscription with us?"


    "Thank you for supporting our private/home version! We do offer this for your use between family and friends. How can we help you today?"

    "Not listed"

    "We do have millions of private users globally. To ensure that we can all help each other more efficiently we have created a community. Please jump in, help yourself and maybe others too! There are great resources if you are just getting started or have been using it for years: Teamviewer Community (link) Use your Teamviewer account to sign in. We appreciate it and thank you again! Have a great day"


    So then I try to call the phone number. My god. What. ARE. THEY. DOING.

    I'm asked whether I'm a paying user or a free user. About one button press later, I'm given "AH YES, THERE ARE MANY HELPFUL RESOURCES IN THE COMMUNITY. HAVE A GOOD DAY" After which point I'm met with another 30 seconds of godawful music and then hung up on.

    Honestly, I tried to go back and recall the bot to get a word for word, but it's 8 PM EST, and "everyone" "working" at "team" "viewer" ""support"" has gone home. This is understandable, but MY ENTIRE INTERACTION OVER THE PHONE WAS WITH A PRERECORDED VOICE. AT THE BARE MINIMUM, THESE CLOWNS COULD HAVE AT LEAST LEFT THEIR USERS WITH THAT. ESPECIALLY WHEN A GOOD PORTION OF THEM ARE NON-PAYING.

    And now, I will sit and watch as my post gets merged along with hundreds of others into a single thread that ultimately contributes nothing. And hey, I just realize there is an emoji picker at the bottom of this text box

    **bleep** Support.

    Oh right. This is supposed to be a question. WHY EVERYTHING ABOUT TEAMVIEWER TERRIBLE?

  • velvetlady
    velvetlady Posts: 3 ✭✭

    Why are my sessions timing out after a very short time? I haven't time to do much of anything and I am still working and it times out and then locks me out

  • cdaehn
    cdaehn Posts: 0 Newbie

    I'm having the same issue and this forum only support is for the birds. I want some human somewhere to know that there's a problem as this has been going on for two days now and nobody has fixed it. I'm running the insider builds. Who else?

  • Steveo369
    Steveo369 Posts: 1 ‚ú≠
    edited March 2021

    Similar issues as others have noted. I have a Win10 PC connecting to a Win10 PC, both running the latest version of Teamviewer, and I get disconnected after 30 seconds with the "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your licence. Connections to this partner will be blocked until XX:XX."

    I have used the reset function, now awaiting review of my submitted signature PDF form.

    It does appear that a connection from my Windows 7 PC to my Win10 PC doesn't run into the same limits. Very frustrating.

    ***UPDATE - TV reset my account, approximately 10 hours after completing the request form and uploading. All is working now. Thanks!

    While I acknowledge the frustration that others on this thread have about getting locked out and having to reset your account, I suggest that you just go through the reset process, and include the TV ID's of ALL the machines you use. Yes, it's a minor inconvenience, but remember, this program is FREE. TV has policies and controls to confirm private vs commercial usage, and while it's inconvenient, it is still one of the better remote access options around (IMO).***

  • TuscPhil
    TuscPhil Posts: 1 ‚ú≠

    I keep getting a message "Your Teamviewer has timed out and will be closed". This started in the last week. I've tried reinstalling but nothing works

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    Like a lot of us this your first time on this forum because TEAM VIEWER is locking us out. At this point all you can do is request a reset Sry it won't let me post link  I have no idea if it will work, they say it might take one or two business days to resolve . Good luck

  • I use TeamViewer for personal use. Apply for lifting the ban.

  • rerny99
    rerny99 Posts: 1 ‚ú≠
    edited March 2021

    Hi, I have my account **Information removed as per Community Guidelines** tagged as business but is a personal computer please help.

  • soter947
    soter947 Posts: 0 Newbie
    edited March 2021

    Dear Teamviewer

    I am a member of yours as SOTER947 and again when I log in it tells me that my session has expired and does not allow me to connect with my friend in private mode and not for COMMERCIAL USE. in the past I have already had this problem and you have kindly solved it. I ask you to verify precisely that my connection is not CONTINUOUS OR DAILY OVER TIME and is indeed private and not COMMERCIAL. Thanks in advance for your intervention to resolve the problem and best regards

  • soter947
    soter947 Posts: 0 Newbie

    Dear Teamviewer

    I am a member of yours as SOTER947 and again when I log in it tells me that my session has expired and does not allow me to connect with my friend in private mode and not for COMMERCIAL USE. in the past I have already had this problem and you have kindly solved it. I ask you to verify precisely that my connection is not CONTINUOUS OR DAILY OVER TIME and is indeed private and not COMMERCIAL. Thanks in advance for your intervention to resolve the problem and best regards

  • Jmauperin
    Jmauperin Posts: 0 Newbie

    Hi everyone,

    I'm using Teamviewer only for family service but suddenly I'm detected as a Business utilisation. Which it is not.

    How can I solve this ?

  • martinu
    martinu Posts: 2 ✭✭

    I wish I knew what I could do to prevent my PC support for my parents being detected as commercial usage. I've filled in several declarations over the past few years after getting more informative "Commercial usage detected" messages. This time I get kicked off after about 1 minute, then told that I'm blocked until (present time)+2 mins, but when I try after that time, I get the same message with a new time - and so on until I eventually get in for 1 minute.

    TV used to be an excellent product, but the commercial-usage algorithm is generating far too many false-positive detections.

    I haven't a clue what I'm doing "wrong" which falsely gets me accused of commercial access. Each time I fill in a declaration I get a standard response and service is restored (eventually) but they never reply to my question "why is this still happening".

  • nnanna
    nnanna Posts: 0
    edited March 2021

    I have a problem because it constantly throws me out when connected. I am using a learning app. tell me how to fix it?

  • Using a free account for private use supporting 1 computer. Both computers are apple Macs.

    Connections are timing out after only a short time, for example just connected and tried to change sound preference on remote, selected setting but connection timed out before I could even select sound.

  • BB63876
    BB63876 Posts: 2 ✭✭

    FWIW I went through the reset process (the suggested fix in this thread) despite NOT getting a 'commercial use detected' prompt, and the problem persists.

    Resetting ID(s) did NOT resolve the issue for me.

  • Jeffbx
    Jeffbx Posts: 1 ‚ú≠

    Ugh same - I've been using TeamViewer for years since I'm the designated tech support for my family. I filled out the "I promise I'm not using this for commercial use" waiver and things were fine for about 18 months, but now I'm getting kicked out after about 1 minute of connection time. Do I have to fill out the form again? Has anyone had success with doing that?

  • Ski
    Ski Posts: 2 ‚ú≠

    Good Day

    Hope you all are well

    I always used my TeamViewer to connect to my personal laptop at home and All the sudden

    its telling me the following.

    Commercial Use

    Commercial Use Detected

    This software seems to be used in commercial environments. Please that the the free version may only be used for personal use.

    Please help what stands me to do to fix this.

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    Well just got a confirmation that my ID was reset, It didn't resolve the problem. I will try to submit one for my 90 year old father in-law which i don't know if that is possible to submit for second party .

  • Alcove
    Alcove Posts: 13 ✭✭

    After some years (overall), for the past two weeks, I have been unable to connect using TeamViewer.

    When I do so, I get this message after just 30s of staying connected.

    "Your TeamViewer session has timed out and will be closed."

    "Connection blocked after timeout.

    Your license limits the maximum duration to a partner, immediate reconnects are blocked. Please try later of upgrade your license.

    Connections to this partner will be blocked until XX:XX."

    This is not what I am understanding.

    • These are free licenses for personal use. All computers this is installed on are on personal systems at personal residences.
    • All the GUIs say "free license (non-commercial use only)."
    • The computer I access the most is my second system next to me, where I have no room on my desk for two keyboards and mice. I been using TV on this system daily for ages, until two weeks ago.
    • The program (and my user account) is installed on three children computers in the next town, accessed when needed.
    • The program (and account) is installed on mother's system in another state, accessed when needed.
    • All programs have been updated to recent version.

    I am the main one to connect into my second system, or others when needed. No one else connects to me or one another. (I am the family tech). I have also tried connecting into this main system of mine from my secondary, same failure.

    I have tried to find a way to email customer support, but their "contact us" and their "submit a ticket" options keep taking me back to user forums and community stuff. Places where non-employees of the company are. So, am I am posting. Most suggesstions I have seen were un/reinstalling but not worked, and to submit a ticket which as I stated, is fruitless.

    Everything I have is showing I am using all this for personal reasons, but the program thinks I have some licensing issue going on.

    Does anyone have a solution on what to be done to solve this?

    Thank you kindly.

  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    It didn't work for me. Received a conformation email that it had been reset ,It did not resolve issue. I have submitted a reset for my 90 year old father in-law, but have my doubts that it will resolve issue :( good luck with yours

  • cobrajet
    cobrajet Posts: 1 Newbie

    I have been successfully using the non commercial version of teamviewer to connect from my home PC to my friends home PC for some time now. Starting this morning, I successfully connected but after about 1 minute the connection was dropped. I cannot remember the exact failure message I got, but I have tried several more times and after entering my partners password, I get connected (as usual) but then disconnected, just like before. Said something about "immediate reconnects not allowed will reset at 930am" . So, I waited till 931 am and tried again and the failure repeated. My partner is also a non commercial user.

  • mgavin1027
    mgavin1027 Posts: 1 ‚ú≠

    My free version of Teamviewer times out after a minute , how do I fix this ?

  • scotthep
    scotthep Posts: 5 ✭✭

    Me too!! This has been happening for days. Anytime I try to connect from either computer in the house. Using for a file transfer 90% of the time. HELP, please.

  • Chappy6975
    Chappy6975 Posts: 0 Newbie
  • scotthep
    scotthep Posts: 5 ✭✭

    I have same problem between computers within my house - totally non commercial use. Just file transfer / backup. Is this a bug or a blocking of free personal use? Been trying for a couple of days now.

  • LeeInFlorida
    LeeInFlorida Posts: 0 Newbie

    Same here. Just using for other PCs in my own home.