link icon
Ask The Community

Commercial use - Connection time out



  • markdmoss
    markdmoss Posts: 3 ✭✭

    I've been using TeamViewer to help family members (primarily with my mom) for several years. I don't need it often, so I'm not entirely sure when or how this started.

    Trying to connect from my home (PC) computer to my mom's (iMac) has now started connecting for about 1 minute, then disconnecting with a "Session Timeout" and not letting me reconnect ... giving me a pop-up that says I'm not allow simultaneous connections, and that I'm blocked until XX:XX (where the Xes are the exact current time). This is not commercial use, or a particularly recent installation, and I'm definitely not abusing the personal use license. Any clues how to fix this? I realize asking for help from the company for a freebie use license is an exercise in futility.

    Both copies of the software client say they are the most current version and up to date.

  • markdmoss
    markdmoss Posts: 3 ✭✭

    I'm having the exact same issue! I also posted a question. I'll let you know if I get an answer!

  • KJD
    KJD Posts: 0 Newbie


    I use teamviewer free to remotely access a few of my own personal workstations. I have a server that I remotely manage with plex and I use it every day for an hour or so. Suddenly yesterday my teamviewer began to abruptly close out after only 8 seconds with an error message 'Sponsored Session: Inactivity Timeout". It continues to do this when I make any connections at all. I tried several hours of troubleshooting, including reinstalling teamviewer on all devices. Teamviewer has become un-usable!

    I've checked all my settings twice over. Timeout time was set to OFF, but even changing it to 4+hrs has no effect on this. Teamviewer shows green ready to connect. I can connect remotely to my laptop and my server, both will auto terminate after 8 seconds. I have not had 1 successful session in 2 days

    My log files show a few errors:

    G2!! DataTransceiver: UIModel => RemoteScreenDragAndDropUIModel::IsIncomingDndOperationRunning: dndStateClient is null

    G2! JPEG message: Corrupt JPEG data: 8 extraneous bytes before marker 0xe0

    G2!! EmergingUdpConnection[3]::AsyncReceiveHandler receive failed e=10009

    G2!! PLItemPermissions::IsAllowed: ConnectionType unknown!

    G2!! PLConnector::Connect: Connection type not allowed.

    There are more, but these were from the bottom just before everything terminated. Everything should be working fine and I should be able to connect like I have been every other day.. Any help would be appreciated.

  • adamc85
    adamc85 Posts: 1 Newbie

    Hi Support,

    Team viewer is closing immediately after opening with the below message.. the session doesn't even open to display the remote screen before this message comes up.

    I'm currently using a free license since this is for personal use to my home computer.

    "Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnections are blocked. Please try later or upgrade your license.

    Connections to the partner will be blocked until x:xx"

    Please let me know if you need any additional information to assist with this.


  • linuxlore
    linuxlore Posts: 4 ✭✭

    I'm getting this too and it is not to do with commercial use (except possibly as a side issue). I have confirmed my account is permitted and am still getting the problem, so there is a bug somewhere. With no way to contact TeamViewer without a commercial license this seems the only way to raise the issue, but if commercial licenses aren't seeing the problem I guess they have not major incentive to sort it. It is driving me up the wall trying to support family members I can't visit who are non technical. This really doesn't make me want to purchase the software if the time comes that I need it for business use!

  • WillyB
    WillyB Posts: 4 ✭✭

    Hello YooYJ,

    I have been experiencing the same very annoying problem. Did you ever figure out how to fix this issue?

    TeamViewer has worked very well for me for +-1 year then all of sudden this morning, out of nowhere, my connection is blocked and I find it somewhat suspicious that after it kicks me out up pops an Ad to Upgrade to a Business Plan for $699/yr. 🤔

  • I submitted my form to have my access reset to personal use yesterday and had an email today saying it has been reset. I haven't had a chance to try it yet but hoping that it's sorted out now.

  • xorxfon
    xorxfon Posts: 1 Newbie

    I would like to see a one time Non-Commercial payment to unlock the program so our time is not wasted and more importantly the company time is not wasted on someone constantly reseting the free profiles. Just a one time fee that lets TeamViewer know that I use the program on the regular but it is not for commercial use so there would be no monthly charges. Or just charge a monthly non-commercial license fee and watch the customers bleed away.

  • DvilDove
    DvilDove Posts: 1 Newbie

    I use team viewer to help my parents and one friend, yet I keep getting timed out.

    Where can I find the time limits, as well as how much I have used?

    Can anyone explain this to me or do I need to look for another solution?

  • ralnavman
    ralnavman Posts: 5 ✭✭

    I'm getting this for the 2nd time's really infuriating. Especially as I was 'warned' last time I posted the problem. I was contacted by someone (probably support) who apologised for the 'warning' saying it was an error but that I had to complete a form. I duly did that but I didn't get yet it was fixed.

    So I've been using it for about a week and bang, I'm chucked out again!! I've completed the form (AGAIN) but that was 2 days ago and I haven't received any email. It would seem that there is a general issue which they can't fix but it is getting really tiresome, I can't access my personal machines round the house (they don't have monitors etc..).

    And the weekend is approaching.....

  • jfbernard
    jfbernard Posts: 1 Newbie

    Hi to all,

    I'm get timeouts after very short connections, and afterwards I get the error window "Unable to connect" with the message "Connection blocked after timeout" etc.

    The message does NOT say "Commecial use detected" though. Is this the same problem anyways?

    Can you please help?

    Thank you so much!

  • jugdeep
    jugdeep Posts: 1

    I'm getting the same issue too

  • Jami1
    Jami1 Posts: 1 Newbie

    I'm getting the same issue.

    Anyone know how to fix this?

  • larryamay
    larryamay Posts: 2 ✭✭

    I am going to fix it after months of abasing myself in frint of these people, I am going to immediately Un-install, hope it does not screw up my computers and then install one of the other remote desk-tops that will work. Adios Teamviewer after many many years of enjoyment.

    Larry May

  • linuxlore
    linuxlore Posts: 4 ✭✭

    I wouldn't bank on it. I did that about a year ago, and thinking that I had been flagged commercial again with this timeout issue I did it again. I was told that I was already non-commercial a couple of days ago - hence assuming this is something bug related. It also tells me "Connection blocked after timeout", and "Your license limits the maximum duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license". This wouldn't be as bad if the session was longer than about 15 seconds or so, and if the block actually was removed when quoted (which tends to be about a minute later) rather than just getting the same message that indicates I will be unblocked if I want another minute (all be it only for another 15 seconds!).

  • Ninoninixion
    Ninoninixion Posts: 1 Newbie

    having the same issue, connection drops out/ timesout after a few seconds and doesn't let me connect anymore for X amount of minutes (which increases each time i try to reconnect) years i've used this software and got others onto it aswell but this issue can't easily be resolved as i cannot submit a ticket and not much help actually seems to be happening from the looks of this post, i may have to ditch this software and recommend another that actually works as described without such hiccups as this is not the first time i have had issues with the software, such a shame too.

  • sjt3
    sjt3 Posts: 1

    Is this something new, just started the other day. I have been using team viewer for along time, and never had this issue

  • RemoteGradStudent
    RemoteGradStudent Posts: 1
    edited April 2021

    Me too. I've been using Teamviewer every week since March 2020 and I just started getting this issue today (Connection blocked after timeout). Very frustrating! I seem to be able to connect again briefly if I reinstall the app or sometimes when I restart. Was anyone able to find a solution?

    Edit: I realized Teamviewer has been/is working fine on my Windows machine. Seems like this is a Mac issue.

  • Tinbum
    Tinbum Posts: 2 ✭✭

    I don't know why all the messages on timeouts are being merged here as i've followed the instructions to send the PDF and received the acknowledgment but still get the timeout message. The message also says connection will be blocked until xx:xx but you still can't reconnect until a lot later.

    Lets actually have a reply from teamviewer- they must actually realize this is a bug or are they wanting everyone to leave?

  • Hunven
    Hunven Posts: 3 Newbie

    Hello, I'm using the free version of TeamViewer so I can jump into my two home computers while at work. The problem I'm having is all of the sudden, when I get into one of my computers, I have only a minute or so before the session times out. Then it blocks me from getting back into that computer for a few minutes. Is there any way around this?

  • JoshP
    JoshP Posts: 858 Senior Moderator
    Answer ✓

    Hello @Hunven

    Thanks for your post.

    Connections to or from work computers, for any purpose, is considered commercial use.

    This is why the connection is limited. A license would be required to make connections to or from a work computer.

    More information is here:

    Josh P.

    Senior Community Moderator


  • Hunven
    Hunven Posts: 3 Newbie

    Ah ok that makes sense. I'll try connecting from my personal phone then. I don't believe I've had these connection issues through there. It's a bit of a pain to travel through the phone, but I understand the rules that are in place. Thank you for the clarification!

  • imgkc
    imgkc Posts: 6 ✭✭

    I know I like many others are using the free version of TeamViewer. For me it seems as if TeamViewer doesn't care about us. I again like many others have been having connection timeout issues. We've posted in the community forum and are unable to help each other. We need some assistance from the TeamViewer support team but all we hear is nothing.

    How about some help TeamViewer.. If by ignoring us is your way of enticing us to purchase a license guess what, it's not working.

    We want to support your product but you're not doing anything to make us feel welcome. Even chat based support would be welcome.

  • Crosstrax
    Crosstrax Posts: 1 Newbie

    I am having the same issue but it is not a work computer, it is my personal computer and it just started happening. It have received no message that it has been flagged as commercial so what is causing this?

  • Hunven
    Hunven Posts: 3 Newbie

    Are you doing it from work? It looks like those guides state that if you are doing it from a corporate network, it could be flagged as well.

  • redlands
    redlands Posts: 1 Newbie

    I am experiencing the same issue. It started happening out of the blue. I am using the free license version in my home between 3 separate computers. All are on my private home network. I don't have the ability to use a KVM switch due to distance limitation. I have been using the program for probably a year and a half and was not having any issues until the other day when I had logged into the TV program to do an update on my 2nd pc's windows op system. Within a minute the connection timed out and I couldn't get back in for several minutes with that noted message to upgrade to commercial.

    How do I de-flag my account as being commercial?

    Any help would be appreciated!

  • Terrie
    Terrie Posts: 2 ✭✭

    I have a free TeamViewer account for personal use only. For the past several days, I have been able to successfully connect to a partner account (my father's computer), but TeamViewer times me out after less than a minute, with the message, "Your TeamViewer Session has timed out and will be closed." My father and I have attempted to reconnect numerous times over the past several days and have not been able to have sessions lasting beyond a minute. Please advise. Thank you!

  • Tinbum
    Tinbum Posts: 2 ✭✭
    edited April 2021

    Tinbum was warned for this.

    Warning 0 points Message from a moderator. This is NOT a warning, just a note. This topic has already been answered here : You can request the reset for your TeamViewer ID here:

    Thanks and have a great day!

    My post says I have been warned for the post by a moderator and says this has been answered and gives a link to the first page of this topic. I have done that already as I said in my post.

    Please solve this instead of telling me to do something I and many other people have already done that doesn't solve it.

  • Radiotwo
    Radiotwo Posts: 1

    For the last week when I try to use teamviewer I can connect then get this pop up:

    Your teamview session has timed out and will close.

    and drops the link

    Can any one tell me why this is dong this?

    Many thanks


  • mikeyb
    mikeyb Posts: 3 ✭✭

    On logging in 0n 22 April 2021, for no reason at all, TeamViewer logged me out of the account after 1 minute, with the message “Connection blocked after timeout” and “You license limits the maximum session duration to a partner. Immediate reconnects are locked. Please try later or upgrade your licence”. This message repeated every time I logged in.

    On investigation, I discovered that this was due to “suspicion that Teamviewer is being used for commercial purposes”. That is a nonsense! I have been using Teamviewer for personal use almost 2 years and have NEVER had reason to use it for commercial purposes. I only use it for 1 to 2 hours per week on average, and I am a retired person with no commercial Interests whatsoever.

    I chatted with your sales team, who kindly sent me a link to get the account reinstated. I followed the process, completed the form, signed it and pdf’d it. On trying to submit it, the message came back “The form can only be sent in pdf format”. I tried several times, with the same result. The form IS in pdf format, but your system won’t accept it.

    So after going through all of this I still don’t have TeamViewer.

    Please could you resolve the problem, as this has gone on for far too long.