Commercial use - Connection time out



  • Nikitaman
    Nikitaman Posts: 0
    edited May 2021

    Hi guys, my name is Nikita an I’m a it-enthusiast.

    Currently I have a tiny homelab setup and I’m using TeamViewer to connect to some of these machines from time to time. Also, I sometimes use it to help someone from my or my gf’s family with it stuff. Today I’ve got the message that I have reached the maximum duration of connections and that seems to be the way of TeamViewer to say that they think I’m using the software commercially.. Is there any way to reset that or contact them? Opening a ticket is only possible with a premium license…

    Best regards from Germany


  • MisterUnhappy
    MisterUnhappy Posts: 1

    Hello, for some reason my free license has been flagged as "Commercial use"... Even when at most I use it maybe once a month... Business must be great right ? 30 min of connection once every month is enough to make a living...

    Anyway, moving on. I tried following the reset procedure to get that flag off my ID, but I was quite surprised that I need to provide a lot of personnal data as well as my signature... And it is asked of me to print the give document, sign it then scan and send it...

    So a question, what if I don't have a printer/scanner ? Am I locked out of the tool just because of some disfunction in the review process even when I'm not doing any commercial usage ?

  • Connor194
    Connor194 Posts: 1


    I recently got this message on my teamviewer.

    I then filled out the declaration for personal use form.

    I received an email confirming that I was using it for personal use and my block would be lifted.

    It is now a week later and I am still blocked from my account.

    I have attempted to re-submit but I have this window on the reset page.

    Can I have any help with this?


  • dmitriynikitin
    dmitriynikitin Posts: 0
    edited May 2021


    I'm using TeamViever just for personal purposes, however, I can't connect to my home PC. I did connected to a couple of my friends devices to help them, but it was not related to any commercial things.

    Could you please check my ID **Do Not Post TeamViewer IDs** and unblock it?

    Thank you.

    Kind regards,

    Dmitriy Nikitin

  • Skaira
    Skaira Posts: 0

    Please help, it blocks me every time asking for license. I dont use it for commercial purposes


    I am fairly new to using TeamVIewer and recently the app has been timing me out with an error requesting I purchase a corporate license. I am using it personally and have friends who use it for free personally without any issue. Can someone please share how I can reset Teamviewer and start using it again?


    Mark S

  • adaws
    adaws Posts: 2 ✭✭

    Ok so merged usefully perhaps to other people having same problem and what you are supposed to do

    I have successfully filled out PDF forms and sent which say update in 2 days but not a thing since

    From the considerable number of posts not alone and a lost small voice amongst so many so easy to ignore

  • Sekelin4
    Sekelin4 Posts: 1

    I have 27 partners in my list of computers. It is only friends and relativs. Some very old, 90-92 years, others are blind. I help them with Desktops, Laptops, Tablets and Phones.

    I also use Teamviewer in my local network to Raspberry Pi and my wife's Laptop and two Tablets.

    Question 1: What shall I tell my friends?

    Question 2: Why are you blocking my connections in the local network?

  • Predator04
    Predator04 Posts: 1

    I cant find a way to create a ticket. But i logged into my personal account at work and now it only allows me to stay signed into my accounts for 2 minutes before kicking me out.

    We also have a corporate account here but I need to log into personal computer. however it has now effected my account and cant log into my personal ones or friend/family.

  • JPChiarella
    JPChiarella Posts: 1

    Thank you, community, for your help!

    I'm using the Teamviewer non-commercial version (free for home use) to access a desktop computer in my home - while I travel. Been doing so for many months with no problem. Today, I tried to connect and got as far as the Windows login on the target computer and while I was typing in the password - Teamviewer disconnected telling me something about having been connected too long and that it suspected a commercial account (it is not). When I tried to get back in - it said I had to wait until such and such a time. I waited until after the stated time and tried again - it said (again) that I had to wait until such and such a time - I did and it still failed. So, I waited maybe an hour and, tried again. I got connected and got to the Windows login, but was disconnected again before I could even type the password and told that I was disconnected because I had been connected too long! How can I be connected too long when I can't even connect?! Please advise? How do I fix this remotely?

  • Roymarm
    Roymarm Posts: 1

    I have the same problem. Did you fix it?

  • mrbarold
    mrbarold Posts: 2

    Same, I get about five seconds on the site and it's terminated

  • mrbarold
    mrbarold Posts: 2

    Same, I'd love to find a solution

  • pablesdj
    pablesdj Posts: 1

    I've a free license not for commercial use but i'm unable to connect with other people. Always get a wait until xx:xx message to reconnect

  • DDStick
    DDStick Posts: 1

    I have a free license noncommercial account. I connect with a friend to help him with his PC. After approx. 10 minutes I receive a timeout message and am disconnected from his PC. Why is this happening?

    I use version 15.17.7

  • pbouy
    pbouy Posts: 2 ✭✭

    I use the free personal version as I only use it to help family and friends (some who live in another city). Lately, it has started kicking me off after about 1 minute and it tells me my license limits the amount of time I'm allowed to connect. Can't do much in less than a minute.

    Is there some kind of setting I need to look at? Also, I downloaded and installed the 64 bit version today and it does the same thing.



  • v1psme
    v1psme Posts: 0

    I use the app for personal purposes, why does my account have a connection time limit?

  • bradipo
    bradipo Posts: 1

    My name' s Maurizio, " bradipo" as a nick name.

    Sometimes I'm helping few friends with difficulties in the Country where I live (Dominican Republic). I've been using the free version of TeamViewer since a long time, when my father was still alive in Italy, helping him with his pc to staying in contact with me. There are 9 computers in my list, and 4 of them are not connected anymore since a long time...

    Tonight I was using TeamViewer to help my son (musician, living in China) updating his laptop, and getting it a little bit more organized. Unexpectedly, TeamViewer cut out the connection, telling me that I'm using its service as an enterprise and that I have to upgrade the version.

    Is there something I can do to keep on using TeamViewer as before, or this is just the unfair way of the TeamViewer Company, to announce that the non-commercial use license has ended?😏

    Thank you for your answer!

  • Palma_Pedro21
    Palma_Pedro21 Posts: 1

    I have applied to get my ID reactivated after having been mis-classified as a commercial user.

    But nobody ever gets back to me.

    Been a week now and counting.........

    Can anybody give men an update?

  • vanlilith
    vanlilith Posts: 2 ✭✭
    edited May 2021

    Same issue, still waiting for a reply, Support by mail insist with the reset form I've already sent, on my profile is still "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request." 😕

    Moved in a 271 pages discussion, dozen of people with the same problem everyday, doesn't sound good 🤐

  • juliandeber
    juliandeber Posts: 0

    Hi I sent in a request management form about 5 days ago and all it says is under review?

    I really need to be able to connect to get some school work done. When will they review it?

  • dcweather
    dcweather Posts: 10 ✭✭

    Is anybody else having this problem with Team Viewer no longer responding to queries or requests? They have been falsely accusing me of commercial use for some time now and timing me out after 30 seconds and when I query it they just ignore me whereas before I got a reply. I have followed the recommended steps for re-installing and re-setting but still get timed out immediately. Looks like I will have to use anothe software app that does the same.

  • dcweather
    dcweather Posts: 10 ✭✭

    Re. The above - I see I now have a reply - thank you. I will see if it works this time.

  • danco29
    danco29 Posts: 6 ✭✭

    Same problem as others. I get thrown off my friend's computer after about a minute. If I try to get back on I am told that connection is blocked until a time that keeps increasing.

    My licence is shown as a free licence (which is correct). I do NOT get a message saying that commercial use is detected.

    My computer is a Mac running Big Sur 11.3.1. I never had any trouble until recently.

  • anthony3974
    anthony3974 Posts: 2 ✭✭

    i am trying to get my TeamViewer ID reactivated but i can't submit (no errors)

  • Anonimous
    Anonimous Posts: 2 ✭✭

    Nobody resolve the problem with that msg about comercial use detected...i'm waiting from yesterday morning to resolve my problem but no answer,i can not use the app! So someone resolve that isue or we need to find other app to use?

  • Anonimous
    Anonimous Posts: 2 ✭✭

    Why we receive that msg about comercial use and we can not use the app? Why we need to wait so long time to resolve that problem? It more that 24 houres i can not use the app,someone fix this issue or we need to find other app to use?

  • dcweather
    dcweather Posts: 10 ✭✭

    I have the same problem :- does not generate PDF to upload when you click button.

  • anthony3974
    anthony3974 Posts: 2 ✭✭
    edited May 2021

    my generates a PDF and I signed it but it doesn't let me push submit

  • sparella
    sparella Posts: 1

    When I attach my scanned reactivation request pdf, the page says that only pdf files are allowed to be uploaded.