Commercial use - Connection time out



  • Fede15012
    Fede15012 Posts: 4 ✭✭
    me too but only if I try it from the PC, with the smartphone I can use it as long as I want

  • Fede15012
    Fede15012 Posts: 4 ✭✭
    me too but only if I try it from the PC, with the smartphone I can use it as long as I want

  • Fede15012
    Fede15012 Posts: 4 ✭✭
    me too but only if I try it from the PC, with the smartphone I can use it as long as I want

  • bingston
    bingston Posts: 1

    A while back I was suspected of commercial use. I contacted TV and they fixed my account. Shortly after that I began getting disconnected after a short time of using it and get a "Connection blocked after timeout" message. I don't know what's happened, but I can't seem to get it fixed. It's virtually unusable now.

    Can someone please help me with this. I use this to help my family or connect to other computers in my house, and I'm unable to do so at the moment. Thanks in advance

  • Crysty
    Crysty Posts: 4 ✭✭

    Reset management is not working anymore. You can't download the pdf file to be signed.

  • Crysty
    Crysty Posts: 4 ✭✭

    Reset management is not working anymore. You can't download the pdf file to be signed.

    Probably, after a change, Teamview team is overloaded because of too many requests created to solve wrongly categorized commercial use.

  • Crysty
    Crysty Posts: 4 ✭✭

    The reset form is not working in step 2, when you try to download pdf file. Can you check if is an issue?

  • Crysty
    Crysty Posts: 4 ✭✭

    I want to mention that I get an message that I can connect at a specified time, but when I tried it, I got another time and so on. Even I tried after 10 or 15 minutes it's the same.

    Are these bugs created with Teamviewer team will?

  • AwatITWork
    AwatITWork Posts: 1

    Hello everyone,

    Does anyone know how to use TeamViewer for free? They have removed the free version

    I am using 15.19.3

  • Esther
    Esther Posts: 4,052 Former Community Manager

    Hi there,

    TeamViewer free is still available - however, as usual for private use only.

    Please see this blog post for more information:

    Thanks, Esther

    Former Community Manager

  • ahmedsarhan97
    ahmedsarhan97 Posts: 1
    edited June 2021

    Hi, this ID: **Do Not Post TeamViewer IDs** is considered as a commercial use and they blocked it and need a license but in fact this is ID is for personal use so please can you unblock this ID

  • Carol13
    Carol13 Posts: 0

    For the past 2 days TV times out after 5 minutes! I am using the same computers that I have always used.

  • FabioCrema
    FabioCrema Posts: 1
    edited June 2021

    I am user of Teamviewer for a long time, of free version, and only for my personal computers or to fast help a friend for a couple times. Now I can't use the service, it don't open any remote computers connection or shows me the message of 5 minutes and "Commercial Use Detected". What Can I do? I don't have budget neither necessity to sign a payed licence!!

  • Tammy21
    Tammy21 Posts: 1

    TeamViewer says I need commercial licenses. I only use it for personal use. It’s kicking me out. I’m not computer sappy. What do I do?

  • TA2DE
    TA2DE Posts: 1
    edited June 2021

    Reset page takes me back to the info page... How kind of a link is this?

  • spv
    spv Posts: 0
    edited June 2021

    what can I do?

  • timothylangness
    timothylangness Posts: 1

    Same problem here. submitted issue with support form somewhere on the help site and haven't heard anything for a couple of days. very inconvenient at the moment as i am literally all the way across the country for a funeral and trying to connect to and access my home network and home machine.

  • carlyboy
    carlyboy Posts: 1
    edited June 2021

    Hi, with my free Team Viewer, I keep having this message ... My Team Viewer session has end and will be terminated.

    How do I solve this problem ?

    Thkx in advance and have a great day!

  • Heinrich_k
    Heinrich_k Posts: 1

    I have the same problem.

    I occasionally use teamviewer to help my mother or sisters with their systems, but mostly I try to use it to manage an old laptop I use as a print server.

    But for several months now, I get annoyed by all my connections getting cancelled after mere minutes. Sometimes seconds.

    "This was sponsored by - did you enjoy your experience" - well not much of an experience lately.

  • helen261
    helen261 Posts: 1

    I have same problem i was suspended but my account was allegedly reinstated but i can't access it.

  • Organic
    Organic Posts: 0
    edited June 2021

    Remote control access was limited again in a week.

    Please release the access limitation.~

  • zerkms
    zerkms Posts: 1

    It's again that time of year when teamviewer thinks I'm using it commercially.

    While I use it couple times a year to support my and my wife's old parents that live on a different continent.

    It happened once before and somehow I could find how to ask to unblock me easily. But not anymore - 20 minutes are spent to find a direct support link, with no results. Hence I'm here.

    So, how to prove now I'm using it just to support siblings?


  • Donmarsh
    Donmarsh Posts: 1

    Can't download pdf file

  • Kaantje48
    Kaantje48 Posts: 0
    Teamviewer disconnects after 2 minutes on my macbook pro.
    Not on my windows laptop.
    What could be the cause.
    Resetting via does not help.

  • JimJennett
    JimJennett Posts: 1

    I have been using the free version of TeamViewer to connect to my home computer when I am away from home. I am retired, so it is not for commercial use, only personal use. Recently my connection has been timing out after about 30 seconds and I see the reason seems to be because TeamViewer suspects commercial use. I have sent the form to restore my account about ten times. Each time I have received an email from them saying it has been restored but it has not. I am at a dead end. Any help with this will be appreciated. Thank you.

  • AngelB
    AngelB Posts: 1

    Every time I try to remote into a friend or my family's computer for the first time, I'll be successful getting in but after a few seconds I get kicked out of the session, then a window will display the following

    "This was a free session sponsored by Teamviewer sessions are free of charge for personal use. We thank you for playing fair!".

    Then when I try to reestablish another remote session with the same computer, I receive the following

    "Unable to connect" window message "Connection blocked after timeout. You license limits the maximum session duration to a partner. Immediate reconnects are blocked. Please try later or upgrade your license. Connections to this partner will be blocked until 11:42."

    At the top of my teamviewer client application reads:

    Free license (non-commercial use only) - Angel

    Not sure why this is happening to me now. It never happened before. I've uninstalled, downloaded and reinstalled the latest version 15.19.3 (both 32 and 64 bit version) and still the same problem persists.

    Can someone help or advise ASAP? Thanks, really appreciate it.


  • JayLen
    JayLen Posts: 1

    Teamviewer disconnects me after 1-2 mn and its not a network issue even on the same network :


    Your TeamViewer session has timed out and will be closed.


    and then prevents me from reconnecting :


    Connection blocked after timeout

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try latr or upgrade your license.

    Connections to this partner will be blocked until 16:09


    But then at 16:09 it still says the same message till 16:10 and at 16:10 till 16:11 etc till maybe an hour later I can use it again and then get blocked after 1-2 mn again

    I contacted the free license suspected commercial use form and got approved :

    We have successfully reset the TeamViewer ID(s) you submitted via the form provided earlier.

    We acknowledge that you are using TeamViewer for private use only on these devices.

    So how do I get teamviewer to not disconnect me ?

  • hasimotoatumu
    hasimotoatumu Posts: 1

    Teamviewer Connection is disconnected.

    I don't use Teamviewer for commercial use.

    Please research my Teamviewer usage.

  • Deadeye
    Deadeye Posts: 1

    Likewise, I always use it between two computers but because I use my VPN it probably keeps tripping that I am using it commercially when I clearly don't they can research my account and my usage as well please this is frustrating 3rd time that happened to me.

  • jphilippa
    jphilippa Posts: 38 ✭✭

    One remote PC that I have accessed often through the years to offer help to, is now timing me out after 30 secs - and then I am blocked from re-connecting for a period. Another PC, almost as far away, presents NO restrictions. How can I restore unrestricted access to the 'first' mentioned ?