Commercial use - Connection time out



  • Jokkiz
    Jokkiz Posts: 2 ✭✭

    Hello, I really like TeamViewer but I'm a private person that is using it and the auto detection is forcing me to be a company so I cannot control the computers any more. Can you please take away the blockages and let me use this program as a private person?

    Best regards Joacim.

  • Jokkiz
    Jokkiz Posts: 2 ✭✭

    Please help me out.

  • My acc has been suspended becouse it's apparently under suspension for commercial use. I am a student and dont have a business nor a job and the account is rarely used to help my parents so how do l get in touch with team wiever to rectify this as there is only a contact for commercial licences ?

  • Teressa
    Teressa Posts: 2 ✭✭

    I seem to be experiencing the same issue as @CarlZ. From my Windows 10 computer, I am using TeamViewer 15.25.8 to connect to a new Windows 11 computer. Initially, I could connect and control the remote endpoint. All of a sudden I was unable to click on anything in the remote computer and the remote screen stopped refreshing in my TV. I tried removing the default antivirus that came on the new computer (McAfee) and I tried shutting off the Windows 11 firewall in case it was blocking. Neither helped. The only other thing I can think of is that the new Windows 11 computer might have been downloading updates as it was just recently turned on; maybe a Windows 11 update is not compatible and that broke my ability to control the remote computer with TV?

  • imb123
    imb123 Posts: 1
    edited December 2021

    I've not read all the comments above so sorry if this is a duplicate. I've connected from a windows 10 laptop to a windows 11 desktop When I click the start button on the remote desktop computer I don't see the app dialog. There's a hint of a right edge of a window.

    Update: having gone to the trouble of connecting a monitor to the remote desktop (remote is 2m :-)) I can now see the apps dialog when I click on the start button when operating the remote machine from the windows 10 laptop. This rather defeats the object though. I usually use the desktop far from the router and use wi-fi. But, I want to download a particularly large file so brought it down to connect to the router by wire. I hoped to avoid bringing down a monitor, keyboard and mouse.

  • Kerstin_PO
    Kerstin_PO Posts: 78 Staff member 🤠

    Hi @CarlZ , @Teressa ,

    thanks a lot for your feedback and sorry for the inconveniences.

    Could you maybe check the Windows build number that is installed on your Win11 computer? Are you using the Windows Insider Program?

    Thanks a lot for your help.

    Best, Kerstin

    Product Owner TeamViewer Core
  • yasminkorai
    yasminkorai Posts: 1

    @Anwarjutt Wow, thanks - I didn't suspect that my scope of using TV could be admitted as commercial usage. Well, I'll write to their support and will explain the situation. Thanks for that tip!

  • CarlZ
    CarlZ Posts: 3 ✭✭

    Thanks Kerstin. I should have physical access to the remote machine in a couple of days. Not an insider build for sure. It's a brand new Dell machine for Grandpa. My details are almost exactly like @Teressa. Uninstalled the factory shipped McAfee. My first attempt was using TV Host on that machine. Exactly as described by @Teressa "Initially, I could connect and control the remote endpoint. All of a sudden I was unable to click on anything in the remote computer and the remote screen stopped refreshing in my TV." Control lasted less than 10 seconds. I then had them install the full version. No control ever at that point. I can connect & see the screen (black screen though, no wallpaper showing) but that's it. Will update you when I gain physical access.

  • CarlZ
    CarlZ Posts: 3 ✭✭

    Windows 11 Home 21H2 22000.376

    Well, it's working now. Not sure what fixed it though. Updated TeamViewer to latest 15.25.8 version. Didn't work for @Teressa so I doubt that's it. Cleaned out all the Dell crapware (10+ programs). Also found a second McAfee entry & deleted that as well. @Teressa, happen to be working with a new Dell?

  • Teressa
    Teressa Posts: 2 ✭✭

    I am also working with a new Dell, Inspiron 5510. I removed the McAfee Antivirus but I did let the McAfee Webroot program stay. My version is Windows 11 Home, 21H2, OS Build 22000.376. Windows Feature Experience Pack 1000.22000.376.0. Not an Insider build.

    After the first issue occurred, I left it during the next day and tried again after work that night. It was miraculously working. I suspected that a Windows update might have fixed the problem. However, over the next few days as I continued to use TeamViewer to access the remote computer to finish setting it up, I encountered the issue several more times. Usually a reboot of the remote Windows 11 computer would fix it. Once I had to reboot both my Windows 10 computer and the remotely controlled new Windows 11 computer to fix the issue.

    While TeamViewer is more flaky on Windows 11 than it had been on Windows 10, it's still an invaluable tool for helping my mother with her computer issues when we're in different states. Thank you so much!

    @CarlZ If you can recall what other Dell nuisances you removed, I'd welcome the info. Did you remove their My Dell, Support Assist software? Thanks.

  • rmyoung
    rmyoung Posts: 0

    I have read whereTeaviewer access if free to personal computers. I have two residences so i just connect remotely to my other computer from time-to-time. Every connection is time limited it terminates after about 3-5 minutes. Is the personal accounts time restricted?

  • norm1206
    norm1206 Posts: 2 ✭✭

    How do I contact support about getting my account reset as it is being incorrectly identifying my usage as commercial.

    This happened to me about 2 years ago and was reset back then by support but I cannot get support form the same process as I did back then.


  • Amaldidi
    Amaldidi Posts: 1
    edited January 2022
  • @Esther They want you to pay for it. You can argue til you're blue in the face… they may or may not reverse their decision, but there's nothing anyone here can do. Signed, an ex-teamviewer user with the same issue...

  • fmartinn
    fmartinn Posts: 1
    edited January 2022

    Same thing here.

    We are able to connect on PC's with W11. The icons that allows remote control are ON but we can't control mouse neither keyboard.

    Source Team Viewer PC OS version: W10 v. 21H1 ( compile 19043.1415)

    Source Team Viewer version: 15.25.8 (32 bits)

    Source Team Viewer License: Corporate (3 channels)

    Remote Team Viewer PC OS version: W11

    Remote Team Viewer version: Most Recents from December 21 until today.

    I hope I've helped you to find a solution for this.

    Ps.: We are literally installing **Third Party Product** to give support to our clients with W11. This is a very bad situation from the marketing's and sales' perspective. But as i am seeing here, I am not the only one and I know that you are working to fix this.

    Best Regards.

  • Eldesoqi
    Eldesoqi Posts: 1

    I have been flagged as a commercial user around 3 weeks ago and I have submitted the form as requested 2 weeks ago. They told me that they will respond within 5 days. However, I didn't get any reply from their side till now. what should I do ??

  • Eldesoqi
    Eldesoqi Posts: 1

    I have been flagged as a commercial user around 3 weeks ago and I have submitted the form as requested 2 weeks ago. They told me that they will respond within 5 days. However, I didn't get any reply from their side till now. what should I do ??

  • awistrcill
    awistrcill Posts: 2 ✭✭
    edited January 2022

    HELP. CALL ME AT [removed per Community Guidelines] immediately

  • Hello

    I am using the free version of team viewer, my account recently got limited due to suspicion of commercial use, so i went in and filled out a form to regain access to my account. I failed to realize that i had to put in my phone as part of the devices, and cant edit the application.

    what to do?

  • Kerstin_PO
    Kerstin_PO Posts: 78 Staff member 🤠

    Hi @Teressa , @CarlZ , @fmartinn ,

    thanks a lot for all your feedback.

    We will try to reproduce the issue. If we are not successful, we might come back to you with further questions to find and fix the problem.



    Product Owner TeamViewer Core
  • WyattBowser
    WyattBowser Posts: 1 ✭✭


    I used to use TeamViewer last year or the year before for school and I could remain remotely connected indefinitely, now that I am using it again, it keeps disconnecting me because I need a License upgrade.

    Reason I use TeamViewer in school is I have a good pc at home so I just remote into that pc through a little dingy laptop that I use at school (so I don't lose a lot of money in case of theft or breaking the laptop).

    So I was wondering if there is a Student Liscence where it can let me use unattended access indefinitely for one pc.

    Thanks for any answers!

  • Hello,

    wondering if there is any way to stop the team view from timing out?


  • thenufoxx
    thenufoxx Posts: 0

    Very close to finding another remote management solution, I have just been connecting with my tablet and phone and now barred from using any teamviewer connection, with no support, tried twitter, no support no solution...not happy with it, not paying when only light use between a cpuple of personal devices

  • seltzdesign
    seltzdesign Posts: 1

    Just trying out TeamViewer with Windows 11 that I just freshly installed on another machine.

    Things I noticed:

    1 - Taskbar Icons don't seem to be updating. I change the position to center, but icons stay on the left. This happens even if I close the connection and reopen.

    2 - the windows menu is shifted and not fully visible if I have taskbar buttons on the left3

    3 - I cant scroll inside settings windows. Or rather I can see the vertical bar on the right go up and down, but not the contents of the settings menu.

    Everything else works fine, it just seems to be around the taskbar, home menu and settings that things are not updating.

    Using latest version of TeamViewer. Connecting from a Win10 PC to a Win11 PC.

  • TheBlakey
    TheBlakey Posts: 5 ✭✭

    I have been trying to get my free account reset for a couple of months now, I fill in the form with the details and it all seems to go through but I have no response. I get the message that it takes 5 days to process but nothings seems to happen after that time. How can I convince TV that I am not using as commercial ( Just my PC and several laptops ) ??

  • killachris
    killachris Posts: 1
    edited January 2022

    hi i have a server that i have my files on and use it for personal use not for bussiness i stor photos videos and persnal stuff on it and now i can not access my server cause my account is blocked cause i conect to it to muchany help i cant find any help on there web site or [removed per Community Guidelines] please help me

  • TumainiTiger
    TumainiTiger Posts: 1
    edited January 2022

    I connect to my father's pc sometimes (1/2 times a week) so I'm not using it for any commercial use. Today I got an error saying the app thinks I'm using it for commercial purposes but I'm not.

    Is there a way to unblock my account? I don't want to pay to help family out with their pc or share my screen with them...

  • joshss7
    joshss7 Posts: 1

    What a joke. I'm getting the same commercial use error. It's really frustrating when you're at your work PC and try to connect to your work PC to let family members know your phone has no battery. I'm not signed into Telegram or WhatsApp Web on my work PC and usually remote to my home PC if I ever need to do so.

    Thanks TeamViewer for your planned sabotage into getting premium licenses from free users.

    Looking for an alternative, and I'm not buying a Man Untied kit till you stop sponsoring them.

  • EdwardUK
    EdwardUK Posts: 47 ✭✭

    Whilst some valid criticism can be directed towards TeamViewer in the way they have handled things I think it is perfectly legitimate that they clamp down on people using their software in a work environment using their free tier. TeamViewer makes it very clear in their literature that the free tier is not available in work environments.

  • Nicholls
    Nicholls Posts: 0
    edited January 2022

    [removed per Community Guidelines]

    I can't use TeamViewer anymore as it's unreliable in flagging me as a business user when I need it the most, like going on holiday and then barred from accessing my own machine. This has happened to me so many times now over the last 7 years that I would be a fool to continue using an unreliable app that can fail at any given moment (by design). It's basically ransomware.

    [removed per Community Guidelines]