Commercial use - Connection time out



  • JaseHeuer
    JaseHeuer Posts: 1 ✭✭

    When I connect to any of my computers I get kicked off then I cannot log back on for several minuets. This is connecting from one of my personal computers in my home to another in my home.

  • porcupine
    porcupine Posts: 6 ✭✭

    I've been using Teamviewer for non commercial use. Mostly I use it to help my mom who lives on the other side of town. She is non technical, but I've helped a sister in law and also a friend out in the boonies in Arizona. But 99% of my usage is to help mom. I'm always using Teamviewer from home to connect to her at her home, so we're not talking about lots of IP addresses here.

    Now Teamviewer Corp has locked me out saying they think I'm using it for commercial purposes. What was my offense? I tried using Teamviewer on my Mac instead of my usual Linux Mint system.

    So what gives? Does Teamviewer not want computer enthusiasts as part of their community? Is it not in their realm of possibilities that a user might run something other than one operating system in their home? Guess what? I've also got a Windows box, and a different Linux laptop. Woo woo big woopie. I guess the Teamviewer algorithm thinks I'm running a data center.

    Have I no recourse? A friend suggested I set something called Tailscale up on my mom's PC, but I'd prefer using Teamviewer because she is not technical, its easy for her to use, and depends on me to help her on her PC ALL THE TIME. Teamviewer has been great, but now not so much. It would be great if I could get someone at Teamviewer to study my pattern of use and determine that I in fact am not a commercial user. It would be easy to see if a humanoid would look at my logs. Are we doomed in life to be forever governed by fallible algorithms?

  • RoninBonita
    RoninBonita Posts: 3 ✭✭
    Answer ✓

    No, you are not done, Porcupine. I've had the same issue for the same reason. As you do, I use Teamviewer to help friends and neighbors with technical issues they would otherwise have to wait and spend to get resolved, and mostly they are simple issues. Go to this link and follow the directions to get your FREE Teamviewer usage reinstated. It will take a day or so turnaround.

  • Mechanis789
    Mechanis789 Posts: 5 ✭✭
    edited March 26

    I just started having the same problem today as well!

    Hoping the team at TeamViewer can help get this sorted out for all of us! I use TeamViewer only for personal use, to connect to home media servers and to help my mom who lives in another city!

  • Mechanis789
    Mechanis789 Posts: 5 ✭✭

    Same issue here, my license no longer works for some reason as of today. Times out after one minute.

    Not sure if exact same message for you, but for me, it's the exact same issue as you can see a screenshot of in this other post:

  • 7278608
    7278608 Posts: 2 ✭✭

    Hey He keeps telling me that there is a problem with personal use, and I don't care. Why does he keep suspecting me? How do I fix the problem?

  • Jokerunited
    Jokerunited Posts: 2 Newbie

    I don't know why, my account is detected as "Comercial Use" when I am just connected to my brother pc for a fix a Sunday night..... 😅

    What can I do?

    Thank you.

  • davmax
    davmax Posts: 14 ✭✭

    I have been a free Teamviewer user for over a decade supporting family and friends in their 70s & 80s, plus an aboriginal community group to whom I donate my time. I am in my 88th year. Over the years I have been terminated a number of times because I help too many people, suspected of profiting. No, I do not charge for my help of the elderly. Previously I have had the ability to have the Teamviewer help sessions restored. Access to support is generally denied, only for paid licenses. I notice standard membership is unviable in that it appears that there is a limit on those supported/helped, limited to 3. Additionally, it is not viable for me to pay the monthly fee for donated time.

    I am seeking to enable my ability to help others restored, again.

  • Hellcat
    Hellcat Posts: 1 Newbie

    i am trying to get a non-commercial reset on my free account. The form says to "generate and upload pdf" which i click but i dont get confirmation it has been send?? could it be the "add more ID"? i have only one ID, why does it keep asking for more (red lined box)... unless i fill that, it wont send...

  • ucarov
    ucarov Posts: 1

    I'm using TeamViewer for personal purposes "Free account" for many years . 

    I access my pc's at my home and my frends. 

    nowadays i am trying ro found best OS to my oldest laptop and i try many OS vith teamviewer.

    Suddenly I get flaged for comercial use.

    I had this problem years ago, but I don't remember the solution.

    Can you help me with the solution?


  • JustJames
    JustJames Posts: 1 Newbie


    I tested a Team Viewer trial for commercial use years ago, customising it with logo etc. But found we didn't really have the use for.

    I now only use it to help friends and family in need, all done free of charge. However, the QuickSupport module seems to only give me 5 minutes. I get a notice saying something about "due to logo", but no logo is used anymore. It's just the default Team Viewer Quick Support module.

    How do i remove the 5 minute time limit?


  • Speed1
    Speed1 Posts: 2 ✭✭

    Normally everything works fine connecting to my desktop from my iPad. however this weekend i'm getting a error that disconnects me after about 30 seconds of being connected to my desktop.

    the error on the iPad is this

    Unable to connect

    A connection could not be established

    Connection blocked.

    you reached the maximum session duration to this teamviewer ID please try again later.

    Connectios to this teamviewer ID will be blocked until X time

    (there is a more info button)

    when i click on it, it's telling me i should upgrade my license.

    i'm connecting to a windows 10 system. no servers

  • mandaj
    mandaj Posts: 1 Newbie
    edited March 27

    How can I get back to using the free version. I have not shared anything.

  • BBIzabich
    BBIzabich Posts: 1 Newbie

    I'm trying to use TV to connect to my dad's computer and I am able to connect but after about 15-20 seconds it disconnects me claiming I timed out. If I try to reconnect it tells me that immediate reconnect is disabled and to try gain after a minute. I am using the free version but I am not getting a message saying I was flagged for commercial use or anything like that. If I wait a few minutes and try again I can connect no problem, but the same thing will happen. After about 15 seconds it says I timed out and can't immediately reconnect.

  • davmax
    davmax Posts: 14 ✭✭

    I filled in the form using the ID number listed in my Teamviewer app. The reset form will not process because that ID is refused and a valid number is requested. Sorry I have no idea how to obtain any other valid number.

  • davmax
    davmax Posts: 14 ✭✭
    edited March 28

    To assist the my ID displayed in Teamviewer is [Removed as Community Guidelines] hope this helps.

  • davmax
    davmax Posts: 14 ✭✭

    I saw a note that I was warned. When and how? I am not aware of any warning; I was simply terminated.

    I have completed an account reset, following helpful assistance via Teamviewer. What happens next?

  • mike1111
    mike1111 Posts: 1 ✭✭

    Hi. I am using quick support with a friend. I helped he download the latest version of TeamViewerQS on her Win10 PC. When we start a session (she trying to share her screen with me), I get the error shown below. She had the full version installed previously, but I uninstalled that. How can we resolve this? Thanks.

  • camyferraz85
    camyferraz85 Posts: 1 Newbie

    I would like to report the difficulty in accessing a computer at the university. I can only connect for a few seconds because there is apparently a problem with my license. I use the program to access a computer to collect some data at Federal University of Rio de Janeiro, for research only. I am a Professor trying to do some GC analysis. I appreciate Teamviewer team for the comprehension to solve this issue.

  • yiersanmutouren
    yiersanmutouren Posts: 1 Newbie

    Hi. I have a computer in my dorm in college and now I am home. I used to have access to my computer through teamviewer, but recently it started to show "there is a problem with the license" and immediately disconnects my connection. I am wondering what I could do with this?

  • Andrew736278
    Andrew736278 Posts: 2 Newbie


    I've been operating a free license for a while now and have just been restricted based on some pattern.

    I'm in IT and my home/lab setup is pretty complex and could well look commercial but its simply not.

    Is there anyway to sort this out so I can keep using it?

    The product is good and something I have been recommending in my professional life.



  • Andrew736278
    Andrew736278 Posts: 2 Newbie

    Have submitted the form required - fingers crossed :)

  • ray4nier
    ray4nier Posts: 3 ✭✭

    Usage pattern suggests you've been supporting others professionally. Vehemently disagree!

    Pls advise

  • astrohart343
    astrohart343 Posts: 2 Newbie
    edited March 29


    My name is Brian [Removed as Community Guidelines], and I have a TeamViewer account under this email address: [Removed as Community Guidelines].  It's the same email address that I am writing to you from today.

    I am getting an error when I attempt to use the computers on my Contacts list. The error message says, "We apologize for the interruption. It looks as if you're trying to support others professionally, and we can't allow this. Your usage of TeamViewer is being blocked."

    That's not so! I'm an astrophysicist, and I have multiple personal computers at multiple locations. Right now, I am at the coffee shop and I am trying to access the computer in my lab. But it is not letting me.

    Can you fix my account please? I am only using TeamViewer for personal use. Thank you.

    (P.S. The second picture shows a message that appears when I connect to one of my remote computers and then it disconnects after, like, 30 seconds, saying that my session has "timed out," and then it says connections to the partner will be blocked until 20:58.

    What rubbish! You know, times are hard and people are trying to pay rent and buy food and you're grubbing license money from free users.




  • Tdpbrian
    Tdpbrian Posts: 1 Newbie

    I am a teacher at a small nonprofit school for troubled teens that is a kind of juvenile detention so kids need to be closely monitored when on computers. I looked at professional licenses but they all seemed geared towards IT work, so I started using as personal use just to monitor, usually between 3 and 7 computers only at a time ( it's a small school with less than about 15 students so we'd never be using more than that ).

    I got a pop-up for 'suspected professional use' so my question is, does this use case require a professional license? The school is a small nonprofit and the administration is more likely to just not let kids use computers at all in class than to pay for a license I think, so I am hoping this is fine-- the purpose really is to just have one screen where kids' screens can be seen while they do school work. Please advise. Thanks!

  • 66590
    66590 Posts: 1
    edited March 29

    I am trying to connect to a pc i just bought. I have 3 laptops and 5 PCs that I work on with my wife including the one at my office. I tried to setup REMOTE CONTROL with the new PC and messed up on setting it up. Now my viewer says i have too many connections. How do I correct this?


  • DavidianX
    DavidianX Posts: 1 Newbie

    This just randomly happened to me. I mainly use it to connect from my older laptop to my PC to update my blog or play around with power automate and then out of the blue... it's telling my I am a commercial user...

  • CJustin
    CJustin Posts: 1 Newbie
    edited March 30

    I have no idea why this message pop up. I'm a college student using this to do my research on lab's windows computer, and this message popup. Then, they block me from access and force me to by their product. How should I solve this? :( Or are there any similar software I can use? I don't know how to ssh windows computers...

  • leewalters
    leewalters Posts: 1 Newbie
    edited March 30

    I am trying to connect to my other computer in my house but times out immediately

  • 이동호
    이동호 Posts: 3 Newbie
    edited March 30

    I use it for personal use at home, but teamviewer alerts commercial use suspected.