Catalina Remote screen frozen

I have been using Team viewer from my macbook pro to access my mac back in the UK. I am currently 2000 miles away.

It has worked well for 3 weeks and I have rebooted the remote several times and even switched remote users. Recently this has all stopped working and it looks to me as if teamviewer has crashed at the remote end. The remote screen comes up and there is a box that says the session was free and thank you for playing fair - there are three option buttons - option 3 "OK" is highlighted but I cant click it - I cant get any of the menu options to respond either. I have tried sending a force quit to the remote through the loccal teamviewer options but nothing happens.

I have killed the session and tried from a different device - my iPhone and I see the same unresponsive screen. infact i can take control from iphone and macbook at the same time and both get the same froxen screen - i would expect one to be declined when another takes control. 

How can i get the remote working again without flying home to restart it?

Perhaps there should be a local option to forc e a restart of the remote machine.

Comments

  • JeanK
    JeanK Posts: 6,959 Community Manager 🌍

    Hello @KevReid

    Thank you for your message.

    With the Catalina update, you need to allow TeamViewer in the device settings. ?

    You will find all the information you need in our Knowledge Base article here: How to control a Mac running macOS 10.14 or higher

    I hope this could help. If not, do not hesitate to ask your questions here. ✌

    Cheers,

    Jean

    Community Manager

  • GeoffWiddowson
    GeoffWiddowson Posts: 2 ✭✭

    Hi,

    I have started to see that on Mac's with Teamviewer 15.2.2756, control is lost, not just on Catalina but on Mojave. I have tried the official support guide

    https://community.teamviewer.com/t5/Knowledge-Base/How-to-control-a-Mac-running-macOS-10-14-or-higher/ta-p/44699

    to grant access in Security and Privacy, which used to work but of late is very hit and miss, mostly miss now. If I uninstall and put on older version of TV like version 12, I can control the mac again, but as soon as I update it I lose control. This has become very frustrating in the last few weeks as I am not able to support my users. I’m stuck with Macs now that I cannot control even after granting rights in Privacy Accessibly, Full Disk Access, Screen Recording.

    Regards

    Geoff Widdowson

  • GeoffWiddowson
    GeoffWiddowson Posts: 2 ✭✭

    Hi have discovered the issue was down to Jamf managed PPPC configuration. Starts working once the existing, presumable now outdated settings were turned off, for an affceted device. Will need to create a new payload to deploy with Jamf.