link icon
Ask The Community

QuickSupport no more working since Android 10 on Huawei

Yesterday we got the Android 10 update on our HUAWEI P smart 2019 devices, since this we can not remote support with QuickSupport, after connecting to the device only a Blue-Hand apears and the message "Das Gerät kann aufgrund von Firmware Einschränkungen nicht gesteuert werden." (The device can’t be controlled because of firmware limitations).

We also updated to latest QuickSupport and Huawei Addon (b) App, but same Problem.

Please fix it, beacause we can not support more then 4000 devices now...


Best Answer



  • We have same Problem with P30 Lite and Nova 5T, any solutions? 

  • Same here with P30 Lite, we can't manage over 200 Phones now...please fix it ASAP


    Thank you


  • Esther
    Esther Posts: 4,112 Former Community Manager

    HI @BJeankins and @StefanTrebo 

    Thanks for reaching out to us.

    I checked with our Product Owner for the Mobile part and he informed me that we are already working together with Huawei on getting a new, working AddOn online asap. The root cause is a change in the signature.

    I hope this gets resolved quickly! However - I do not have an ETA right now.

    Thanks and sorry for the hassle!



    Former Community Manager

  • Sandrokan80
    Sandrokan80 Posts: 4 ✭✭

    Good day,

    do you have any news on it?

    I need to use remote controlling on Huawei P Smart 2019 with Android 10 but I just can see the screen without any possibility to control the device.

    Thanks for your quick reply.

  • Sandrokan80
    Sandrokan80 Posts: 4 ✭✭

    Good morning, any update please?

  • Gypons
    Gypons Posts: 1

    Dea @Esther any update here?

    Still no solution found? 

  • Sandrokan80
    Sandrokan80 Posts: 4 ✭✭

    Good day @Esther ,

    we are still waiting for Community Manager's update on it.

    Please take care of our questions.


  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi guys,

    sorry still no update!

    Former Community Manager

  • Dornford
    Dornford Posts: 3 ✭✭

    Just to let you know there are a lot of people waiting for the update. Very disappointing to do an update (to Android 10) and lose functionality.

    Now not working on my Huawei P30 Pro.

    Any news on an update?



  • EranS
    EranS Posts: 1


    As I was trying to conect and take control over Huawei Y9 Android 10 all I could do is to see the device's screen yet no action is available .

    Although I downloaded the adds-on (a+b) and the Host app yet nothing seems to be working 

    Could you please advise what would be the proposed solution?

    Thank you 

  • PhilippeS
    PhilippeS Posts: 2

    Hello, any news on this ? 

    Very disappointing to wait so long for an update and not be able to use Teamviewer !

  • B_H
    B_H Posts: 1


    Huawei P SMART 2019 smartphone received android 10 update 3 months ago.

    Ever since the update, our teamviewer quick support is not working properly for all of our mobile phones. In our environment, quick support is necessary for our work to get done. 

    When can we expect an updated add on for this product? @Esther 

  • GTC-Michael
    GTC-Michael Posts: 2 ✭✭

    Hi @Esther ,

    Can you please update us on this topic? I have the same on a Samsung with Android 10, so it's caused by the Android version and not the manufacturer.

    Thanks and best regards,

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi all,

    I am in contact with the mobile team and hope to give you an update next week.

    Thanks for your patience,


    Former Community Manager

  • Buzzydude
    Buzzydude Posts: 2

    Please let us now soon!

  • PhilippeS
    PhilippeS Posts: 2

    Dear @Esther 

    are there any news on this topic ?



  • Esther
    Esther Posts: 4,112 Former Community Manager

    HI @PhilippeS 

    Still waiting for a reply from the team and I will update you as soon as I hear something ?

    Former Community Manager

  • Buzzydude
    Buzzydude Posts: 2

    Hi. I have a similar problem:

    Huawei P Smart 2019 with Android Enterprise, managed with Citrix EMM (Secure Hub):

    - Android 9: no problem with Teamviewer remote control

    -Android 10 COPE (with a personal and an work profile): remote view works with the personal apps, black screen on the work-apps. 

    Maybe this can help your team to find a solution soon.

  • RAE1
    RAE1 Posts: 1

    QuickSupport not working on Alcatel 1S (Android 10).  Viewing only with blue hand.  A problem with Android 10?

  • jhanzuro
    jhanzuro Posts: 1

    Hi, just to share, Samsung A207m + Android 10 + QuickSupport is not working now. A week ago it was working without problems (I'm not sure, but I think that it was before any update, maybe Android 9 to 10). Firstly I tried to remote my Android but it rejected connection always, then I tried to allow all of the requested permissions and I was able to share the screen only, not to controlled it.

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi all,

    I did not forget you, but unfortunately, I still have no news to share! I am sorry about that!!

    I will again follow up with the mobile team again next week to check on the current status regarding the signature.

    I wish you all a fantastic weekend,


    Former Community Manager

  • Any news?

  • p_p
    p_p Posts: 3 ✭✭

    I found clipboard sharing works fine. It helps me a lot to support my parents.

  • Thanks Quicksupport is working. I hope you will extend the same ability to Host app soon

  • janna_s
    janna_s Posts: 1

    I had the same issue :after upgrading a Samsung Galaxy Tab A (SM-T290) from Android 9 ot Android 10, when trying to control it via TeamViewer Host, I see a blue hand icon that suggests where the user should click but can't actually click any buttons. After installing the version of TeamViewer QuickSupport mentioned here and enabling the universal plugin as prompted, I can see that controlling the tablet now works through QuickSupport.

    Are there any plans to apply ths same fix ot TeamViewer Host?

  • Craig89
    Craig89 Posts: 1

    We had success allowing QS to always appear on top in app permissions.

    We currently operate on SM-T515 which have started updating to android 10 and the above allows us to operate as before on QS.

  • It doesn't work on my Huawei P20 with Android 10, I installed QS and Universal Add-on but when I try to control it from another Android device or Mac, I can only see blue pointer on the screen but no interaction is available.

    Please can you help me? Thank you

  • p_p
    p_p Posts: 3 ✭✭

    When I installed "TeamViewer Universal Add-On", I had to give the add-on authority in setting menu and then I could control the Android 10 device.  However when I tried next time, I could not control and blue hand pointer did not show.  Then I tried once off the authority switch and turned on again, I could control again.  Anyone faces the same situation?

  • whith android 10 don't working. i can only see the screen but don't use the remote controll